All material is Copyright © 2008-2012 Smartware Technologies. All rights reserved.

WorkPlace Pro is a trademark of Tridium, Incorporated. Microsoft is a registered trademark and Visio is a trademark of Microsoft Corporation. TAC, Invensys and I/A Series are registered trademarks of Schneider Electric. Designer Suite and Smartware Studio are trademarks of Smartware Technologies.
# Table of Contents

1. **INTRODUCTION / ABOUT THIS GUIDE ................................................................. 7**
   - Introducing Studio360 powered by Smartware Studio ........................................... 7
   - What Does “powered by Smartware Studio” Mean? ............................................... 8
   - Where Do I Start? ........................................................................................................ 8
   - About This Guide ....................................................................................................... 10
   - Other Guides .............................................................................................................. 10
   - Installing and Administering Smartware Studio ......................................................... 10
   - Using the Estimating Module .................................................................................. 10
   - Using the Designer Module (Design360) ................................................................. 10
   - To Learn More about Smartware Studio ............................................................... 10
   - To Contact Us .......................................................................................................... 10

2. **SMARTWARE STUDIO PROJECTS ................................................................. 11**
   - Types of Projects ....................................................................................................... 11
   - What is Stored in a Project? ..................................................................................... 12
     - The Project View .................................................................................................. 13
     - The Network View ............................................................................................... 13
   - Local and Server Projects ......................................................................................... 14
     - Creating a New Local Project ............................................................................. 14
     - Moving a Local Project to the Server ............................................................... 14
   - Working with Server Projects .................................................................................. 15
     - Opening a Server Project .................................................................................. 15
     - Checking Out a Project ..................................................................................... 16
     - Closing a Project ................................................................................................ 17
   - Other Project Tasks .................................................................................................. 18
     - Exporting Folders and Files ........................................................................................ 18
     - Importing Folders and Files .................................................................................. 19
     - Duplicating Projects .............................................................................................. 19
     - Deleting Projects .................................................................................................. 20
   - New Project Templates .............................................................................................. 20
     - Creating a New Project Template ........................................................................ 21
     - Using a New Project Template when Creating a New Project ....................... 21
   - Organizing Server Projects ...................................................................................... 22
     - Embedding Projects in a Customer Site or Job ...................................................... 22
     - Project Shortcuts .................................................................................................. 22
     - Extracting Embedded Projects to Stand-Alone Projects .................................. 25
   - Server Project Groups .............................................................................................. 26
     - Creating and Editing Project Groups ..................................................................... 26
     - Assigning Projects to Groups ............................................................................... 28
     - Browsing for Projects in Groups .......................................................................... 29
3. **WORKING WITH FOLDERS AND VIEW ITEMS**................................................................. 31
   - *Property Tabs for Items* .................................................................................................... 32
   - *Building the Project View Tree* .................................................................................... 32
   - *Checking Out a Project* .................................................................................................. 33
   - *Adding Items to the Project View Tree* ................................................................. 33
   - *Selecting Folders* ........................................................................................................... 33
   - *Moving and Reordering Folders* .................................................................................. 34
   - *Copying and Duplicating Folders* ............................................................................... 34
   - *Renaming Folders* ......................................................................................................... 35
   - *Deleting Folders* ............................................................................................................ 36
   - *Restoring Deleted Items* ............................................................................................. 36
   - *Importing Folders and Files from Windows* ............................................................. 38
   - *Exporting Folders and Files to Windows* ................................................................... 38
   - *Using a Folder with Other Windows Applications* .................................................... 38

4. **WORKING WITH FILES**................................................................................................. 41
   - *The Files Tab* .............................................................................................................. 41
     - *Adding Existing Files to a Folder* ............................................................................ 41
     - *Moving Files between Folders* ............................................................................... 42
     - *Copying Files back to Windows* ............................................................................ 42
     - *Creating New Files from Blank Templates* ............................................................ 42
     - *Adding Descriptions and Comments to a File* ..................................................... 43
     - *Adding Shortcuts to a File or Web Sites to a Folder* ............................................. 43
   - *How Files are Stored Locally and On the Server (Synch Status)* .......................... 43
   - *The File Synch Status* ................................................................................................ 44
   - *Downloading Files* ....................................................................................................... 44
     - *Managing and Cleaning Up Local Files* ............................................................... 45
     - *Setting a Local File Quota* ..................................................................................... 47
   - *Uploading Files* ........................................................................................................... 47
     - *Uploading Files at a Later Time* ............................................................................. 48
     - *Ignoring Changes to a File* ..................................................................................... 48
   - *Deleting and Restoring Files* ...................................................................................... 48
     - *Deleting Files from a Local Project* ....................................................................... 48
     - *Deleting Files from Server Projects* ....................................................................... 48
     - *Restoring Deleted Files from the Server* ............................................................... 49
     - *Purging Deleted Files* .............................................................................................. 50
   - *Previous Versions of Files* .......................................................................................... 50
   - *File Conflicts* .............................................................................................................. 51
   - *Adding Custom Blank Template Files to the ‘New’ Menu* ..................................... 54

5. **WORKING WITH EMAIL** ................................................................................................. 57
   - *The Emails Tab* .......................................................................................................... 57
     - *Viewing Emails and Attachments* .......................................................................... 57
     - *Searching for Emails* ............................................................................................. 58
     - *Forwarding Emails* ................................................................................................. 58
   - *Copying Emails into Smartware Studio* ................................................................ 58
   - *Forwarding Emails into a Smartware Studio Project* ........................................... 59
     - *Specifying an Email Alias for a Folder* ................................................................. 59
     - *Accessing a Shared Contact List in Microsoft Outlook* ....................................... 60
     - *Selecting an Email Address from the Smartware Studio Contact List* .............. 62
6. THE NETWORK TREE

Viewing the Network Tree.................................................................................................................. 65
  Checking Out the Project.................................................................................................................. 65
The Structure of the Network Tree...................................................................................................... 66
  Device Properties............................................................................................................................. 67
Building the Network Tree.................................................................................................................. 70
  Adding Devices to the Network Tree............................................................................................. 71
  Deleting Multiple Devices from the Network Tree......................................................................... 72
  Reordering Devices......................................................................................................................... 72
Property Sheets and Reports................................................................................................................ 73
  Property Sheet Reports.................................................................................................................... 75
  Importing and Exporting Property Sheet Data................................................................................ 76
The Passwords Tab............................................................................................................................... 77
Automation Overview Diagrams........................................................................................................ 78
  Generating an Automation Overview Diagram.............................................................................. 79
  Device Display Format.................................................................................................................... 79

7. NETWORK TREE SOFTWARE FILES

The Software File Properties.............................................................................................................. 81
  Software Files Report....................................................................................................................... 82
  If Software File Is Not Required...................................................................................................... 83
Scanning Files..................................................................................................................................... 83
Copy Software Files to Devices........................................................................................................ 84
Duplicating a Single Software File among Multiple Devices........................................................... 86
Working with WorkPlace Tech........................................................................................................... 87
  Opening WorkPlace Tech.................................................................................................................. 88
  Creating a New WorkPlace Tech Application File.......................................................................... 91
  Creating New Application Files within WorkPlace Tech............................................................... 91
  Exporting the Temporary WorkPlace Tech Project........................................................................ 91
  Configuring the WorkPlace Tech Settings..................................................................................... 92
Working with XPSI.............................................................................................................................. 92
  Configuring the XPSI Program Settings......................................................................................... 95

8. NETWORK TREE DEVICES

I/A Network 8000 GCM Devices....................................................................................................... 97
  Backing Up the GCM Block Database............................................................................................ 98
  Importing the GCM Block Database............................................................................................... 98
  Automatically Building the Network Tree from the GCM Database....................................... 100
  LNC Devices................................................................................................................................ 101
Niagara R2 Devices............................................................................................................................ 105
  Bus Configuration Tab..................................................................................................................... 105
  Backing Up a Station....................................................................................................................... 106
  Converting a Station Backup to a Different Format...................................................................... 106
  License Properties.......................................................................................................................... 107
  View Station Tree............................................................................................................................ 108
  Import and Re-synch Devices......................................................................................................... 109
Continuum Devices............................................................................................................................ 111
  Importing Devices from .DMP files............................................................................................... 111
PC Network....................................................................................................................................... 113
  The Ethernet Router......................................................................................................................... 114
  Remote Connection.......................................................................................................................... 115
1. Introduction / About This Guide

Smartware Studio is a sophisticated environment for use in all aspects of project development, engineering, estimating and document storage.

Introducing Studio360 powered by Smartware Studio

Smartware Studio, also known as Studio360, is a software platform for creating and managing a wide range of documents and information about engineering control projects. It consists of several fully-integrated modules, including:

The Core Module

- Advanced File Storage
- Email Storage
- Automatic online/offline synchronization of files
- Automatic retention of multiple versions of each file
- Network Tree modeling and software file storage
- Password storage
- Part Database and PDF Data Sheet browsing
- Standard System Library

Designer Module (also known as Design360)

- Creating of Engineering Submittals using Microsoft Visio
- Controller Library shapes
- Reporting and Checkout Sheets
- Gathering of PDF Reports

Estimating Module

- Creation of Sales and Engineering Estimates and Reports

All the modules include data and direct support for the following Product Lines:

- Schneider Electric I/A Series (I/A Lon, I/A BACnet, Network 8000)
- Schneider Electric Continuum, Vista and I/Net
- Schneider Electric Struxureware
What Does “powered by Smartware Studio” Mean?

Studio360 is the Schneider Electric branded edition of Smartware Studio. The installation process and many display elements are customized to best suit the Schneider Electric branches and partners. Both editions contain all of the same features and functionality, so anywhere in the documentation or programs where you may see references to Smartware Studio, you can be sure it applies equally to Studio360.

Likewise, the Designer Module is also referred to as Design360, and is an integrated version of our well established Designer Suite 2005 stand-alone product.

Where Do I Start?

Where you start depends on what type of user you are. There are three general classes of users (you may be more than one):

<table>
<thead>
<tr>
<th>Type of User</th>
<th>Your Normal Role(s)</th>
<th>What You Want to Do with Studio</th>
</tr>
</thead>
</table>
| User                  | • Application Engineers  
• Application Software Developers  
• Graphics Developers  
• Project Managers  
• Estimators  
• Technicians  
• Administrative Personnel | • Install the software on your Workstation  
• Work with Files  
• Work with Emails  
• Create Submittal Drawings with Design360  
• Model a Controller Network  
• Store Controller Software |
Before anyone in an office can begin to use the system, the IT/Network Administrator will need to install and configure the database and file server.

- The *Setup and Administration Guide* provides a complete, detailed walkthrough of the various steps required.
- Once the server has been configured, workstations can be installed and licensed by individual users without them having direct access to the server. The licensing process points each workstation to your server.

You will want to designate at least one person in your office (and possibly several) to be an *Office Administrator*. When using the software, this person has access to additional administrative tasks (through the ADMIN menu and described in the later chapters of the *Setup and Administration Guide*) such as:

- User Account Management
- License Account Management
- Parts Database Management
- Permissions Management
- Design360 Template Management
- Standard Library Management

For all other *Users*

- If the software needs to be installed and/or licenses on their workstation, refer to the relevant chapters in the *Setup and Administration Guide*.
- Once installed, this *User’s Guide* will provide a solid foundation of the Core Module and its Project and File storage features.
- For Applications Engineers who will use the Design360 module, refer to the *Designer Module/Design360 User’s Guide*. If you are already a user of *Designer Suite 2005*, refer to the document *Upgrading from Designer Suite 2005*.

---

**NOTE**

- All the *Guides* are available in printer-friendly PDF formats directly from the Help menu or on our web site.
- An *Office Administrator* can determine which other users have access to the administrative features by selecting the ADMIN ➔ USER AND LICENSE ADMINISTRATION menu command.
About This Guide
This guide is intended for all users of Smartware Studio. It describes most of the basics for using it to store and retrieve all types of information for Customer Sites and Job Projects, and how to work with the devices on the Network Tree.

Please refer to the table of contents for a complete list of chapters and topics.

Other Guides
There are a number of other Guides, all of which are available from the Smartware Studio Help menu or from the Smartware Studio/Studio360 page of our web site.

Installing and Administering Smartware Studio
For complete details on how to install, setup and configure Smartware Studio, refer to the separate Smartware Studio Setup and Administration Guide.

Using the Estimating Module
For complete details on how to use the Smartware Studio Estimating Module, refer to the separate Smartware Studio Estimating Module User’s Guide.

Using the Designer Module (Design360)
For complete details on how to use the Smartware Studio Designer Module, refer to the separate Smartware Studio Designer Module User’s Guide.

To Learn More about Smartware Studio
Many of the topics covered in this Guide are better illustrated through visual examples. To that end, our video training sessions are available for viewing and downloading from our web site. We encourage you to use these videos as part of your training.

To Contact Us
Our technical support team is available weekdays from 8 am to 5 pm eastern time at (716) 213-2222. You may also visit our web site at http://www.smartwaretech.com or email us at techsupport@smartwaretech.com.
2. Smartware Studio Projects

All Smartware Studio Projects are similar in that they allow you to store all types of files and information in tree-based structures. Where they usually differ is in the type of information that is normally stored in the Project and some of the specific features that are available.

Types of Projects

There are five types of Projects:

- Customer Sites
- Jobs
- Estimates
- Designer (Design360) Projects
- Libraries

A Customer Site Project is designed to represent an entire Client Facility, such as an entire school district, manufacturing plant or hospital system. A Job Project is intended to represent an accounting-level job or project.

- If the devices from multiple buildings are connected or integrated, they should be part of the same Customer Site project so that a single Network Tree can be used.
- If you have multiple jobs related to a Customer, you can create shortcuts to the Job projects within the Customer Site Project. Refer to the later section on Organizing Projects.

An Estimate Project is used to calculate the costs associated with a prospective project and to create the corresponding quotes and reports. Refer to the Smartware Studio Estimating Module User’s Guide for more detail.

A Designer (Design360) Project is used to create a project submittal consisting of Visio-based engineering drawings and other schedules and reports. Refer to the Smartware Studio Designer Module User’s Guide for more detail.

A Library Project is intended to be a repository for portions of project trees that you want to share and reuse.

Refer to the later section on Organizing Server Projects for more information about the best way to organize projects with and within each other.
What is Stored in a Project?
A Smartware Studio Project consists of two tree-like sets of information:

- **The Project View**, which for Customer Sites and Job is essentially the same as the folders and sub-folders in Windows.
  - In a **Designer Project**, the Project View also contains System Folder and Schedule Folders, which hold Designer-specific Visio drawings and Excel schedules.
  - In an **Estimate**, the Project View contains the Estimate’s Areas and Systems.
- **The Network View**, which allows you to model the physical layout of the devices in the facility or project.

As you select any item in either tree, a set of tab pages is shown on the right side of the application window:

For any item in either tree, you can store:

- Any type of files, which can be shared between users and automatically versioned.
- Emails copied from Microsoft Outlook or forwarded from any email program
- Tasks and Notes
- Additional properties specific to the item (e.g., the address of a device)
Not all the tabs may be visible at all times. To explicitly show a tab, select the item from the View menu.

The Project View
The folders in the Project View are intended to store documents of all types.

- There are two main types of folders: *Folders* and *Job Folders*. They are essentially the same, though the Job Folder contains additional properties (e.g., *Job Number*) that will help Smartware Studio locate specific jobs across multiple projects.
- There is a default folder in the Project View of a Customer Site called *Jobs*, designed to contain separate Job Folders for each accounting-level job associated with the client facility.
- Each Job Folder can contain any number of sub-folders. A good practice is to have a standard folder structure to use for each job. Refer to the later section on Organizing Projects.
- You can import an entire folder structure with all its files from Windows. Right-click on a node and select Tools ➔ Import Folders.
- You can export a folder structure with all its files to Windows. Right-click on a node and select Tools ➔ Export Folders.

Refer to the later chapters Working with Folders and Working with Files for more details on these and other tasks.

The Network View
The Network View is intended to model a complete facility and its network and devices.

- You can store device-specific information, such as addresses and configuration information with each device.
- You can store software application and backup files directly with the corresponding device nodes.
- The tree can be built by hand from stencils or imported from other device backups, such as a Niagara R2 UNC *config.xml* file, a Network 8000 GCM block file, or a Continuum *.dmp* file.
- Smartware Studio contains advanced tools for working with WorkPlace Tech and generating Automation Overview diagrams.
- There are many customizable reports that can be run with detailed device information.
Refer to later chapters on the *Network Tree* and *Network Tree Software Files* for more details on these and other tasks.

**Local and Server Projects**

All projects start as a local project stored only on the workstation on which they were created.

Local projects can then be moved to the server so that all users can open and view them, and access and add files, emails and tasks.

Once on the server, Smartware Studio will automatically enable you to keep multiple versions of files, allow users to share and synchronize their files and data, and enable the Password Manager.

**Creating a New Local Project**

To create a new Local Project:

- If the Open Project dialog is not displayed, select the **File ➤ New Project** menu command.
- On the Open Project dialog, click the **New Project** button under the **Local Projects** list. You will be prompted to specify the **Project Type** and other information.
- If your company has created any New Project Templates (projects flagged by an administrator as projects to be copied as starting points for new projects), you can choose from the list of Templates for the corresponding Project Type. Refer to the later section on *New Project Templates* for more information.

**Moving a Local Project to the Server**

To move a local project to the server:

- From the Open Project dialog, select the Local Project from the **Local Projects** list and click the **Add Project to Server** button.
- Or, if the Project is open, select the **File ➤ Add Project to Server** menu command.
- Once moved to the server, the files will no longer be on the local workstation. You will need to open the project and/or download all the files from the Server Project list to retrieve local copies again.
Working with Server Projects
There are a few additional options you should be aware of when opening and closing projects from the Server.

When Smartware Studio first opens, you will usually be presented with the OPEN PROJECT dialog:

Opening a Server Project
To open a project from the server:

- On the OPEN PROJECT dialog, select the project from the Server Projects list and click the OPEN PROJECT button
  - You can also double-click the project name in the Server Projects list.
- Type characters into the SEARCH box to filter the list of Server projects to just those that contain the characters or keywords.
Select one of the Project Type icon buttons to filter the list of Server projects to just those of that type.

Click any of the column headings to sort the list by that column. For example, sorting by the Last Opened date will show you your most recently used projects.

When you open a Server project, you will be asked the following:

**Checking Out a Project**

If you want to create or edit folders in the Project View, or make changes to the Network View tree, then check one of the boxes. When you do, you will be told that the project is being Checked Out to you.
The project can only be checked out to one person at a time. This prevents two people from making changes to the tree structures at the same time, and allows someone to make these types of changes to a server project while not connected to the network.

- Nobody else can check out a project while it is checked out to you. They can, however, add or edit files in that project while you have it checked out.
- If a project is checked out, the user name, computer name and date checked out will be displayed in the Open Project dialog.
- You will be prompted to check in the file (by default) when you close it.

\textit{Note: If you are only working with the files or emails in a project – including adding or editing them – then you do not need to check out the project.}

\textbf{Closing a Project}

When you close a Server Project, you will be prompted to upload your changes:

- Unless you have a poor or slow connection, it is recommended that you upload your changes whenever you close your project.
- There are several methods for uploading the changed files later. Refer to the section \textit{Uploading Files} in the later chapter \textit{Working with Files}. 
If you had the project checked out, you will also be prompted to check it back in:

If you keep the project checked out, you can continue to edit it the next time you open it, even if you are not connected to the server at that time.

Other Project Tasks
Some other common tasks that you can do with all types of projects include Importing and Exporting the Folders and Files, Duplicating Projects and Deleting Projects.

Exporting Folders and Files
For technical reasons, the folders in a project are not stored on your workstation or server exactly as they appear in Smartware Studio. If you wish to extract a copy of a project, or a portion of a project, to use in other programs, you can export a copy of the folders and files.

To export a copy of a portion of a project tree view:

- Right-click on a node and select TOOLS ➔ EXPORT FOLDERS. You be prompted for the folder into which the extracted folders and files will be copied.
**Importing Folders and Files**

If you have existing folders and files that you want to bring into Studio, you can import them directly from any local, network or removable drive.

To import a set of folders and files:

- Right-click on a node and select **TOOLS → IMPORT FOLDERS**.
- If the project is a Server Project, it will need to be checked out to import the folders.
- You will be given the option of importing the folder and its sub-folders, or just the sub-folders.

**Duplicating Projects**

You can make a complete copy of an entire project, including its folders, files and all associated properties. For Estimate projects, this includes all the settings and values in the Estimate.

To duplicate a project:

- In the Open Project dialog, right-click on the name of the local or server project and select **DUPLICATE PROJECT**.

![Duplicate Project dialog](image)

- By default, all the files will be duplicated along with the Project and Network view folders and items. You can also choose to **ONLY DUPLICATE FOLDERS AND NETWORK TREE**.
Regardless of whether the project was local or on the server, the duplicated project will be created as a Local Project. You can then upload it to the server as you would any local project.

- You can also select the ADD PROJECT TO SERVER checkbox to do this automatically.

**Deleting Projects**
Deleting a project will remove the project, its folders and all the files within. You should ensure that a project is truly not needed anymore before deleting it.

To delete a local project:

- Select the project in the Local Project list and click DELETE PROJECT. You can also right-click on the project name and select DELETE PROJECT.
- Once a local project is deleted, it is gone for good.

To delete a server project:

- Right-click on the project in the Server Project list and select ADMIN→DELETE SERVER PROJECT.
- When server projects are deleted, they are actually marked as deleted on the server. They can be restored by an appropriate administrator from the ADMIN→SERVER CONFIGURATION tool (until the deleted project is purged). Refer to the Setup and Administration Guide for more information.
- You can control who has the ability to delete server projects by setting the appropriate Project Permission for each project type. Refer to the Setup and Administration Guide for more information.

**New Project Templates**
It is a good practice to have a standard organization and structure to the various types of projects that you create with Smartware Studio. To help make it easy to manage and use these structures, you can create one or more projects of any type that will serve as a template for new projects to be created.
Creating a New Project Template

A New Project Template is just a server project that has been flagged as such. There are no other restrictions or requirements. To mark a project as a New Project Template:

- In the Open Project list, right-click on the server project and select **ADMIN ➔ MAKE PROJECT A NEW PROJECT TEMPLATE**.
- You can control who has the ability to mark projects as templates by setting the **Set Project Group and Templates** Project Permission for each project type. Refer to the **Setup and Administration Guide** for more information.
- This feature requires that the Project Database Server be upgraded to at least Version 1.1.3. If you find this feature unavailable, have your administrator go to **ADMIN ➔ SERVER CONFIGURATION** and select the **PROJECT DATABASE SERVER** tab.

You can remove the project from the New Project Template list:

- In the Open Project list, right-click on the server project and select **ADMIN ➔ UNMARK PROJECT AS NEW PROJECT TEMPLATE**.

To view all the projects that are marked as New Project Templates:

- Select the **ONLY SHOW ‘NEW PROJECT’ TEMPLATES** checkbox in the Open Project list.

Using a New Project Template when Creating a New Project

When you create a new project, you will be given a list of New Project Templates available to use:

- If you choose one of the template projects, it will be duplicated to create the new project.
- You must be connected to the server to see and use New Project Templates.
Organizing Server Projects

While you can organize your project information any way you like, there are some best practice suggestions that will help improve your performance and experience with Smartware Studio.

- For each customer site, create a distinct Customer Site project. The Network Tree for the site, along with all the controller software files, should be stored in the Customer Site.
- Jobs, Estimates and Designer Projects can be created in two ways – embedded in a Customer Site or Job, or as a Stand Alone Project.

Embedding Projects in a Customer Site or Job

You can add a Job, Estimate or Designer Project node to a folder Customer Site or Job project, either from the Toolbox or by right-clicking on the node and selecting the Add menu. That embedded Job, Estimate or Designer node will have essentially all the functionality as a new project of that type.

With embedded projects:

- All the information about the embedded project, including all its files, is part of the parent project in which it was created. You will need to check out the entire parent project to make modifications to parts of the embedded project, preventing anyone else from modifying the structure of any part of the parent project or its other embedded projects.
- As the size of a project (the number of folders or files) grows, the time it takes to open or download it grows proportionally. There is therefore incentive to not let any one project grow too large.

While embedded projects may be convenient, especially with local projects or projects in their initial stages of development, long-term organization is best served by using Project Shortcuts.

Project Shortcuts

A Project Shortcut is an item in the project tree of one project (the parent project) that represents a link to another server project (the child project). When you double-click the shortcut in the parent (or right-click it and select OPEN), the child project is opened in a separate instance of Smartware Studio.

- You cannot create links to local projects (until they become server projects).
- You can, however, create shortcuts to server projects within local projects.
You create a shortcut to a project as you would any type of item:

- Right-clicking a node in the tree and selecting the shortcut item from the ADD menu (such as ADD->GENERAL->SHORTCUT TO JOB); or
- Dragging a shortcut from the Toolbox stencils (General, Estimating or Designer) onto the tree

You will then be prompted to select the project to which to link:

![Select Project for Shortcut dialog box](image)
The link will be displayed in the tree with a default name:

![Project View Diagram]

The information about which project the shortcut links to is stored in the shortcut, and is not related to the name of the shortcut in the Project View.

- You can rename the shortcut to anything you want.
- On the other hand, if you rename the linked project (by checking out and editing that project), the shortcut in this parent project will not change automatically.

The advantages of using shortcuts include:

- Greater granularity for editing project structures – if someone has a child project checked out, someone else can still check out the parent project.
- Each project is smaller, with fewer files, and will therefore load faster.
When a shortcut is embedded in a server project, it also establishes a link from the child project back to the parent. If you select a child project in the Server Projects list, you can see a list of all if the parent projects that contain a shortcut to it and select one to open.

- Right-click on the project in the Server Projects list and select **Open Parent Project**.

### Extracting Embedded Projects to Stand-Alone Projects

If you have Jobs, Estimates or Designer projects embedded in a Customer Site or Job project, it is easy to extract them from that parent project and make it a separate stand-alone project. This allows you to build projects earlier using the quicker embedding methods, then structure them later as the more efficient shortcuts.

To extract an embedded project to a new stand-alone project:

- Right-click on the embedded Job, Estimate or Designer node and select **Tools → Extract to New Project**
• All the folders and the files from the embedded project will be removed from the original parent project.
• You will have the option of replacing the removed project node with a shortcut to the new project.
• The parent project and the newly created project must both be server projects.

Server Project Groups
As another method of organizing projects you can create Project Groups. Project Groups are essentially another tree of virtual folders that you can name and define as you see fit (e.g., each folder can be a department, a sales territory, a calendar year, etc.). Each server project can then be associated with one or more of these folders. When a user browses the Project List, they can view the Project Group tree and filter the list to just those projects in a specific folder or sub-tree.

Creating and Editing Project Groups
The Project Group tree is global to all users. To edit them, you must be connected to the server, and if permissions are enforced, have the appropriate permission to change them.

To view and edit the Project Group tree:
• On the Open Project list, check the SHOW PROJECT GROUPS checkbox. This will cause the Project Tree to be shown to the left of the project list.
Click the **EDIT PROJECT GROUPS** button to bring up the Project Groups editor.

- To add a new group to a folder, select the folder and click the **ADD GROUP** button (the folder icon) in the toolbar, or right-click the folder and select **ADD GROUP**.
- To delete a group, select the folder and click the **DELETE GROUP** button in the toolbar, or right-click the folder and select **DELETE GROUP**. None of the actual projects will be deleted or affected.
- To rename a group, select the folder and hit F2, or right-click the folder and select **RENAME GROUP**.
- To reorder the groups at a specific level, select a folder and click on the **MOVE UP** or **MOVE DOWN** icons in the toolbar.
- To move a folder to a different parent folder, select it and drag it onto the new parent folder.
- The root folder, *All Projects*, is fixed and always shows all the projects in the system. You cannot associate or disassociate projects with or from this group or rename it.
Assigning Projects to Groups
There are several ways to associate projects with groups.

While in the Project Group editor, as you select a group folder in the tree on the left side, the upper-right pane will show the list of projects associated with the group. The bottom-right panel will show a list of all the projects that are not currently associated with any groups.

- You can drag a project from either list to any group in the tree to associate it with that group.
- You can drag a project from the bottom list (Unassigned Projects) to the top list (Projects in Selected Group) to associate that project with the selected group.
- You can select a project in the top list and press Delete to disassociate it with the selected group.
- Using this interface you can only associate a project with a single group.

When you first add a local project to the server, you will be given the option to associate the project with one or more groups:

- You can also edit the Project Group Associations at any time by right-clicking on the project in the Server Project list and selecting ADMIN→EDIT PROJECT’S GROUP ASSOCIATIONS,
**Browsing for Projects in Groups**

When the Project Group tree is shown in the Open Project list, it acts as another way to filter the list of projects. If there are any other filters (Project Types or keywords), they are applied as well.

- If you select the root (*All Projects*), all the projects are shown.
- If you select a group, only those project assigned to that specific group will be shown.
- If you select a group and check the **INCLUDE PROJECTS IN SUB-GROUPS** checkbox, the projects in the selected group and any sub-groups will be shown.
3. Working with Folders and View Items

The Project View and the Network View are used to contain a tree-like structure for storing information. The items, or nodes, in the trees include:

- *Folders*, which are the most generic type of item. They generally just hold files and emails.
- *Job Folders*, which is a slightly more specific type of folder that is also used as the root of a Job Project.
- *Network Devices*, which can only be used on the Network View, and each of which represent a real-world device such as an HVAC controller or an Ethernet router.
- *Shortcuts* to other server projects.

*Note:* The terms item, node, tree node, or sometimes generically folder, are used to refer to any of these items in the tree or view. They are all essentially interchangeable in this guide.

There are also Project View items that are only used by certain modules:

- *Estimate Nodes* represent the root of an Estimate, and contain a number of special tabs for storing estimate-specific information, such as subcontracts and expenses.
- *Areas* and *Systems* are used within estimates to describe the structure of the estimate and to store the parts, points and labor detail for each system.
- *Designer Project Nodes* represent the root of a Designer project and contain special tabs and commands for the Designer Tools.
- *Designer Systems Folders* and *Designer Schedule Folders* are special folders used only within a Designer project to store the Visio drawing files and Excel schedules.

**Property Tabs for Items**

All of these items in the tree have four common tabs that are shown on the right side of the Studio window as you select them: *Properties, Files, Emails* and *Tasks*.

Some, such as the Network Devices and the various Estimate and Designer items, contain additional tabs. For example, the Designer Project node has a Designer Tools tab, the Estimate nodes have Parts, Points and Labor tabs, and some Network devices have tabs for bus configurations and additional Properties sub-tabs for address and communications properties.

**Building the Project View Tree**

The Project View is designed to look and feel as much like Windows Explorer as possible, so many of the actions you will do should be familiar and intuitive.

Most of the tasks are made available by right-clicking the node and choosing from the popup menu. The menu commands available may vary from item to item,

- The first level of the menu will be the same for all types of items, though some command are only available if the project is checked out and others only if you are connected to the network.
- The commands on the TOOLS sub-menu will vary for each type of item.
- The Toolbox on the left contains all the different types of items that can be added to the trees.
Checking Out a Project
For Server Project, in order to make any changes to the Project View tree, such as adding, moving or renaming folders, you will need to check out the project when you open it:

- You can also check out a project once it is open by selecting the File → Check Out Project menu command.
- Refer to the previous chapter for more details on checking projects in and out.

Adding Items to the Project View Tree
To create a new folder or item:

- Right-click on the folder in which you want to add the new item and select Add from the context menu. You will be offered a choice of different types of items (e.g., Folder, Job Folder, etc.) that can be added. These will change depending on the type of item; or
- Open the Toolbox, open a stencil (e.g., General stencil), and drag one of the folder types onto another folder in the tree. You can also double-click the item in the Toolbox and it will be added to the currently selected item (if allowed).
Selecting Folders

- To select a folder, simply click on it. The Properties tabs (such as Files and Emails) will be updated immediately with the files and data for that folder.
- To expand or contract a folder to view or hide its sub-folders, click on the plus or minus sign to the left of its name.

Moving and Reordering Folders

You can move the folders around in a number of ways:

- To move a folder from one parent folder to another, simply click on it and drag it into the new parent folder.
- To cut and paste a folder from one parent folder to another, right click on the folders and select CUT and PASTE as you would in Windows.
- To reorder a folder within a set of sub-folders, click on it and slowly drag it until a thin line appears between the two folders in which you want to insert it.
- To reorder the folders automatically based on their names, right-click on the parent folder and select REORDER from the context menu.
  - You can reorder BY NAME (purely alphabetical) or BY NAME AND NUMBER, which sorts names such as Folder2 and Folder10 in proper numerical order.

Copying and Duplicating Folders

You can Copy and Paste folders as you would in Windows:

- To create a new copy of a folder in the same parent folder, right-click on the folder and select DUPLICATE. You will be prompted with any options in the same way as if you had selected COPY then PASTE.
- To create two or more copies of a folder, right-click on the folder and select DUPLICATE X. To rename the duplicated folders more easily, right-click on the parent folder and select PROPERTY SHEET AND REPORTS. Refer to the later section on Renaming Folders for more detail.
**Renaming Folders**

To rename a folder:

- Right-click on it and select RENAME from the context menu; or select the folder and hit the F2 key.

To rename multiple folders more easily, right-click on the parent folder and select **PROPERTY SHEET AND REPORTS**:

- This spreadsheet view allows you to enter the new names quickly. Pressing **ENTER** or hitting the down arrow after each entry will automatically move you to the next.

You can also copy and paste a column of values from Excel into the property sheet.

- Select a range from a single column in Excel and select **COPY**.
- Select a similar range in the property sheet (or the topmost cell in the range) and select **EDIT → PASTE** (or press **CTRL+P** or **CTRL+V**).
**Deleting Folders**

When you delete a folder, you will also delete its sub-folders and all the files, emails and tasks associated with it.

- To delete a folder, right-click on the folder and select DELETE from the context menu.
- You can also select a folder and press the DELETE key.

To delete multiple folders quickly, right-click on the parent folder and select DELETE CHILD ITEMS from the context menu. This will present the folders in a multi-selectable list box:

- You can select multiple items (CTRL+CLICK to select individual folders; SHIFT+CLICK to select a range of folders) and then click DELETE SELECTED ITEMS to delete them.

**Restoring Deleted Items**

Deleted folders and the files contained in them can be recovered for some time by clicking the VIEW ➔ RECYCLE BIN menu command or clicking on the RECYCLE BIN icon in the toolbar.
There are two tabs on the Recycle Bin. Select the DELETED FOLDERS tab to restore deleted folders or items:

- To restore a deleted folder and its data back to the Project View, simply drag it from the Recycle Bin back to the tree.
- You can also copy and paste files and emails directly from the node in the Recycle Bin.
- You will be prompted to permanently delete empty folders when you check the project back in.
**Importing Folders and Files from Windows**

Very often you will want to bring in files and folders that already exist on a file server. Smartware Studio can import all the data with one command.

To import an entire folder structure and its files from Windows:

- Right-click on the parent folder where you want the new folder to be created and select **TOOLS ➔ IMPORT FOLDERS** from the context menu.
- Browse to the folder you want to import and click OK.

All the data will be brought into the project. Depending on the amount of files, this could take a few minutes.

- If you import a folder using the pre-defined *Jobs* folder as the parent folder, the newly created folder will be converted to a Job Folder automatically.

**Exporting Folders and Files to Windows**

There may be times when you want to export a folder structure and its files to use or distribute outside of Smartware Studio.

To export an entire folder structure and its files to Windows:

- Right-click on the topmost folder you want to export and select **TOOLS ➔ EXPORT FOLDERS** from the context menu.
- Browse to the folder where you want the exported folder to be saved and click **EXPORT**. You can also paste the folder path from Windows Explorer’s address bar into the **EXPORT TO** box.

**Using a Folder with Other Windows Applications**

The folder structure you see when viewing a project does not correspond to how the folders and files are stored in Smartware Studio. Therefore, there is no corresponding drive letter or path for navigating the Project View from outside of Smartware Studio.

However, there may be times when you want to provide Windows or other programs access to a single folder, such as in order to open or save a file. In this case, you can temporarily map a Windows drive letter to a folder in an open project.

- Right-click on the folder you want to map, and select **MAP FOLDER TO DRIVE LETTER** in the context menu.
You will be given a list of the available drive letters:

Select a drive letter and click MAP FOLDER TO DRIVE. The drive letter will now be available to Windows and other programs.

- These drive mappings are temporary, and will be removed when Windows restarts.
- These drive mappings may be removed when the project is closed in Smartware Studio.

If you want to open the folder immediately, check the OPEN IN WINDOWS EXPLORER box before mapping the folder.
4. Working with Files

Every Folder (actually, all items including Network Tree items) can be used to store all types of files.

The Files Tab
When you select a folder (or other item), you can select the Files tab in the Properties panel to see a list of the files in that folder.

- As you would expect, you can right-click on a file in the file list to see a menu of actions, such as OPEN, OPEN WITH…, RENAME, COPY and PASTE.
- To see a list of files in a folder and all its sub-folders, click the ALSO SHOW FILES FROM CHILD ITEMS checkbox.
- There is a column called Description that is used to add additional comments to a file record (outside of the file itself). Right-click on the file and select PROPERTIES to bring up the form for editing the description.

Adding Existing Files to a Folder
You can add existing files to the project from Windows by:

- Dragging and dropping one or more files from Windows Explorer or another program.
- Selecting the files in Windows, selecting COPY and then right-clicking in the Files Tab and selecting PASTE from its context menu.
A copy of the file will be added to the Smartware Studio project. The original files will not be removed from Windows, even if you have done a Cut and Paste operation.

**Moving Files between Folders**
You can move a file around between folders in the project.

- Dragging and dropping the file from a file list onto another folder will move the file into that folder.
- You can also right-click on the file and select Cut or Copy from its context menu, then right-click on a folder and select Paste from its context menu.

**Copying Files Back to Windows**
You can copy one or more files from the project to Windows by:

- Dragging and dropping one or more files from the Files Tab to Windows Explorer or another program.
- Selecting the files in the Files Tab, Windows, right-clicking and selecting Copy from the context menu, and then right-clicking in a folder in Windows and selecting Paste from its context menu.

A copy of the file will be sent to Windows. The original files will not be removed from Smartware Studio, even if you have done a Cut and Paste operation.

**Creating New Files from Blank Templates**
Just as in Windows, if you want to create a new blank Word or Excel document from scratch, you can do so directly in Studio.

- Right-click in the empty area of the Files list or right-click on the folder and select from the New menu (such as New ➔ Microsoft Excel Document)

The list of possible templates is customizable. Refer to *Adding Custom Blank Template Files to the ‘New’ Menu* later in this chapter.
**Adding Descriptions and Comments to a File**
You can add a description to a file to show more information about it. This description is stored in the Smartware Studio database, and not in the file itself.

- Right-click on a file and select **Properties** from the menu.
- Fill in the **Description** field.

**Adding Shortcuts to a File or Web Sites to a Folder**
In Windows a shortcut to a file or a web site is actually files themselves (.lnk or .url files). If you paste one into a Studio folder’s file list, you can double-click it to open that linked file or web page.

- You can copy and paste or drag and drop the shortcuts from a Windows folder or desktop. Since the shortcut is a reference to a file, only users who can access that file from the same location will be able to open it.
- You can copy and paste the web site links from the Favorites menu of a web browser.

**How Files are Stored Locally and On the Server (Synch Status)**
For a local project, all the files are stored in folders that Smartware Studio maintains for each project.

For server projects, the master copy of the file is stored on the File Server. When the project is open, Smartware Studio gets a list of the files in each folder as needed, along with other information such as the file size and date modified.

When you need to access a specific file (e.g., to Open it or copy it to Windows), Smartware Studio downloads the latest version of the file to your workstation and then opens or copies it from there. This ensures that no two people are ever trying to modify the same file at the same time, or that one is changing a file while another is viewing it. This also allows the files to be used when you are not connected to the server, assuming that the file has been downloaded to the local machine at some earlier time.
Working with Files

**The File Synch Status**

When viewing the files for a server project, you will see an extra column labeled Synch Status. This column indicates how the local version (if any) of a file compares to the current version of the file on the server. The possible statuses are:

- **New File**: The file was added to this project on this workstation, and the project has not yet been uploaded. The file will be uploaded to the server when the project is closed (if the machine is currently connected) or the next time the connection is available.

- **Only on Server**: The file has never been downloaded to this workstation. It will be downloaded automatically if you choose to open it. You can also download it explicitly.

- **Up to Date**: The file on the local workstation is the same version that is on the server.

- **New Version Available**: The file has been downloaded to the local workstation, but there is a newer version on the server. The newer version will automatically be downloaded if you open or otherwise access the file.

- **Changed/Needs Uploading**: The local copy of the file that was downloaded to the workstation has been modified. The changes will be uploaded to the server (as a new version) when the project is closed.

- **CONFLICT: File Changed Both Places**: The local copy of the file that was downloaded to the workstation has been modified, but somebody else has uploaded a new version to the server since your copy was downloaded. Refer to the section on *File Conflicts* for more details.

**Downloading Files**

To open or otherwise work with a file on your workstation, Smartware Studio will download a copy from the server to the local machine. This happens automatically when the file is accessed.

Once it has been downloaded, the file will still be accessible and editable on the local machine if the project is accessed when not connected to the server (e.g., on a laptop taken onto a job site).
If a set of files will need to be accessed in an off-line scenario (or in a situation where the connection speed will not be ideal), it will be necessary to download these files explicitly while connected.

- To download a single file, right-click on the file and select **DOWNLOAD LATEST** from the context menu. This happens automatically if you open a file.
- To download multiple files from a list, multi-select the files, right-click on the selected group, and select **DOWNLOAD LATEST** from the context menu.
- To download the files in an entire folder (and all its sub-folders), right-click on the folder and select **DOWNLOAD ALL FILES**.
- To download all the files in an entire project, right-click on the project in the Server Projects list in the Open Project dialog and select **DOWNLOAD ALL FILES**.
- When downloading entire folders or projects, you will be told exactly how much data will be downloaded and asked to confirm your action (in case the amount of data is exceptionally large).

**Managing and Cleaning Up Local Files**

Since every file you access or explicitly download is stored on the workstation's local hard drive, it is likely that a large amount of data will accumulate on the machine. This is especially true if you work with a large number of projects or a large number of files.

Since the latest version of all files is stored on the server, you can safely remove the local copies of any files you no longer need, knowing that they will be downloaded again if a future need arises.
To view how much local space is being used, go to the **OPEN PROJECT** dialog.

![Open Project dialog](image)

The total size of all the local files for each project is shown in the last column.

- To determine which projects are using the most space, click on the **LOCAL FILE SIZE** column in the Server Projects list to sort by that column.
- The total size of all the local files in all the projects is shown in the bottom section.
- To clean up a local project and delete all the local copies, right-click on the project in the Server Projects list in the **OPEN PROJECT** dialog and select **CLEAN UP LOCAL FILES**.
- To clean up all the local files for all the server projects, click the **CLEANUP ALL** button beneath the Server Projects list.
- To clean up a selected portion of the local files in a project, open the project, right-click on any folder and select **CLEAN UP LOCAL FILES**. This will clean up only the local files in that folder and its sub-folders.
**Setting a Local File Quota**

To help alert you that you may need to clean some projects, you can set a Quota for the amount of space you consider reasonable.

- To set the quota, click the SET QUOTA… button on the OPEN PROJECT dialog.
- The QUOTA USAGE meter will indicate how much of your quota space is being used by the local files.
- The meter will turn yellow and then red as you near the quota.
- The quota space is not reserved, does not prevent the space from being used by other application and may not actually be available on your hard drive.
- The quota is soft and will not be enforced. It is therefore possible to exceed the quota without any warning other than the meter turning red.

**Uploading Files**

If you add or change files in a server project, Smartware Studio will want to automatically upload these new and modified files to its file server, making them available to all other users as the latest version of the file.

When you close a project while connected to the server, you will be prompted to upload your changes as the default action:

![Close Project dialog]

You should always upload your changes when you close a project unless your connection speed would make it prohibitive. In that case, you should explicitly upload your changes then next time you have a good connection.
Uploading Files at a Later Time
If you don't upload the changes when you close the project, you can upload them explicitly when you can.

- You can determine which projects need to be uploaded by viewing the Open Project dialog. For the projects that need uploading, the Files Last Uploaded date in the server project list will be shown in red.
- To upload the changes in a project from the Open Project dialog, right-click on the project and select Upload Changes from the context menu.
- To upload the changes for all projects that need to be uploaded, click the Upload All button beneath the server projects list in the Open Project dialog.
- To upload the changes in a project while it is open, choose the File → Upload Changed Files to Server menu command.

Ignoring Changes to a File
If you have modified a file but do not want your changes to be saved to the server, you can tell Smartware Studio to ignore your changes.

- Right-click on the file and select Ignore Changes.
- The most recent version from the server will be downloaded and all your changes will be lost.

Deleting and Restoring Files
When a file is deleted by a user, what happens depends on whether the project is local or being stored on the server. The file can end up in the

- Windows Recycle Bin (generally available on your Windows desktop);
- The Studio Recycle Bin (available from the Studio toolbar or by selecting View → Recycle Bin in Studio); or
- Both

Deleting Files from a Local Project
For Local Projects, deleted files are sent directly to the local workstation’s Windows Recycle Bin. They are not stored in the Studio Recycle Bin.

Deleting Files from Server Projects
For Server Projects, deleting a file on a workstation is a signal that the file should be deleted from the server and all other workstations.
If the deleted file is new (i.e. it was added since the project was open and before any uploads to the server), it will be treated as a local file and only be sent to the Windows Recycle Bin.

If the file has been uploaded to the server at least once, a copy will be sent to the Windows Recycle Bin on the local workstation. During the next upload, Studio will indicate that the file be deleted:

![Upload Files](image)

Once the upload is complete, the file is marked as deleted on the server. The next time any user opens the project or downloads the files in that folder, the deleted file will no longer appear. If another user happens to have modified the file, they will receive a message about the conflict.

You can use the Permissions model to limit who has the ability to delete files from certain project types or folders. Refer to the Setup and Administration Guide for more detail.

**Restoring Deleted Files from the Server**

Deleted server files are not actually deleted initially, but are instead marked as deleted. Any user can restore a deleted file, regardless of who deleted it, from the Studio Recycle Bin.
To restore a deleted file:

- Open the Studio Recycle Bin by clicking the toolbar icon or by selecting **View ➔ Recycle Bin**.
- Select the *Deleted Files* tab

- If you right-click on the file, you will have the option to open the file, restore it to its original location, or delete it permanently.

**Purging Deleted Files**

Deleted files may not be available forever. An administrator can purge a range of deleted files to reduce the amount of server space being used. Refer to the chapter *Administering Smartware Studio* in the *Setup and Administration Guide* for more detail.

**Previous Versions of Files**

When you upload a new version of a file in a Server Project, Smartware Studio does not delete the previous version immediately. Instead, depending on the settings for your server, it makes one or more of the previous versions available as well. This allows you to “go back in time” in case a file has been modified in a negative way by a user or if you want to see who made certain changes and when.

- To see a list of the Previous Versions of a file that are available, right-click on the file and select **Previous Versions**. You must be connected to the server to see the list.
- Local Projects do not maintain previous versions of files.
The list numbers the versions sequentially:

<table>
<thead>
<tr>
<th>Name</th>
<th>Sync stellar</th>
<th>Size</th>
<th>Date Modified</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bid Letter.doc</td>
<td>Up to Date</td>
<td>20 KB</td>
<td>4/09/2012 10:40 AM</td>
<td>Word Document</td>
</tr>
</tbody>
</table>

- To view a previous version, right-click the version in the list and select View.
- To make a previous version the current version, right-click the version in the list and select MAKE CURRENT.

If there was a conflict with the file (refer to the next section on File Conflicts), the conflicted version would be shown in red if the conflict was not resolved. The Action column would also indicate what the conflict was and how it was resolved.

Previous versions of files may not be available forever. An administrator can purge a range of older versions of files to reduce the amount of server space being used. Refer to the chapter Administering Smartware Studio in the Setup and Administration Guide for more detail.

**File Conflicts**

One of the most important features of Smartware Studio is its ability to ensure that one person doesn’t inadvertently overwrite the changes of another when they both modify the same file.
Consider the following scenario:

- A file exists in a Server project. The latest version is Version 2.
- Person A (John Smith) opens the file, automatically downloading Version 2 to their workstation.
- Person B (Larry Burns) also opens and downloads Version 2.
- Person A modifies and saves the file. He uploads his changes, which become Version 3.
- Person B modifies and saves his version of the file. He uploads his changes, which become Version 4.

The problem that would occur in a normal file server situation is that Person B has overwritten the changes that Person A has made. Smartware Studio, however, tracks the versions of the files that are downloaded to each machine, so when Person B uploads their version, they will receive this message:

As indicated, all three versions are stored on the server. This is apparent in the Previous Versions list:

<table>
<thead>
<tr>
<th>Properties</th>
<th>Previous Versions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version</td>
<td>Upload Date</td>
</tr>
<tr>
<td>4</td>
<td>12/02/2010 11:08 AM</td>
</tr>
<tr>
<td>2</td>
<td>12/02/2010 11:00 AM</td>
</tr>
<tr>
<td>2</td>
<td>12/02/2010 10:38 AM</td>
</tr>
<tr>
<td>1</td>
<td>6/28/2010 3:41 PM</td>
</tr>
</tbody>
</table>
The important things to note are:

- Person A’s changes (Version 3) are still available to view.
- Person B’s changes (Version 4) are considered the current version.
- If nobody does anything else, Version 4 will remain the current version until the next person modifies and uploads the file.

The best way to resolve this conflict is for the two people to speak and determine what changes were made, whether either set of changes can be ignored, or if the changes need to be merged by hand.

There are therefore three ways to resolve this conflict:

1. Do nothing, leaving Version 4 as the latest and losing Version 3’s changes.
2. Make Version 3 the latest (creating a copy as Version 5), overwriting and losing Version 4’s changes.
3. Merge the changes manually to create Version 5. Versions 2, 3 and 4 are all available on the server to help make this possible.

To review and resolve the conflict, right-click on the conflicted version shown in red in the Previous Versions list (in our example, this would be Version 3):

![Resolve File Conflicts]

**Conflict Type:** Multiple Changes to the Same File

**Description:** Two people changed the same file separately. Both of the modified versions of the file, as well as the original they were both derived from, have been saved. This version was uploaded first, and has been superseded by the next version. You should review this version and the next one to see if there are changes in both that should be merged.

**Details:** This file was changed, but another changed version (Version 4) has superseded these changes.

**Options:**
- Ignore this Conflict
- Make this Version the Current Version

Accept  Cancel
Adding Custom Blank Template Files to the ‘New’ Menu

As described earlier, the New menu is available when you right-click on a folder or in the empty area of a folder’s Files tab. This menu contains a list of blank documents that you can insert into your project.

- The default list of blank template files will vary depending on the type of folder. For example, Microsoft Word documents can be inserted anywhere but Designer Drawings can only be added to a Designer Systems folder.

You can add your own documents to this list, and if you are an administrator, you can make this list available to all users.

Note: This process is a bit advanced and does require some manual file manipulation in Notepad or another text editor.

You will need to create a text file called Custom Templates.xml which lists the entries for the New menu. The format of this file should be similar to the following example (we suggest you cut and paste from here):

```xml
<?xml version="1.0" encoding="utf-8" ?>
<TemplateFiles>
    <TemplateFile>
        <Description>Our Letterhead</Description>
        <FileName>Acme Letterhead.doc</FileName>
        <DefaultFileName>New Letter.doc</DefaultFileName>
        <MenuSection>Custom</MenuSection>
    </TemplateFile>
    <TemplateFile>
        <Description>Our Legend Page</Description>
        <FileName>Acme Legend.vsd</FileName>
        <DefaultFileName>Acme Legend.vsd</DefaultFileName>
        <MenuSection>Systems</MenuSection>
        <FileType>Designer Suite Drawing</FileType>
    </TemplateFile>
</TemplateFiles>
```

The file is essentially a list of <TemplateFile> records. For each one, you will specify:

- **Description**: What it says on the New menu
- **FileName**: The actual name of your blank template file
- **DefaultFileName**: The initial name that will be given to the file the user creates when they select it from the New menu.
- **MenuSection**: An indicator as to the section of the menu in which the file should be listed.
- **FileType**: An indicator as to what the specific type of file is (mostly for Visio files, which can be more than one type)
The valid values for \textit{MenuSection} are:

\begin{itemize}
  \item \textit{Blanks} \quad \text{The same section as the default blank Word, Excel and Text documents}
  \item \textit{Custom} \quad \text{A separate section at the bottom of the menu}
  \item \textit{Systems} \quad \text{The same section as Designer Drawings (and only shown when in a Designer Systems Folder)}
  \item \textit{Schedules} \quad \text{The same section as Designer Schedules (and only shown when in a Designer Schedules Folder)}
\end{itemize}

The \textit{FileType} is only needed for Designer-specific file types, and can be: Designer Suite Drawing, Designer Suite Valve Schedule, Designer Suite Air Flow Schedule, etc.

The \textit{Custom Templates.xml} file and the template files should be stored in the \textit{Custom Templates} folder on a workstation (and server, to distribute to all users). Refer to the \textit{TOOLS} \textit{\textgreater} \textit{OPTIONS Template Files} tab and the \textit{ADMIN} \textit{\textgreater} \textit{LIBRARIES AND TEMPLATES Template Files} tab for more detail on these folder locations.
5. Working with Email

In addition to files, every folder (actually, all items including Network Tree items) can also be used to store email.

The Emails Tab

When you select a folder (or other item), you can select the Email tab in the Properties panel to see a list of the emails in that folder.

- Some items in the tree may not have the Emails tab visible by default. If not, you can show it by selecting View ➔ Emails Tab.
- If there are any emails stored with the folder, the Emails tab will automatically be visible and show an envelope icon next to the tab name.

It is common to create a folder named Correspondence in a Customer Site project to store all the emails, or to create one Correspondence folder per Job.

Viewing Emails and Attachments

To view the content of an email, select it in the list:
To print the email, right-click the email in the list and select PRINT or PRINT PREVIEW.

To view the contents of an attachment, select in from the list and click OPEN.

To extract an attachment, select it in the list and click COPY (and Paste it to your desktop or other Windows folder) or click the SAVE AS button.

**Searching for Emails**
There are some additional ways to find a specific email in a project:

- If you have multiple folders with emails stored in the them, select the root of the project, go to the Emails tab, and check the Also Show Emails from Child Items.
- Enter one or more keywords in the Search box, which will search the subject lines. Check the Search in Email Bodies checkbox to also search the body of each message.

**Forwarding Emails**
You can use Microsoft Outlook to forward an email directly from the Smartware Studio project to someone else.

- Right-click on the email in the list and select OPEN. The email will open in an Outlook window with all options (Forward, Reply, etc.) available.

**Copying Emails into Smartware Studio**
You can copy emails directly from Microsoft Outlook into your Smartware Studio project. When you do, the format of the message will generally include most of the formatting and the attachments.

To copy an email from Outlook (not all methods are available in all versions of Outlook):

- Select the email in Outlook and from the Edit menu select COPY. Right-click in an empty area of the Smartware Studio email list and click PASTE.
- Right-click on the email in Outlook and select COPY, then right-click in an empty area of the Smartware Studio email list and click PASTE.
- Drag the email from the list on Outlook and drop it in the email panel in Smartware Studio.

Depending on the version of Outlook and your security settings, Outlook may prompt you for explicit permission to copy the email.
**Forwarding Emails into a Smartware Studio Project**

If properly configured, you can assign a unique email address to each Correspondence folder in each project (e.g. ChelseaCSD@studio.yourcompany.com). You can then forward or carbon copy emails to this address from any email program and they will automatically be routed to the appropriate project and folder.

*Note: This feature requires some additional setup and configuration that requires advanced IT experience. Refer to the chapter The Email Forwarding Service in the Smartware Studio Setup and Administration Guide.*

The email addresses for the projects will be based on a sub-domain address defined by your Administrator. If your company’s normal email address is @yourcompany.com, the Smartware Studio email address will be something like @studio.yourcompany.com.

**Specifying an Email Alias for a Folder**

Any folder in any project in Smartware Studio can be configured with an email address to receive emails through the service.

- All the email addresses will end with the sub-domain name created by your Administrator (e.g., @studio.yourcompany.com).

To create a new email address, specify the EMAIL FORWARDING ALIAS property of the folder.

- With the project checked out, create and select the Correspondence folder in the project tree.
- On the right side, select the PROPERTIES tab.
• On the DETAILS sub-tab, fill in the EMAIL FORWARDING ALIAS.

• The full email address for this folder will be Acme@studio.ourcompany.com

Accessing a Shared Contact List in Microsoft Outlook
Your Administrator can generate a Contact List with all the aliases in the system and make this contact list available through Microsoft Outlook.

To make the shared contact list available in Outlook, do the following:
• Go to the Folder List pane by:
  o Selecting the Go ➔ Folder List menu command, or
  o Clicking on the Folder List panel in the Navigation Pane

• Navigate to the Public Folders ➔ All Public Folders ➔ Smartware Studio folder.
• Right-click on the Smartware Studio contact list and select Properties from the menu.
Select the **OUTLOOK ADDRESS BOOK** tab

- **Check the SHOW THIS FOLDER AS AN EMAIL ADDRESS BOOK checkbox**

**Selecting an Email Address from the Smartware Studio Contact List**

Once the shared folder has been configured, you can access the contact list whenever you are composing, forwarding or replaying to an email.
• When composing an email, click on the To… button next to the field for entering the sender's email address:

![Email composition screenshot]

• In Outlook's SELECT NAMES dialog, drop down the SHOW NAMES FROM THE list and select the shared folder:

![Select Names dialog screenshot]

The complete list of defined alias for Smartware Studio projects will be displayed for you to browse and search.
6. The Network Tree

The Network Tree is designed to help you model various types of physical device networks, including

- HVAC Controller Systems
- PC Networks

Once created, it provides a number of significant features:

- Organized storage of Software Files for each device
- Storage of device passwords
- Generation of Automation Overview diagrams
- Generation of Device Reports
- Tools for specific software tools, such as Schneider Electric’s WorkPlace Tech.
- Tools for specific devices, such as Niagara R2 backups.

Viewing the Network Tree

The Network Tree is a part of all Smartware Studio projects. If not already visible, you can make it visible by:

- Selecting EDIT ➔ NETWORK VIEW
- Clicking the NETWORK VIEW tab on the left side of the Smartware Studio window

Checking Out the Project

When you open a server project in Smartware Studio, you will be asked if you want to check out the project.

- If you are only going to work with the files on the network tree (including adding, editing or modifying the files) you do not need to check out the project.
- If you are going to add, remove or move the devices in the network tree you must check out the project.
- If you are going to change the properties of the devices in the network tree, such as the network addresses, you must check out the project.

Refer to the earlier chapter on Smartware Studio Projects for more information.
The Structure of the Network Tree

The Network Tree includes three types of items:

- Devices
- Buses
- Folders

Here is a sample tree with all three types of items:

- The Network Root can contain Devices and Folders.
- Folders can be added to Devices and other Folders.
- Buses exist underneath Devices, but cannot be added directly. They either exist automatically or are turned on or off from the Device’s property tabs.
- Devices can be added to Folders or compatible Buses.

Each type of item and each type of Device can have different information and functionality. You can access these from:

- The specific Property Tabs.
- The Context Menu (right-click the item in the tree)
For example, a Niagara UNC device has additional tabs for BUS CONFIGURATION and STATION BACKUPS. Buses have a context menu command for TOOLS ➔ DUPLICATE AND DISTRIBUTE SOFTWARE FILES. The specific tabs and commands for each type of device are described in more detail in the next two chapters.

**Device Properties**

While the exact list of properties will vary from device to device, most share a similar list on three tabs: **Details**, **Network** and **Software**.

The **Details** tab contains general properties:

- The **Physical Order** and **Include Terminator** properties are used to control the generation of the Automation Overview diagrams described later in this chapter.
- The **FTP Forwarding Alias** property allows you to create an alias for automatic forwarding of files to this device’s file list from an external folder or FTP site. Refer to the chapter The Email Forwarding Service in the Smartware Studio Setup and Administration Guide for more information.
The Network tab contains properties related to the device’s network addresses:

- These properties will vary from device to device.
- Some of these properties are filled in when the Network Tree is built automatically from global controller backups (e.g., GCM, Niagara UNC) or from scanned software files (e.g., WorkPlace Tech).
Some properties, when accepted, will make other properties of buses appear.

- For Ethernet devices, if you change Has Public Ethernet Address to True, the specific properties for the public address (in addition to the default private address properties) will appear.

  ![Network Tree Diagram]

  **Public Ethernet Address**
  - Has Public Ethernet Address: True
  - Public Host Name:
  - Public DHCP: False
  - Public IP Address: 0.0.0.0
  - Public Port Number: 0
  - Public Subnet Mask: 0.0.0.0
  - Public Default Gateway: 0.0.0.0

- On a generic BACnet device, if you change Show BACnet MS/TP Bus to True, the bus will appear beneath the device node.

  ![Network Tree Diagram]
The Software tab contains properties related to the software files stored with the device:

- Device Software Files are described in more details in the later chapter.

**Building the Network Tree**

The Network Tree is generally built in a combination of two methods: *manually* or *automatically*.

- When you build a portion manually, you add devices from the toolbox to the appropriate folder or bus. You can then configure the devices to show the appropriate buses beneath them, adding devices to these sub-networks as needed.
- Some global controllers (such as the GCM, Niagara UNC) have utilities that allow you to import a backup of the controller which contains enough information about the devices on its bus to build the network tree and fill in some of their properties. Refer to the later chapter on *Network Tree Devices* and the specific device description for more information.

Remember, if you are going to edit the Network Tree structure, the project must be checked out.
**Adding Devices to the Network Tree**

You can add a device to the Network Tree in one of two ways:

- Open the **Toolbox**, select the appropriate stencil with the device you want, and drag it onto the parent folder or bus. Only compatible devices can be put on a bus.
- Right-click on the parent folder or bus and select the **ADD** menu. A list of compatible devices will be shown.

If you want to quickly add more than one device of the same type, you can do the following:

- Add the first instance of the device.
- Right-click the new device and select **DUPLICATE X** to add the additional instances.
- Right-click on the parent folder or bus and select **PROPERTY SHEET AND REPORTS** to quickly rename the new instances. Refer to the later section in this chapter for more detail.
**Deleting Multiple Devices from the Network Tree**

To remove multiple devices from a bus or folder on the Network Tree at once, right-click on the parent folder or bus and select DELETE CHILD DEVICES. This will present the devices in a multi-selectable list box:

- You can select multiple items (CTRL+CLICK to select individual folders; SHIFT+CLICK to select a range of folders) and then click DELETE SELECTED ITEMS to delete them.

**Reordering Devices**

To reorder the devices based on their names or addresses, right-click on the parent folder or bus and select REORDER from the context menu.
You can reorder:

- **BY DEVICE NAME** (purely alphabetical)
- **BY DEVICE NAME AND NUMBER** (which sorts names such as *RTU2* and *RTU10* in proper numerical order.
- **BY PHYSICAL ORDER** (based on the *Physical Order* property on the Details tab; used by the Automation Overview diagrams described later in this chapter)
- By Device Address (e.g. BACnet Instance Number)

**Property Sheets and Reports**

Property Sheets and Reports is a utility that can be used to:

- Quickly rename a set of devices
- Quickly view and edit the same property across a set of devices
- Generate and export a report of device properties

A Property Sheet is essentially a spreadsheet, with each row representing a single object (e.g., device) in the network tree, and each column representing a specific property (e.g., *Name, Description, and BACnet Instance Number*).
To create a Property Sheet, right-click on a parent node of the items you want in the report and select PROPERTY SHEET AND REPORTS. For example, to generate a Property Sheet of the devices in a single bus, select the menu command from the bus:

- You can edit any of the properties with a white background. Gray background columns are read-only.
- The default Property Sheet report includes just the basic Name and Description properties that all items share. This is a quick way to rename a set of items or update their descriptions.
Property Sheet Reports

To view additional properties, select a specific Report from the list in the upper-right corner. For example, here is the same list using the Devices report:

- If you want to report on items from more than one parent, start with an item higher up in the tree and check the ALSO SHOW PROPERTIES FROM CHILD ITEMS checkbox.
- When you select a specific Report, only the items of that type will be included. For example, if you run a report from a Niagara UNC with multiple bus types and select the Lon Devices report, the report will be filtered to include only Lon Devices.
- In general, a report will show all the properties that all the items of that type have in common. More specific reports show more properties.
Here is the *BACnet Devices* report for the same items. Note the addition of the *Bacnet Instance Number* and *Bacnet Network Number* properties:

---

### Importing and Exporting Property Sheet Data

You can move data into and out of the Property Sheets in a number of ways:

- To export the entire Property Sheet to Excel, click the **EXPORT TO EXCEL** button or select **FILE ➔ EXPORT TO EXCEL**.

- If you want to paste data from an external spreadsheet into the Property Sheet:
  - Highlight the cells in the external spreadsheet
  - Select **COPY**
  - In the Property Sheet, click in the first cell to paste into and select the entire cell (not just the text).
  - Select **PASTE**

- If you want to fill the same value down into multiple cells, highlight all the cells and select **EDIT ➔ FILL ➔ DOWN** (or **CTRL+D**). The top value will be copied into the other cells.
The Passwords Tab

For a server project, each device has a Passwords tab that can be used to store the User Names and Passwords for accessing the device:

- The passwords are stored and encrypted in the server’s database, and are never stored on a local workstation. This guarantees that a lost machine won’t reveal these passwords, but also requires that the workstation be connected to the server in order to view a password.
- You can store multiple User Name and Password combinations on the same device.
- Password storage is not available for local projects until they are moved to the server.
Automation Overview Diagrams
Once you’ve created a Network Tree you can generate an Automation Overview diagram, which is a Visio drawing showing how the devices on each bus are organized and ordered.

- Each bus is shown in a separate group.
- You can specify what information is shown below each device.
Generating an Automation Overview Diagram

To generate the diagram, right-click on the Network Root or a Folder in the Network Tree and select TOOLS → GENERATE AUTOMATION OVERVIEW.

You must have Visio installed on your workstation to generate the diagrams.

When you create the Overview, the Visio file will automatically be saved on the Network Root or Folder that you selected.

The devices on a bus are ordered by the Physical Order property of the device. You can edit these values on the Properties tab of each device or as a group by using a Property Sheet (refer to the earlier section).

To show a Terminator at the end of a bus, set the Include Terminator property of the last device to True.

Device Display Format

You can adjust what values are shown beneath each device in the diagram. The Device Caption Format String is used to define the format, with substitution codes used to fill in the values.

Some examples, assuming a device with the following properties:

- Name: C007
- Description: RTU2
- Bacnet Instance Number: 203030
<table>
<thead>
<tr>
<th>Format String</th>
<th>Generated Caption</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;n&gt;</td>
<td>C007</td>
</tr>
<tr>
<td>Name: &lt;n&gt;</td>
<td>Name: C007</td>
</tr>
<tr>
<td>&lt;n&gt; : &lt;d&gt;</td>
<td>C007 : RTU2</td>
</tr>
<tr>
<td>&lt;n&gt;&lt;br&gt;&lt;d&gt;</td>
<td>C007&lt;br&gt;RTU2</td>
</tr>
<tr>
<td>&lt;n&gt;&lt;br&gt;&lt;da&gt;</td>
<td>C007&lt;br&gt;BAC Inst #: 203030</td>
</tr>
</tbody>
</table>

- The substitution code `<br>` can be used to force a line break. Longer lines will wrap automatically.
- The Device Address is formatted automatically depending on the device.
7. Network Tree Software Files

The Smartware Studio Network Tree is ideal for storing the software files and backups that are associated with the devices in the network. These files often include:

- Source Files (in Visio, text, custom binary or other format)
- Compiler Files
- Backups from the Field (in zip, xml, binary or other format)
- Documentation and Notes

You can store any number or type of file on the Files tab of the device. Each device is programmed to know the name or file extension of its source files, and in some situations (such as with Visio files, which are used by a number of different applications) will scan the file to confirm or determine its contents. You can then run a report of the devices and their latest software file to ensure that all the devices are properly backed up or to determine what backups need to be obtained.

The Software File Properties

All devices have a sub-tab named Software on its Properties tab.
The first four properties show what the device has determined to be its **Current Software File**.

- The file’s **Name** and **Date** are shown.
- If it’s applicable and known, the **Program Version** (e.g., WorkPlace Tech 5.0.1016) that was used to create the source file. Having this value filled in may require that the file has been **scanned**. Refer to the later section for more detail.
- The **Note** lets you know if Smartware Studio has determined there to be a good backup and how it came to that conclusion.

**Software Files Report**

You can easily run a report to show all the devices on a bus or in a building showing the information about the software files and backups in the system.

To run the Software Files Report:

- Right-click on the bus, folder or global controller device that contains the devices on which you want to report.
- Select the **PROPERTY SHEETS AND REPORTS** menu command.
- In the **REPORT NAME** list select **Software Files**.
If Software File Is Not Required

In cases where a software file is not required for a device, you can set the Software File Is Not Required field in the Properties tab or in the Property Sheet. Doing so changes the File Name to “n/a” and the Note to “No software file required.” This fills in the spot on the report to make it easier to find the devices that are missing their backups in the Software Files report.

Scanning Files

In some cases Smartware Studio can glean additional information by opening up a software file and reading some information, or scanning it. Doing so allows Smartware Studio to determine:

- The correct type of the file and what program (and version) is used to open and edit it (e.g. WorkPlace Tech for Visio files)
- Detailed properties, such as device addresses and point configurations.

If Smartware Studio is taking an action that requires the file to be scanned (e.g., launching WorkPlace Tech), it will be scanned automatically.

You can explicitly scan the files for a device or a set of devices:

- Right-click on a device, bus or folder that contains the devices with files you want to scan.
- Select the TOOLS ➔ SCAN FILES command.
• If you selected a folder, bus or global controller, check the ALSO SCAN FILES IN SUB-FOLDERS AND CHILD ITEMS checkbox to include the files in child items in the scan.

• For WorkPlace Tech Visio files, you can optionally choose to have the address and other values read from the file saved to the Properties tab of the device by checking the UPDATE DEVICE PROPERTIES FROM WPT APPLICATIONS checkbox.

Copy Software Files to Devices

After you first create a network tree for an existing network, you will likely have a set of software files somewhere on your server, laptop or USB drive that you want to copy onto the devices. Smartware Studio includes a utility to make it easier than dragging and dropping each file one by one.

To distribute an existing set of software files among the corresponding devices on the network tree:

• Create a folder on the Network Tree (or Project Tree)
• Copy all the software files to distribute from the outside location into this folder.
• Right-click on the folder and select TOOLS → COPY SOFTWARE FILES TO DEVICES.

You will be prompted for the type of software files to work with. You can only work with one type at a time:

• If necessary, the files may be scanned. This might take a minute or two.
After scanning, the software files to distribute and the devices without software files are shown in two lists:

- The left list (SOURCE SOFTWARE FILES) shows all the files in the folder you selected.
- The right list (DESTINATION DEVICES) shows all the devices in the network tree that are compatible with the selected software type and that do not currently have software files.
- To include devices that may already have software files, check the SHOW DEVICES WITH EXISTING SOFTWARE FILE checkbox.
The goal now is to pair up the source files with the appropriate device and then copy the files to the devices. You can pair up files in two ways:

- Select a file in the left list and a device in the right list and click the MATCH SELECTED ITEMS button. The new match will appear in the lower list and the selected items will be removed from the upper lists.
- Choose a rule for the MATCH BY RULE setting (e.g., Exact Same Name) and click the MATCH BY RULE button. All matches that can be made using the rule will appear in the lower list (and will be removed from the upper lists).

You can undo a single match by selecting it in the lower list and clicking CLEAR SELECTED MATCH. You can undo all the matches and start older by clicking CLEAR ALL MATCHES.

When all the matches have been made, choose the appropriate options and click the COPY FILES button. The files will be copied to the devices and optionally removed from the source folder.

**Duplicating a Single Software File among Multiple Devices**

Here is another common scenario:

- You have a set of devices (e.g. VAV) on a bus that will all use the same software file.
- Each device needs its own copy of the source file to upload to the device, as the source will be updated and resaved with the specifics of the device address when the device is commissioned.

You therefore want to:

- Copy the source file to each device individually
- Possibly rename each copy to match the device’s name.
There is a utility that will do just that. To use it:

- Copy the source file onto the Files tab for the bus that contains all the devices.
- Right-click on the bus and select the **TOOLS ➔ DUPLICATE AND DISTRIBUTE SOFTWARE FILE** command.

[Diagram of the utility interface]

- If there are custom versions of the software already on one or more devices, uncheck the **OVERWRITE DUPLICATES** checkbox unless you want them overwritten.

**Working with WorkPlace Tech**

While most files can be opened individually in their host application (e.g., double-click an Excel spreadsheet (.xls) file and it opens up in Excel), WorkPlace Tech works somewhat differently.

WorkPlace Tech uses its own Project (.wtp) file to group together a set of Applications, which are Visio (.vsd) files. The project file does not really contain any required information, it just organizes the files. Different software programmers will group their applications together in different ways, such as by function (Exhaust Fans) or by area (C Wing), that do not necessarily correspond to how Smartware Studio encourages you to organize the devices on the network tree.

The best way to store the WorkPlace Tech files in Smartware Studio is to put each individually Application (.vsd) File on the Files tab of the corresponding device in the network tree. This makes it clear and simple for software programmers and technicians to store and find the latest version of the file for each device.
To facilitate this organization, Smartware Studio allows you to open one or multiple WorkPlace Tech Application files directly from the network tree. When you do, the following occurs:

- All the relevant Application Files are downloaded from the server, if they aren’t already.
- The Application Files are copied to a temporary folder.
- A WorkPlace Tech Project (.wtp) File is created from scratch for the selected Application Files.
- WorkPlace Tech is launched and told to open this temporary project.

You can then work with the applications in WorkPlace Tech as normal, editing and saving the files as needed. When you shut down WorkPlace Tech, Smartware Studio detects the shutdown and compares the files in the temporary folder to the originals on the devices on the network tree. If any files have been changed or added, they will be copied back to the appropriate devices.

**Opening WorkPlace Tech**

To create and open a temporary WorkPlace Tech project with one or more Application Files, do one of the following:

- Right-click on a device, bus or folder containing devices and select the TOOLSÆOPEN WORKPLACE TECH menu command.
- Double-click on a single WorkPlace Tech Application (.vsd) File in the Files tab of a device.

If there are any Visio files in any of the devices that have not been scanned, they will be scanned now to determine if they are WorkPlace Tech Application Files. Refer to the earlier section on Scanning Files for more detail.
You will then be shown a list of all the devices under the selected node in the tree that have WorkPlace Tech files:

- To include any child devices in the list, check the SHOW FILES AND DEVICES IN SUB-FOLDERS AND CHILD ITEMS checkbox.
- You can specify a different PROJECT NAME as needed.

Select the files you want to be included in the WorkPlace Tech project and click the OPEN WORKPLACE TECH button.
WorkPlace Tech will then open with the temporary project and selected Application Files:

![Image of WorkPlace Tech project files]

Leave Smartware Studio and its project open while you work with WorkPlace Tech. When you are done, shut down WorkPlace Tech as you normally do. Smartware Studio will detect the shut down and present a list of the files that have changed:

![Image of Smartware Studio file list]

- Click the **RECAPTURE SELECTED FILES** button to copy the changed files back onto the corresponding devices in the network tree.
Creating a New WorkPlace Tech Application File
You can create a new, blank WorkPlace Tech Application File from the New menu on the device or its Files tab:

- Right-click the device item in the Network Tree or in the blank area of the Files tab and select **NEW → WORKPLACE TECH 5.X APPLICATION**.

The path to the blank WorkPlace Tech Application template file is determined automatically for WorkPlace Tech version 5.7 and 5.8. If WorkPlace Tech is not located in its default location, you may need to point to this file explicitly by going to **TOOLS → OPTIONS** and selecting the Other Software tab.

Creating New Application Files within WorkPlace Tech
If you create a new Application File while in WorkPlace Tech, Smartware Studio will recapture that file as well. Where it saves it depends on what part of the network tree you selected when you chose to open WorkPlace Tech.

- If you selected a bus or folder with child devices, the new file will be saved on that selected bus or folder.
- If you selected a single device or WorkPlace Tech file, it will be saved on that device.

In either case, Smartware Studio will indicate where it will be saved as it’s brought back in. You will likely want to create a device node on the network tree and relocate the file to its Files tab.

Exporting the Temporary WorkPlace Tech Project
If the need arises, you can choose to export the temporary WorkPlace Tech Project and collected Application Files that Smartware Studio creates.

- From the Open WorkPlace Tech dialog, choose the Application Files and click **EXPORT WORKPLACE TECH PROJECT**.
- Specify the **PROJECT NAME**, which will also be used for the folder name.
- You will be prompted to browse to the folder in which to save the project.
- This project folder can then be copied to an external location and opened by itself without Smartware Studio.

**Note:** When you export the project, Smartware Studio makes the copies but does not monitor for any changes. Any modified Application files will have to be copied back to Smartware Studio manually.
**Configuring the WorkPlace Tech Settings**

There are a few options you can set to help Smartware Studio work with WorkPlace Tech. You can access these from the TOOLSÆOPTIONS dialog on the Other Software tab.

- By default, Smartware Studio will wait 30 seconds for WorkPlace Tech to finish its startup tasks. On slower machines this may not be enough time and you might receive error messages that direct you to this dialog. Increase the **Time to Wait for WorkPlace Tech to Start** value as necessary.

- When working with the Designer module, the appearance of the WorkPlace Tech Visio stencils in the Visio Shapes menu can make it harder to find the Designer stencils, so Studio removes the WorkPlace Tech stencil path from Visio’s search list when Studio starts up and restores the path as needed. To disable this behavior, check the **Don’t Hide WorkPalce Tech’s Visio Stencil Paths When Studio Starts** checkbox.

- As noted in the earlier section *Creating a New WorkPlace Tech Application File*, if WorkPlace Tech is installed in a non-standard location, you may need to point Studio to the location of the blank application file.

**Working with XPSI**

Devices in the Schneider Electric Network 8000 product line use an older DOS-based program called XPSI. While the program is often used to manipulate the software file in the controller while directly connected to it, it can also be used to edit an offline, binary...
version of the software file. Smartware Studio makes it easier to edit such an offline file stored with a device in the network tree.

When you double-click a Network 8000 backup file (i.e., an .MZ2 file for a MicroZone II or a .PEM file for a PEM-1), the following occurs:

- The file is copied into the appropriate sub-folder of the XPSI application folder.
- XPSI is launched

To edit the file, go to the ACCESS menu and select the appropriate OFFLINE command for the type of device (e.g. MICROZONE II OFFLINE):

From the FUNCTIONS menu, select EDIT:
Then from the **Edit** menu select **FILE**: 

![XPSI EXE](image)

Finally, select the software file and begin editing. When you are done, save the file and exit XPSI.

If you made any changes, Smartware Studio will detect these changes and offer to copy the file back into Smartware Studio:

![Smartware Studio](image)
**Configuring the XPSI Program Settings**

To launch XPSI, Smartware Studio needs to know where the program is located. To modify these settings, select the TOOLS → OPTIONS menu command and go to the Other Software tab:

- By default Smartware Studio looks in `C:\PSI` for the application `XPSI.EXE`. 
8. Network Tree Devices

There are many different types of devices in the world, and Smartware Studio models the specifics of each by providing sets of items that can be added to the Network Tree. As described in the earlier chapter on the Network Tree, all devices share certain common properties and functionality, while others provide advanced and sophisticated utilities.

Most of the properties are self-explanatory and can be understood by reviewing the properties tab of the device.

This chapter will highlight the advanced features and utilities available on certain types of devices, specifically:

- I/A Network 8000 GCM Devices
- Niagara R2 Devices
- Continuum Devices
- PC Network Devices

I/A Network 8000 GCM Devices

The Network 8000 GCM (Global Control Module) and its derivatives are designed primarily to communicate with and provide global logic to a set of field devices on its ASD bus.

On the Network Tree, the device automatically includes an ASD bus.

- Depending on the variation of the GCM, it also include an LCM bus (GCMs), a Lon bus (LNCs) or a generic third-party bus (SIMs).

An active GCM includes a database of blocks at attributes that are used by the GCM to interact with the devices on its buses. If you capture this database from a GCM, you can use the information to automatically populate the devices on its buses in the network tree. The information can also prove useful in engineering and programming situations where it would otherwise be necessary to use another program to get at the data.
**Backing Up the GCM Block Database**
Although a GCM can be backed up using several older tools (such as Signal or Eclypse), Smartware Studio requires that the block data be captured directly using the free *Smartware Network 8000 Communications Utility*.

- You can download the utility and the instructions on how to use it from the Smartware web site:

  [http://www.smartwaretech.com/Nw8kConversionService.aspx](http://www.smartwaretech.com/Nw8kConversionService.aspx)

- The resulting backup will be in a custom Block (.BLK) format.

**Importing the GCM Block Database**
To import the block data into the GCM device:

- From the *I/A Network 8000* stencil in the toolbox, add a GCM object to the Network Tree.
- Copy the block database (.BLK file) to the Files tab of the GCM.
- Select the Blocks tab on the GCM and click the **OPEN GCM BLOCK DATABASE WIZARD** button.

- The .BLK file name should appear in the **BLOCK DATABASE FILE TO IMPORT** list. Click the **IMPORT** button.
The LOAD BLOCK DATA button should appear. Click it to load the block database onto two additional tabs: All Blocks and Device Blocks.

The Network Number and GCM Number properties will be filled in on the GCM’s Network tab.

The All Blocks tab shows a list of all the blocks in the GCM. As you select a block, the Attributes list on the right side will update to show the values of the inputs, outputs and parameters of the block.
Automatically Building the Network Tree from the GCM Database

Once imported, you can use the block information in the GCM to populate the devices beneath it on the Network Tree.

- Select the **Device Blocks** tab. A list of the blocks that represent devices (e.g. ZONE2, PEM1, FLO2, LIM and SIM) will be shown with their ASD Address.

- Select the devices to import. In most cases, you will want to SELECT ALL.
• Click the **CREATE SELECTED DEVICES ON GCM’S ASD BUS** button. The devices will be created on the GCM’s *Asd* bus.

![Network Tree Devices](image)

**LNC Devices**

An LNC (LON Network Controller) Device is a GCM that also has an *Lon* bus. Lon devices are represented by SIM blocks, which contain certain amount of information about how the inputs and outputs are mapped to the Network Variables (NVs) of the devices. The block database does not, however, contain information about the Lon Profile and SNVT types.

• You can import the block database and populate the Network Tree in the same way as a regular GCM. In fact, if there are SIM blocks in the database you will be warned that you must use the LNC device object instead of the GCM.

• Once imported, the **Device Blocks** tab will show the *Lon Subnet ID* and *Node ID* for each SIM device.

If you want to import additional information about the profiles and SNVTs, you can use WorkPlace Pro to create a Niagara R2 station from the Lon bus and import that as well. This temporary station will include the shadow objects for the Lon Devices.
To generate the temporary station, follow this generate procedure:

- Disconnect the Lon bus from the LNC.
- Connect the Lon bus to a laptop running WorkPlace Pro.
- Use the *LonDeviceManager* in the *LonWorksService* to "learn" a station that contains a shadow object for all the Lon Devices. You must also learn all the Network Variables. Refer to the *Niagara LonWorks Integration Guide* for more information.
- Save the generated station as a *config.xml* file.

Copy the *config.xml* file to the LNC’s File tab and open up the LNC Block Database Wizard. The LNC contains a separate tab named *SIM Blocks*. 
Click the LOAD LON PROFILES FROM LEARNED STATION button. Smartware Studio will match up the shadow objects in the config.xml file with the devices in the network tree based on the Lon Node IDs and extract the profile and SNVT information. Any exceptions or missing information will be reported:

- If a shadow object is not found, it often represents a device that has been decommissioned in the field but not removed from the LNC.
- For LonMark devices, the profile is extracted and will be available on the Software tab of the device.
• For LonWorks devices without a profile, the SNVT information is gathered into a text file named [Device] Lon Profile.csv that is stored on the device.

After loading the profile information, click the LOAD SIM BLOCK NV/SNVT INFORMATION button to load the profile information into the devices for viewing. Go to the All Blocks tab and select a SIM block. The attributes that map to NVs will show their name and type.
Niagara R2 Devices

There are a number of additional properties, tools and utilities associated with the Niagara R2 Devices, including:

- Bus Configuration
- Station Backups and Conversions
- License Properties
- View Station Tree
- Import and Re-synch Devices

**Bus Configuration Tab**

The *Bus Configuration* tab allows you to select the options (depending on the model of the UNC/JACE) and configurations of the communication ports. Doing so causes the appropriate buses to appear on the UNC device in the Network Tree.
**Backing Up a Station**

If the Niagara device is accessible over your network and it has the *WebUI* service installed, you can use Smartware Studio to back it up directly.

Select the *Station Backups* tab:

- If not already specified in the device’s properties, fill in the IP ADDRESS of the device, along with the USER NAME and PASSWORD of the station.
- Select the download format: XML or SNS.
- Optionally check the **SAVE SNS LOCALLY (ON UNC) BEFORE GETTING BACKUP** checkbox.
- Click the **GET STATION BACKUP** button. The backup will download and be saved as *config.xml* or *config.sns* on the device’s Files tab.

**Converting a Station Backup to a Different Format**

If *WorkPlace Pro* is installed on the same workstation, you can use the *Convert Station Backups* utility to convert the downloaded backup from one format to another. This utility directly accesses the WorkPlace Pro Admin tool, but saves the effort of copying the backup to and from the *Niagara* folder on your workstation.
Select the Station Backups tab to view the Convert Station Backups section:

- You can only convert files that are currently on the device’s Files tab. The converted file will be saved there as well.
- You can only convert using versions of Niagara that are installed on your workstation.

Studio assumes that Niagara is installed in the C:\Niagara folder. If it is installed in a different location, you can specify it explicitly by doing the following:

- From the Help menu, select About Smartware Studio (or Studio360).
- With the About box open, press Ctrl+Alt+Shift+I to open the Smartware Studio.ini file.
- Add the following section and entry (substitute your own root Niagara path):

  [Niagara]
  R2RootFolder=E:\Niagara

License Properties

For reference purposes it may be useful to store the License Properties of a Niagara device on the Network Tree. These values are available on a separate Properties tabs:
You can import these values directly from the license file.

- Copy the license file to the Files tab of the device.
- Select the License tab from the top-level list of tabs.

- Click the IMPORT LICENSE PROPERTIES button.

**View Station Tree**

Once you have a backup of the station in the XML format (config.xml), you can use this view this data and use it help build the Network Tree.

- Use the Backup Utility or otherwise get the config.xml file onto the devices Files tab.
- From the Niagara Wizard tab, click the OPEN NIAGARA STATION WIZARD button.
• Click the LOAD button, and then click LOAD TREE.

• This is a read-only view of the station backup.

**Import and Re-synch Devices**

The most powerful use of the station backup is to use the data to add the devices to the Network Tree.

• Use the *Backup Utility* or otherwise get the *config.xml* file onto the devices Files tab.
• From the *Niagara Wizard* tab, click the *OPEN NIAGARA STATION WIZARD* button.
• Click the *LOAD* button.
• Go to the Devices tab and click *IMPORT AND RESYNCH DEVICES.*
The output window will indicate what devices were found on the Asd, Lon and BACnet buses:

The devices will appear on the appropriate buses on the network tree:
Continuum Devices
There are three stencils in the toolbox for the devices in the Continuum product line:

- **NC2 + IOU**: NC2, I/O Modules (DI-8, etc.), AC-1s, DIO-20, etc.
- **Dist Ctrl**: bCX1, ACXs, i2xxx, b3xxx, b4920
- **xP Modules**: xPD18, xPU14, xP Display, etc.

These Network Tree items show the appropriate buses for communications and I/O Modules, and the Properties tabs show the specific Network properties for the addressing.

**Importing Devices from .DMP files**
If you have a backup from an NC2, bCX or network in the form of a .DMP file, you can use this file to build a portion of the network tree with many of the addressing values.

- Add an NC2 or bCX1 item to your network tree. If the backup file contains a larger portion of the network, add a Folder to the network tree.
- Drag or copy the .DMP file onto the Files tab of the device or folder.
• Go to the *Import Devices* tab

• The .DMP should already be selected. Click the IMPORT DEVICES button.

The output window will indicate what devices were found and their properties:
The devices will appear on the appropriate buses on the network tree:

**PC Network**

The PC Network stencil contains shapes for modeling the portion of a network dedicated to servers (file, web, mail, etc.) and workstations, along with the associated internet routing equipment.

The stencil contains shapes for a variety of devices:

- **Computers**  
  *Workstation, Server, Laptop*

- **Peripherals**  
  *Printer/Fax/Copier, Modem, External Storage Device, VOIP Phone*

- **Routing Devices**  
  *Ethernet Router, Firewall, Wi-Fi Access Point*

- **Remote Devices**  
  *Software Remote Connection*
The various devices have different buses:

*Ethernet, Usb, Serial Port, Parallel Port*

**The Ethernet Router**

There are a number of different types of Ethernet routing devices, including switches and hubs. The *Ethernet Router* shape is used to represent most of them.

You can adjust the shape to represent a variety of port configurations. The *Ports* tab shows these properties:

- Select the appropriate options to make one or more buses show on the router.
- You can rename the Router or any of the buses to better describe the devices and connections.
**Remote Connection**

The Remote Connection object is useful for storing the addresses, passwords and files needed to create a VPN or other type of remote connection to an external system.