Table of Contents

1. INTRODUCTION / GETTING STARTED ................................................................. 9
   Server and Workstation Installation ........................................................................ 9
   To Learn More about Smartware Studio .................................................................... 10
   To Contact Us .............................................................................................................. 10

2. INSTALLING SMARTWARE STUDIO ON A WORKSTATION ............................ 11
   Workstation System Requirements .......................................................................... 11
   Before You Install Smartware Studio ....................................................................... 11
   Install Microsoft .NET Framework (Version 4.8 or later) .......................................... 12
   Installing Smartware Studio ..................................................................................... 13
   When Installing on a Server to use the Installation and Setup Tools ....................... 13
   Automatic Updates ..................................................................................................... 14
   After Installing Smartware Studio .............................................................................. 14
   Register Your License ............................................................................................... 14
   Configure the Workstation ......................................................................................... 14
   Configuring Microsoft Visio and Excel ...................................................................... 14
   Install Microsoft Visio ............................................................................................... 14
   Reduce the Macro Security Setting in Microsoft Visio .............................................. 15
   Install Microsoft Excel ............................................................................................... 17
   Reduce the Macro Security Setting in Microsoft Excel ............................................. 18

3. WORKSTATION LICENSE REGISTRATION ......................................................... 23
   Licensing a New Computer ....................................................................................... 23
   Moving a License to another Computer .................................................................... 25
   Resetting a License from a Lost Machine .................................................................. 25
   Updating a License ...................................................................................................... 26
   Changing the Registered User on a Workstation ..................................................... 26
   Licensing a Computer not Connected to the Internet .............................................. 27

4. THE SMARTWARE STUDIO SERVER ELEMENTS ........................................... 29
   What Does Smartware Studio Need on the Servers? .............................................. 29
   The Shared Folder on a File Server .......................................................................... 29
   The SQL Server Database ......................................................................................... 30
   The Studio Windows Service ...................................................................................... 30
   Deciding Where to Install the Server Elements ...................................................... 30
   Using Virtual Machines ............................................................................................ 31
   Using Hosted Environments ...................................................................................... 31

5. SETTING UP AND CONFIGURING MICROSOFT SQL SERVER ........................ 33
   What is SQL Server? ................................................................................................. 33
   SQL Server Requirements ....................................................................................... 34
   Which Version of SQL Server? ................................................................................ 34
   Which Edition of SQL Server? ................................................................................ 34
   Should it be the 32- or 64-Bit Version? ................................................................... 35
   Where Should SQL Server Be Installed? ................................................................ 35
   What Does Smartware Studio Need from SQL Server? .......................................... 35
   What If SQL Server is Already Installed? ................................................................ 35
Installing SQL Server ..........................................................36
Installing Microsoft SQL Server (Full Edition) ..................................36
Installing Microsoft SQL Server Express Edition .................................36
Configuring SQL Server ................................................................37
The SQL Server Configuration Manager ..............................................37
Enable SQL Server Browser Service ...............................................39
Enable TCP/IP ........................................................................41
Connecting to the SQL Server using SQL Server Management Studio ........................................................................43
Mixed Mode Authentication ..................................................................44
Allow Remote Connections to the SQL Server ...................................46
Restarting the SQL Server ..................................................................48
Opening up the Firewall ....................................................................48

6. CONFIGURING THE SMARTWARE STUDIO SERVER ELEMENTS ... 51
Using the Server Setup Wizard ...............................................................51
   Step 1: File Server Setup ................................................................52
   Step 2: Select the SQL Server ........................................................53
   Step 3: Specify How to Log into SQL Server to Create the Database .....54
   Step 4: Test the SQL Connection ...................................................54
   Step 5: Specify the Database Name and SQL Account to Create ..........55
   Step 6: Create the SQL Database ...................................................56
Configuring Additional Workstations to Point to the Server ....................57
Moving the Server Elements to a New Location .....................................58
   Moving the SQL Server Database ....................................................58
   Moving the Shared Folder ................................................................63

7. ADMINISTERING SMARTWARE STUDIO ................................65
Installing Additional Workstations .......................................................65
Adding and Managing Users ...............................................................66
   Adding a New User ........................................................................67
   Managing Users ...........................................................................67
Managing Workstation Licenses ...........................................................68
   Resetting a License ........................................................................69
Smartware Studio Application Updates ...............................................69
   Installing and Publishing a Beta Version .........................................71
   Prompt for a Different Login During Installation ..............................71
Upgrading the Studio SQL Server Database ........................................72
Back Up the Studio SQL Database ......................................................73

8. MANAGING SERVER FILES AND PROJECTS ..........................75
Managing Server Files .......................................................................75
   Viewing Server File Sizes and Purging Older Data ............................75
   Searching Server Files ....................................................................77
   Viewing File Download History .......................................................77
   Server File Update Utility ...............................................................78
Managing Server Projects ...................................................................79
   View Project Statuses and Purge Deleted Projects ............................79
   Viewing Previous Versions of Projects ............................................79
   Reporting on Server Projects .........................................................80
9. CONFIGURING A SMARTWARE STUDIO WORKSTATION ........................................ 81

Workstation Options ........................................................................................................... 81
   Setting a Workstation Region ......................................................................................... 82
Local Files Folder ................................................................................................................ 83
Server Settings .................................................................................................................. 84
Connectivity ...................................................................................................................... 85
   Checking Connectivity .................................................................................................. 85
Parts Database ................................................................................................................... 86
Designer Module ................................................................................................................. 86
PDF Files .......................................................................................................................... 87
PDF Generator .................................................................................................................. 87
   Installing Ghostscript ..................................................................................................... 88
   Installing the CutePDF Driver ......................................................................................... 88
Additional Configuration Settings ...................................................................................... 89
   Estimating Module ......................................................................................................... 89
Prometheus ....................................................................................................................... 89
Import / Export Options ................................................................................................... 89
3rd Party Software .............................................................................................................. 90
Template Files ................................................................................................................... 90
System Library .................................................................................................................. 90

10. SETTING UP PERMISSIONS .................................................................................... 91

Overview of Permissions in Smartware Studio ................................................................. 91
Managing Permissions ......................................................................................................... 92
Creating User Groups for Permissions .............................................................................. 94
Project-Level Permissions ................................................................................................. 95
   Creating Project-Level Permissions for a Group or User ................................................. 95
   Editing Project-Level Permissions ............................................................................... 96
   Individual Project Permissions .................................................................................... 97
Enforcing Permissions ........................................................................................................ 98
Folder-Level Permission Sets ............................................................................................. 98
   Overview ....................................................................................................................... 98
   Creating a Permission Set ............................................................................................. 99
   Specifying the Permissions in a Permission Set ............................................................. 100
Assigning a Permission Set to a Folder in a Project .......................................................... 101
Assigning a Permission Set to Multiple Folders in Multiple Projects ................................ 102
Using Impersonation to Lock Down the Server Folder ..................................................... 103

11. THE PARTS DATABASE MANAGER .......................................................................... 105

Accessing the Parts Database Manager ............................................................................ 105
Keeping the Parts Database Up to Date ............................................................................ 106
   The Dashboard ............................................................................................................... 106
   What Does Synchronizing to the Smartware Master Database Do? ............................. 108
   What Does Publishing to Users Do? ............................................................................. 108
Subscribed Parts ................................................................................................................ 108
Quick Start Setup of the Parts Database ......................................................................... 109
   Open the Parts Database Manager .............................................................................. 109
   Synchronize the Company’s Parts Database with Smartware’s .................................. 109
   Update the Discount Multipliers .................................................................................. 109
Publish the Parts Database for Smartware Studio Users ................................................. 110
Adding and Updating Individual Parts ................................................................. 111
Selecting Top Parts......................................................................................... 111
Adding a New Part .......................................................................................... 112
Updating a Part ............................................................................................... 113
Custom Vendors .............................................................................................. 114
Adding a Manufacturer or Vendor ................................................................. 115
Updating or Adding a Discount Multiplier ......................................................... 116
Duplicating an Existing Part ............................................................................ 117
Importing Multiple New Parts ......................................................................... 118
Step 1: Create the Import Spreadsheet ............................................................. 118
Step 2: Import Parts from Spreadsheet ............................................................. 119
Step 3: Preview and Verify the Imported Parts ................................................ 119
Exporting and Updating Multiple Parts ............................................................ 120
Step 1: Create a Part Import Spreadsheet by Exporting Existing Parts .......... 120
Step 1a: Update the values in the Spreadsheet using Excel ......................... 121
Step 2: Import the Updated Values from the Spreadsheet ............................. 121
Step 3: Preview and Verify the Updated Part Values ..................................... 122
Step 4: Update the Database with the Changes .............................................. 122
Part Properties .................................................................................................. 123
Extended Properties ....................................................................................... 123
Importing and Exporting Extended Property Values ....................................... 126
Multiple Configuration Sensors ....................................................................... 127
Part Groupings .................................................................................................. 128
Labor Factors and Part Categories ................................................................... 129
Specifying Labor Factors for a New or Existing Part ..................................... 130
Specifying Labor Factors when Importing and Updating Multiple Parts .... 131
Specifying Labor by Part Categories .............................................................. 132
Using Custom Categories for Labor Codes .................................................... 134
Managing PDF Files ....................................................................................... 136
Downloading PDFs and Part Images for Smartware Master Parts ................ 136
Where the PDF Files are Stored on Your Server ........................................... 137
Publishing PDFs to Users ................................................................................ 137
User Parts .......................................................................................................... 138
Submitting and Approving User Parts ............................................................. 138
Being Notified of User Parts Awaiting Approval ............................................ 139
Part Packages .................................................................................................. 140
Updating Packages ........................................................................................ 141
Service Equipment and Tasks .......................................................................... 141

12. THE STUDIO WINDOWS SERVICE ............................................................. 143

Installing the Studio Windows Service ............................................................ 143
Create a Domain User for the Service (Optional) ............................................ 144
Install the Service ........................................................................................... 144
Manually Controlling and Configuring the Service through Windows .......... 145
Configure an Outgoing SMTP Server ............................................................... 146
Testing the Outgoing SMTP Server ................................................................. 148
Configure Status Emails ............................................................................... 148
The Email Forwarding Service ........................................................................ 149
Overview of the Email Forwarding Service .................................................... 149
Setting up an Incoming SMTP Server ............................................................. 149
Configure the Email Forwarding Service ....................................................... 150
Managing Multiple Servers .......................................................................... 150
Specifying an Email Alias for a Folder ........................................................... 151
Emailing to a Project ...................................................................................... 152
Generating an Email Import List ..................................................................... 152
The Notifications Service ................................................................. 153
  Subscribing to File Notifications ................................................. 153
  Enabling the File Notifications Service ...................................... 154
  Administrator Notifications ....................................................... 155
The Password Monitoring Service .................................................. 155
  The Device Password Log Report .............................................. 156
Other Services ............................................................................ 157
Example: Setting up an Incoming SMTP Server ............................. 157
  Example: Creating a DNS Record for Subdomain in Windows Server 157
  Example: Installing an IIS SMTP Server – Windows Server 2008 R2 158
  Example: Configuring an IIS SMTP Server – Windows Server 2008 R2 160

13. ENTERPRISE MANAGEMENT AND REPORTS .............................. 163
Enterprise Reports ........................................................................ 163
  The Project Statistics Report ...................................................... 164
  Point Statistics ......................................................................... 164
  Designer Drawings using MFLs ............................................... 165
Configuring a Multi-Server Enterprise ......................................... 165
  Account Family Administrators ............................................... 165
  Remote Users .......................................................................... 166
  Remote Login .......................................................................... 167
Enterprise Features ..................................................................... 167
  The Enterprise Distribution Folder ......................................... 167
  Distributing Enterprise Files .................................................... 168
  Other Enterprise Features ......................................................... 169

14. LIBRARIES, TEMPLATES AND DISTRIBUTIONS ........................ 171
The Resource Folders .................................................................. 171
  The Resource Folder Locations .............................................. 171
  Adding Custom Resource Files .............................................. 171
  The Resource Folders ............................................................... 172
  Updating and Recalling Distributed Files .................................. 173
  Designer Module Templates .................................................. 174
  My Documents Distributions .................................................. 174
Checking for Updates ................................................................. 175
  The Background Updater ......................................................... 176
  Download Options .................................................................. 177
Multi-File Libraries ..................................................................... 177
  Distributing MFLs ................................................................. 177
  Submitting and Approving User Created MFLs ........................ 178
  Schneider Electric MFLs ......................................................... 178
Schneider Electric Distributables .................................................. 179
  Downloading the Distributables to the Company Server .......... 179
  Downloading the Distributables to a Workstation ..................... 180
Customizing the "New" Files Menu ............................................. 181
  Mail Merge Documents ......................................................... 184
  Designer and Estimate Reports .............................................. 185
  Enterprise Version of the 'New' Menu ...................................... 186
15. **CLOUD ACCOUNTS** ............................................................................................................. 187
   How Studio Integrates with a Cloud Account ........................................................................... 187
   Configuring a Box Cloud Account ......................................................................................... 188
      Setup and Configure a Box Developer Account .................................................................. 188
      Register the Box Account with Smartware Studio ............................................................. 189
      Configuring the Cloud Account Service ............................................................................... 192
   Sharing Files with a Cloud Account through Studio ............................................................... 194
   Cloud Account Reports .......................................................................................................... 195

16. **SMARTWARE STUDIO MOBILE APPLICATION** ............................................................... 197
   Configuring the Studio Web Service ...................................................................................... 197
      Testing the Connection ........................................................................................................ 199
   Creating a Self-Signed SSL Certificate .................................................................................. 199
      Starting IIS ........................................................................................................................... 199
      Generating the Certificate .................................................................................................. 200
      Certificate Generation Problems ...................................................................................... 202
   Install the Notifications Certificate ..................................................................................... 203
      Installing the Certificate ...................................................................................................... 203
   Open the Ports in the Firewall ............................................................................................... 207
      Configuring Windows Firewall ........................................................................................... 207
   Testing Communication through the Firewall ......................................................................... 207
   Installing and Configuring the Mobile Application ............................................................... 211
      Permitting the Mobile Applications .................................................................................. 211
      Installing and Configuring the Mobile App on a Mobile Device ....................................... 212
      Licensing the Mobile Application ...................................................................................... 213
   The Mobile Applications ........................................................................................................ 213
      Projects (Studio Mobile Core) ............................................................................................. 213
      Schedule ............................................................................................................................. 214
1. Introduction / Getting Started

This Guide is designed to help get your company up and running with Smartware Studio. It is intended for the people in your organization responsible for installing and maintaining your servers and workstations, as well as for the people who organize the data and files for your projects.

Server and Workstation Installation

Smartware Studio is a client-server based system. All the shared data is stored on your servers, while the program is installed on each user’s workstation.

- The data on the server is stored in a shared folder on a file server and a SQL Server Database. Refer to Chapter 4 (The Smartware Studio Server Elements) for more information.

To begin you will want to set up the server elements directly on the server.

- Install Smartware Studio on your server, only for the purpose of using the ADMIN menu tools. You DO NOT need to license it in order to use the tools available from the ADMIN menu. You will only need to log into the Smartware server using a user account with administrative privileges.

**NOTE:** When doing the initial setup of the shared folder on your file server, several folders will be created that must allow read permissions to all and write permissions to some. Depending on your network, if you are logged into the server as an administrator with too much permission (e.g. a Domain Administrator), the security levels on those folders may be too high. It is recommended that you avoid doing the setup while logged in as a Domain Administrator.

- Review [Chapter 4: The Smartware Studio Server Elements](#) and [Chapter 5: Setting Up and Configuring Microsoft SQL Server](#) of this Guide and then configure the Server Elements as detailed in [Chapter 6: Configuring the Smartware Studio Server Elements](#).

- Install Smartware Studio on your first workstation ([Chapter 2: Installing Smartware Studio on a Workstation](#)). License the workstation ([Chapter 3: Workstation License Registration](#)), which should automatically point the workstation to the server.

- Create additional users as needed ([Chapter 7: Administering Smartware Studio](#)).

- Install, license and configure additional workstations as needed ([Chapter 9: Configuring A Smartware Studio Workstation](#)).
After the initial setup is complete and working properly, you can setup and configure these other features from any workstation (providing you have the appropriate administrative rights):

- **Permissions**, which allow you to limit access to certain data to certain groups of people, are detailed in Chapter 10.
- The **Parts Database**, which is used extensively by the Designer Module (Design360) and Estimating Module, and is also available for browsing from all workstations, is detailed in Chapter 11.
- The **Studio Windows Service**, detailed in Chapter 12, allows for additional features that need to be managed by a server, such as:
  - Allowing your users to send emails and attachments directly to a Smartware Studio project from Outlook or another email client.
  - Allowing users to subscribe to and be notified of changes and additions to individual files or entire folders.
  - Sending administrators notifications of Network Tree passwords that have been viewed or changed.
- The **Studio Mobile Application** and how to configure it is described in Chapter 16.

**To Learn More about Smartware Studio**
All of the Guides, including the *Smartware Studio User’s Guide*, are available on the Help menu or on our web site.

**To Contact Us**
Our technical support team is available weekdays from 8 am to 5 pm eastern time at (716) 213-2222. You may also visit our web site at [www.smartwaretech.com](http://www.smartwaretech.com) or email us at [techsupport@smartwaretech.com](mailto:techsupport@smartwaretech.com).

Additionally, all Smartware support and contact information can be found in the Help → About Smartware Studio / Studio 360 menu (depending on which version of the software you have).
2. Installing Smartware Studio on a Workstation

Before you install Smartware Studio, please review the following sections that note a few simple, yet very important prerequisites and configuration issues.

Workstation System Requirements
Smartware Studio will run on most any modern Windows-based PC. The following are the minimum and recommended system requirements:

- Windows 7 (32-bit or 64-bit). It will not run on Windows XP.
- Windows 8.1 (32-bit or 64-bit).
- Windows 10 Version 1607 or later (32-bit or 64-bit) (recommended).
- 4 GB RAM
- 5 GB Disk Space minimum

Certain features may also require one or more of the following:

- Microsoft Visio (2007 or later)
- Microsoft Excel (2007 or later)
- Microsoft Word (2007 or later)

The 2003 versions of Visio, Excel and Word are no longer officially supported, but should still work. However, some newer features may not be available and future versions of Studio may not support them at all.

Be sure to install all recommended Windows updates, including the Microsoft .NET Framework Version 4.8 (or later).

Before You Install Smartware Studio
You should install or configure the following components and applications before you install Smartware Studio.
**Install Microsoft .NET Framework (Version 4.8 or later)**

You should have installed on your machine all available updates and service packs from Microsoft. Specifically, you must have Version 4.8 (or later) of the Microsoft .NET Framework installed. The .NET Framework is a run-time environment for modern Windows programs, and generally does not interfere with any other aspect of the operating system.

Some versions of the .NET Framework are independent of others and installing a newer one does not necessarily replace those older ones. You should NOT uninstall any older versions manually, as they may be used by other software on your machine.

At the time of this writing, this version of .NET should be an automatic update through Windows Update.

You can also download and install Version 4.0 of the .NET Framework directly from Microsoft’s web site. Do a search on the phrase “Download Microsoft .NET 4.8” to quickly find the appropriate page.

To determine which versions of the .NET Framework are installed, go to PROGRAMS AND FEATURES from the Windows Control Panel.
Installing Smartware Studio

The latest release of Smartware Studio can be found on our web site at www.smartwaretech.com. Click on the link for the Smartware Studio page and review the Downloads list on the bottom half of the page. There you will find the latest setup file, along with a number of documents regarding new features and other current topics.

- Download the SMARTWARE_STUDIO_SETUP_v4.x.xx.msi installation file.
- Run it and follow the instructions.
  - Upon initial installation and setup, Smartware Studio will ask where you would like to create the current workstation’s Local Project Folder. You can either keep the default folder location in My Documents or specify a custom folder location of your preference. This should be a location you are familiar with and can access easily.
    - It is strongly recommended that this be a folder on a local hard drive, and not a network server.
    - This can always be changed later if needed. Refer to the later section Local Files Folder, in the chapter Configuring a Smartware Studio Workstation.

When Installing on a Server to use the Installation and Setup Tools

When doing the initial installation and setup of the shared folder and database, it is a good idea to install Smartware Studio directly on the server to use the Administration and Setup tools available on the Admin menu.

- You will not need to license the software on the server to use the Admin tools.
- Once the server setup is complete, you will need to install and test the first workstation to ensure that the setup is complete. There are network settings and firewall issues that won’t be apparent when connecting from Studio on the same machine as the server folder and/or database.

When doing the initial setup of the shared folder on your file server, several folders will be created that must allow read permissions to all and write permissions to some. Depending on your network, if you are logged into the server as an administrator with too much permission (e.g. a Domain Administrator), the security levels on those folders may be too high. It is recommended that you avoid doing the setup while logged in as a Domain Administrator.
Installing Smartware Studio on a Workstation

**Automatic Updates**
When you launch Smartware Studio, it will check to see if an updated version is available. If you are an IT Administrator, you will be given the opportunity to download the new release to your server so other users will be prompted to download it. If not, you will be told to contact your IT Administrator.

Refer to the later chapter, *Administering Smartware Studio* for more information.

**After Installing Smartware Studio**
After you install Smartware Studio, you will need to license the software and optionally configure some settings in other programs.

**Register Your License**
When you first run Smartware Studio, you will be prompted to register your license. In order to do so, you will need a 9-digit pass code from Smartware Technologies or an Account Administrator in your organization. Refer to the next chapter, *Workstation License Registration*, for complete information on license registration, update and transfer.

**Configure the Workstation**
When you register a workstation license after the server elements have been configured, the workstation will automatically download all the information it needs to properly connect to the server.

Most of the default settings for a workstation should suffice to get started, though there are a few settings that may need to be updated. Many of these are referenced throughout the various Guides. Refer to the later chapter on *Configuring the Smartware Studio Server Elements* in this Guide for details on all the various workstation options.

**Configuring Microsoft Visio and Excel**
The Designer Module (Design360) works with Microsoft Visio drawings and Excel spreadsheets. Some of these features require that you reduce their macro security settings to work properly. Refer to the remaining sections of this chapter for details.

**Install Microsoft Visio**
The Designer Module (Design360) uses Microsoft Visio to view and edit drawing files. You can use Visio 2007 or later (Visio 2003 is no longer officially supported, but may still work. However, some newer features may not be available and future versions of Studio may not support them at all).
Either edition (Standard or Professional) will work the same.

After installing Visio, you should launch it once to answer any additional startup information it requires. Specifically, you should make sure it is “activated” as required by Microsoft. Inactivated software has a limited number of launches before being disabled.

**Reduce the Macro Security Setting in Microsoft Visio**

Visio has security features that warn you when documents with macros are being loaded. Since almost all of the Designer documents contain macros, the warnings messages will become bothersome for most users. While we recommend that you lower the security settings from their initial settings of *Medium* (ask before loading macros) to *Low* (allow macros without warning), you must remain aware of the potential dangers of viruses in macros from documents obtained from unreliable sources.

You cannot have the macro security levels set to *High*, as that prevents macros from being run at all.

**In Microsoft Visio 2003 (no longer officially supported)**

To change the Macro Security settings in Microsoft Visio 2003:

- Start Microsoft Visio.
- On the **TOOLS** menu select **MACROS / SECURITY**…

- Select either LOW (recommended) or MEDIUM security.
Installing Smartware Studio on a Workstation

- Click the tab labeled TRUSTED SOURCES and check the box labeled TRUST ACCESS TO VISUAL BASIC PROJECT.
- Close Microsoft Visio.

**In Microsoft Visio 2007**
To change the Macro Security settings in Microsoft Visio 2007:

- On the TOOLS menu, select TRUST CENTER…
- Choose the MACROS SETTING tab

- Select the ENABLE ALL MACROS setting
- Check the TRUST ACCESS TO THE VBA PROJECT OBJECT MODEL checkbox
- Close Microsoft Visio

**In Microsoft Visio 2010 or Visio 2013**
To change the Macro Security settings in Microsoft Visio 2010 or Visio 2013:

- On the FILE menu, select OPTIONS…
- Select the TRUST CENTER tab
- Click the TRUST CENTER SETTINGS… button
• Choose the MACROS SETTING tab

![Image of Trust Center window]

- Select the ENABLE ALL MACROS setting
- Check the TRUST ACCESS TO THE VBA PROJECT OBJECT MODEL checkbox
- Close Microsoft Visio

**Install Microsoft Excel**

While earlier versions and older features of Smartware Studio used Excel more frequently and required more settings, Studio now uses its own Excel file library to generate reports and other documents, and only opens Excel when displaying the results. You probably don't need to change the Excel security settings unless you encounter one of the older features.

*NOTE: The rest of this section is included for backward compatibility with those features*

Smartware Studio uses Microsoft Excel for a number of important features, such as the generating reports and editing Designer Valve Schedules. These features will not function without Excel. You can use Excel 2007 or later (Excel 2003 is no longer officially supported but should still work. However, some newer features may not be available and future versions of Studio may not support them at all).

Either edition (Standard or Professional) will work.
Reduce the Macro Security Setting in Microsoft Excel

For some of the Designer Module’s older versions of certain features (Valve Schedule and Smart Chart) to work properly, you must reduce the macro security level in Excel. For most other Excel-related features, the macro security level is not important.

Excel has security features that warn you when documents with macros are being loaded. Since almost all of our documents contain macros, the warnings messages will become bothersome for most users. While we recommend that you lower the security settings from their initial settings of Medium (ask before loading macros) to Low (allow macros without warning), you must remain aware of the potential dangers of viruses in macros from documents obtained from unreliable sources.

You cannot have the macro security levels set to High, as that prevents macros from being run at all.

In Microsoft Excel 2003 or earlier (no longer officially supported)

To change the Macro Security settings in Microsoft Excel 2002 or Excel 2003:

• Start Microsoft Excel
• On the TOOLS menu select MACROS / SECURITY…

![Security settings window]

• Select either Low (recommended) or Medium security.
• In Excel 2002 only, click the tab labeled TRUSTED SOURCES (or TRUSTED PUBLISHERS) and check the box labeled TRUST ACCESS TO VISUAL BASIC PROJECT. This change is required to make full use of the Smart Chart features.
• Close Microsoft Excel
*In Microsoft Excel 2007*

To change the Macro Security settings in Microsoft Excel 2007:

- Open the main menu by clicking the Excel icon in the upper left corner.
Installing Smartware Studio on a Workstation

- Click on the EXCEL OPTIONS button.

![Excel Options Dialogue Box]

- Choose the MACROS SETTING tab

![Trust Center Dialogue Box]

- Select the ENABLE ALL MACROS setting
- Check the TRUST ACCESS TO THE VBA PROJECT OBJECT MODEL checkbox
- Close Microsoft Excel
In Microsoft Excel 2010 or Excel 2013
To change the Macro Security settings in Microsoft Excel 2010 or Excel 2103:

- On the FILE menu, select OPTIONS
- Select the TRUST CENTER tab
- Click the TRUST CENTER SETTINGS button
- Choose the MACROS SETTING tab

- Select the ENABLE ALL MACROS setting
- Check the TRUST ACCESS TO THE VBA PROJECT OBJECT MODEL checkbox
- Close Microsoft Excel
3. Workstation License Registration

Each copy of Smartware Studio needs to be licensed before it can be used (except for Administrative and Setup functions, which will still operate without licensing). To activate a license on a machine you will need a user account login (your email address and a password) and a 9-digit passcode for a license account (from our sales and support department or an Account Administrator in your organization).

You will need to be connected to the internet to register the license.

Licensing a New Computer
When you start Smartware Studio when it is unlicensed, the Product License Registration dialog will automatically open:
• You can also bring this form up at any time by selecting **FILE → PRODUCT LICENSE REGISTRATION**.

Click on the **REGISTER LICENSE** button. You will be asked for your login information and the 9-digit passcode.

![Login to Smartware Technologies](image)

**NOTE:** The password here is associated with your Smartware Studio account, which is the same as the one used by our Network 8000 Documenting Service. It is not the same as the one used by the older Smartware Technologies web site for licensing our Designer Suite 2005 or WorkPlace Pro Utilities (I/A SMART) packages. If you have any questions or confusion, please contact our technical support department.

Click OK and your license will be registered:

![Thank you for using our product. Your license has been registered successfully.](image)

• A passcode can only be used one time, though you can give back your license to get a new passcode at any time.
Moving a License to another Computer

To move your license from one computer to another (from an office desktop to a home laptop, for instance), you simply give back the license from the first machine by clicking the GIVE BACK LICENSE button in the License Registration dialog.

![License Registration dialog](image)

This will deactivate the license on the first computer and return to you a new 9-digit passcode. You can then use this new pass code to license a different computer using the procedures detailed in *Licensing a New Computer*.

If you forget the code, it will still show in the Product License Registration form:

![Product License Registration](image)

Resetting a License from a Lost Machine

If a machine with a Studio license is lost due to a hard drive crash or other failure, contact an account administrator to reset the license and issue a new passcode.

Refer to the section *Managing Workstation Licenses* in chapter *Administering Smartware Studio*, later in this Guide.
Updating a License

The license needs to be updated periodically. This allows us to automatically check for system updates and to enable new features. In most cases, Smartware Studio will update itself automatically, continually extending the license period out 90 days any time it can connect to the internet.

If you add new modules or features to an existing license account, you may need to update the license explicitly. Simply click the UPDATE LICENSE button.

Changing the Registered User on a Workstation

It is important that the correct user be associated with each workstation, as various transactions (e.g., uploading files) are logged with the user of the machine. If a machine is reassigned to a different user, you should update the license to reflect the new user.

To change the user, you can either:

- Give Back the license (which will give you a new passcode), then relicense the machine using the new user’s email address and password.

Or

- From the ADMIN menu, select USERS AND LICENSES. You will be prompted to log into the server.
- Select the LICENSES tab.
- Locate the appropriate license record and double-click it or right-click and select EDIT LICENSE.
• In the REGISTERED USER field, select the new user:

**Licensing a Computer not Connected to the Internet**

At this time, it is not possible to license a computer if it is not connected to the internet. If this poses a problem for you, please [contact us](#) to discuss the issue.
4. The Smartware Studio Server Elements

This chapter will discuss the various elements that are needed on the server side to allow Smartware Studio to be work in a network environment. The chapters that follow discuss these elements and their installation and configuration in detail.

What Does Smartware Studio Need on the Servers?

The minimal elements that Smartware Studio needs are:

- A Shared Folder on a File Server
- A SQL Server Database

In addition, there is a Studio Windows Service which can be installed and configured to provide additional features:

- Notifications for changes in Subscribed Files and Folders
- Notifications about Tasks
- Notifications for Device Password actions
- Email Forwarding
  - This feature also requires the setup and configuration of an Incoming SMTP Server.
- Cloud Account Synchronization
- Web Service support for the Studio Mobile Application
- Task Scheduler for Management Imports
- Outgoing Email for all other services
  - The features of the Studio Windows Service also require an available Outgoing SMTP Server, often available from an ISP or other commercial provider.

The Shared Folder on a File Server

Smartware Studio is designed to store, manage, share and version all types of data. You may choose to store any or all of your project related files in Smartware Studio, including estimates, job booking data, engineering and submittal drawings, correspondence, software program files, software backups and reports.
All of this data, and all of Smartware Studio’s configuration information, is kept in a single folder that will need to be accessible by all your users. It is highly recommended that this folder be on a drive that is backed up regularly and that has enough capacity to meet your needs.

- The folder can be located on any file server, as long as it can be accessed by all the workstations that will be using Smartware Studio. Refer to the later chapter on Permissions regarding how the access can be restricted.
- You should reference the folder by a standard UNC path (e.g. \ourserver\Data).
- Referencing the folder through a common mapped drive letter is not recommended as some workstations may be set up differently.

The SQL Server Database
Smartware Studio will store data indexes, transactions and other metadata in a Microsoft SQL Server Database.

- You can use the free Microsoft SQL Server Express Edition or another licensed version (refer to the later chapter Setting Up and Configuring Microsoft SQL Server).
- You will need to configure SQL Server to allow remote connections (refer to the later chapter Setting Up and Configuring Microsoft SQL Server).
- Smartware Studio will walk you through the automatic creation of its database and tables (refer to the later chapter on Configuring the Smartware Studio Server Elements).
- There are features in Smartware Studio to help manage the updating and backing up of the SQL Server Database.

The Studio Windows Service
The Studio Windows Service handles features that require server intervention or scheduled tasks. Refer to the later chapter, The Studio Windows Service, for more information on installing and configuring the service.

Deciding Where to Install the Server Elements
While there are no concrete rules for where the server elements should be installed amongst your existing servers, there are some guidelines:

- The Shared Folder can be located on any machine that can be accessed by all the users (local and VPN) as well as the other server elements. It should have sufficient disk space to store all the files (including older versions of files) and should be part of your regular backup procedures.
• The SQL Server should be installed so it can be accessed by all the users (local and VPN).
• Take caution if installing the Smartware Studio database on an existing SQL Server being used by another application. You must configure certain SQL Server settings, which might interfere with the other application’s operations.
• The Studio Windows Service, if used, must be able to connect to the SQL Server and the Shared Folder. It should not be an issue to install and run the Service on a machine running one of the other Server Elements.

**Using Virtual Machines**

There are no known issues running any of the server elements on servers in a virtual environment.

**Using Hosted Environments**

It is possible to use a hosted cloud server, such as Amazon's AWS, to host the Server Elements.

• In general, you would treat the cloud server as any other, installing SQL Server Express, setting up the Studio database, and designating the shared folder for the files.
• You will need to establish a VPN connection between that server and the workstations, such that the workstation can access SQL and the files as if they were on a local server.
• While you can use a Microsoft Azure Windows platform (essentially a hosted Virtual Machine), you cannot use a Microsoft Azure hosted database as a replacement for an installed version of Microsoft SQL Server.
  o Instead, SQL Server (Express) must be installed on the VM.
  o For reference, the issue has to do with incompatibilities between the T-SQL language on the Azure hosted database and the native SQL Server installations.
5. Setting Up and Configuring Microsoft SQL Server

Smartware Studio needs to create and maintain a Microsoft SQL Server database. Almost all setup and communication with the database itself are handled by Smartware Studio, but the initial installation and configuration of Microsoft SQL Server needs to be done first.

This chapter will outline some important settings that are required to allow Smartware Studio to communicate with SQL Server. It is by no means a complete description of how to setup and configure that program. It will attempt to highlight key steps and note troubleshooting issues that we have discovered in the real world.

NOTE: As with all software, especially sophisticated server systems such as SQL Server, there are many variables that can affect its ability to work as expected in specific scenarios, including other software that is installed on the server and other Windows Server settings.

If you experience problems setting up SQL Server, we will make every attempt to help you diagnose and resolve your problem. We cannot, however, guarantee that we can make SQL Server function on every specific server. In some cases, our recommendations may include using a different server machine.

What is SQL Server?

A Database Server (or Database Management System [DBMS]) is a software program used by other applications to store and retrieve data. Most sophisticated software packages, such as Accounting Packages, use a database server as their storage system. There are a number of popular Database Servers on the market, including Oracle, IBM’s Cloudscape, and of course Microsoft’s SQL Server.

SQL (pronounced S-Q-L, or very often “sequel”) is a language used by most modern Database Servers to add and retrieve the data. In general, a SQL Server refers to any Database Server that uses the SQL language. In common parlance, however, SQL Server is most often used to refer specifically to Microsoft SQL Server.

From herein, the term SQL Server will likewise refer specifically to Microsoft SQL Server.
SQL Server Requirements
This section will help you determine which version and edition of SQL Server you should use.

Which Version of SQL Server?
Smartware Studio is designed to work with Microsoft SQL Server (2008 or later).

- It will not work with Microsoft SQL Server 2000
- The current recommendation is SQL Server 2012 or later.
- We have found that SQL Server 2005 may have performance issues compared with later version and should therefore be avoided.
- If installing on Windows Server 2012 or later, you must use SQL Server 2012 or later.

Which Edition of SQL Server?
Microsoft SQL Server comes in many editions under a wide variety of licenses. For the sake of this discussion, we will refer to them as:

  A free version of SQL Server that Microsoft makes available to everyone to download from their web site. While it does have some limitations regarding the size of a single database or the amount of processing cores that the software will utilize, it is quite sufficient for most Smartware Studio applications, especially when beginning. A database created in SQL Server Express can be used by the full version of SQL Server as well, so it will be easy to upgrade as your needs evolve.

  All other licensed versions of SQL Server.

Smartware Studio will work fine with the free SQL Server Express. As your database grows, however, it may be necessary to upgrade to a licensed version of SQL Server.

SQL Server Express can also be installed on the same computer as another edition of SQL Server.
Should it be the 32- or 64-Bit Version?
As far as Studio is concerned, there should be little difference in how the two versions operate. There are performance and resource utilization differences depending on what else the SQL Server is used for, so if this is a concern you should search the internet for further details.

Where Should SQL Server Be Installed?
SQL Server will run on most current versions of Windows Server, as well as on workstations with Windows 7 or later. Although some people install it on its own machine, SQL Server is often installed alongside other server components such as IIS or other applications.

For the purposes of Smartware Studio, it is only necessary that the instance of SQL Server be visible to all the machines that will need to access it, including workstations. This connection can be made from a named machine on your Windows domain or VPN, or through a publicly visible IP address.

Note: Unless you are an experienced IT professional, you should take great care before installing any software on a server that is integral to your business. Specifically, you should avoid installing new software on a server running:

- Microsoft Exchange
- An Accounting (or other Line-of-Business) software package
- Any software you can’t specifically identify but could be critical.

What Does Smartware Studio Need from SQL Server?
Smartware Studio will create a new database on the specified instance of SQL Server, along with any tables and queries that it needs. As updates are made to Smartware Studio, it will update the database structure as necessary.

What If SQL Server is Already Installed?
Smartware Studio’s database can certainly be created on an existing SQL Server and will coexist with any other applications that are storing their data on it. The only consideration should be whether any of the settings that are necessary for Smartware Studio’s client to access the data will adversely affect any other programs using the same SQL Server.
If you are going to use an existing SQL Server, please make note of any other application using it before you install Smartware Studio’s database or make any other changes to the SQL Server configurations.

*Note: If you are at all unsure about how an existing server is being used, do not install or change any configurations without consulting your network administrator.*

### Installing SQL Server

In general, you will want to refer to Microsoft’s documentation on how to initially install SQL Server.

Before you begin the install (and again after SQL Server is installed), you will want to review the later sections in this chapter for information on configuring SQL Server to work with Smartware Studio. Some of the settings can be made during the initial installation, though they can usually be changed after the installation.

#### Installing Microsoft SQL Server (Full Edition)

If you have a license for one of the licensed versions of Microsoft SQL Server, refer to its setup instructions for details on initial installation.

Be sure to install the optional SQL Server Management Studio, a separately installed tool which is a front-end for viewing, editing and configuring the SQL Server databases. If SQL Server came pre-installed and you can’t find the original installation disks, the Express edition of SQL Server Management Studio can be installed instead (refer to the next section).

#### Installing Microsoft SQL Server Express Edition

The installation files for the current versions of SQL Server Express as well as the SQL Server Management Studio can be found on our web site.

You can also download the various Microsoft SQL Server Express editions from Microsoft’s web site at [www.microsoft.com](http://www.microsoft.com). As the pages tend to move, you should do a web search, such as ”SQL Server 2017 Express Download” to find the current download location.

You will also want to download and install the corresponding SQL Server Management Studio Express (SSMS), which is a front-end for viewing, editing and configuring the SQL Server databases. Its download can also be found on the Microsoft web site, and in later releases it is included as a component of the SQL Server installation (be sure to select it as an option to install).
Configuring SQL Server

The default configuration of SQL Server is intended for it to be used only on the server on which it is installed. Smartware Studio is designed to have each workstation communicate directly with the SQL Server, so you will need to update some settings in order to make this possible.

These settings include:

- Enable SQL Server Browser Service
- Enable TCP/IP
- Mixed Mode Authentication
- Allow Remote Connections

You may also need to configure your firewall to allow the following processes to pass through:

- SqlServer
- SqlBrowser

Once you’ve made these changes, you may need to

- Restart the SQL Server (not the computer itself).

Refer to the following sections for step-by-step details on all these settings. In some cases, the names of folders and menu items may or may not include the SQL Server version (e.g. “2017” and/or “EXPRESS”).

The SQL Server Configuration Manager

Some of the SQL settings are accessed through a tool called the SQL Server Configuration Manager, which is installed with SQL Server. The method to access it varies between versions of SQL Server and Windows.

Older Versions

For Windows 7 and some Windows Server versions, it is installed onto the Start Menu. Open the following program from the Windows Start Menu’s PROGRAMS group:

```
PROGRAMS ➔
MICROSOFT SQL SERVER [2012] ➔
CONFIGURATION TOOLS ➔
SQL SERVER CONFIGURATION MANAGER
```
• The "[2012]" in the menu name will vary, or may not be shown

**Newer Versions**
For Windows 10, and some other Windows Server versions, you need to explicitly run the Microsoft Management Console snap-in, which is a file that ends in .msc. Here is the path for the most recent versions of SQL Server, assuming it was installed on the C Drive.

- **SQL Server 2017**  
  C:\Windows\SysWOW64\SQLServerManager14.msc
- **SQL Server 2016**  
  C:\Windows\SysWOW64\SQLServerManager13.msc
- **SQL Server 2014**  
  C:\Windows\SysWOW64\SQLServerManager12.msc
- **SQL Server 2012**  
  C:\Windows\SysWOW64\SQLServerManager11.msc
- **SQL Server 2008**  
  C:\Windows\SysWOW64\SQLServerManager10.msc

• Depending on the version of Windows, you should be able to go to the Search box on the Start Page and enter "SQLServerManager14.msc" (or the appropriate version number) to open it.

- If you right-click on the .msc file in the search results, you can open its folder in File Explorer.
- If you right-click on the .msc file in File Explorer, you can pin it to the Task Bar or Start Menu for easier access.
**Enable SQL Server Browser Service**

To enable the SQL Server Browser Service:

1. Open the SQL Server Configuration Manager (as described in the previous section).
2. Select SQL SERVER SERVICES in the left tree.

3. Select SQL SERVER BROWSER in the right pane.
4. Right click on the SQL SERVER BROWSER entry and select PROPERTIES:
5. On the SERVICE tab, change the Start Mode to Automatic:
If you receive an error message, refer to Step 7 of this sub-section for troubleshooting information.

6. On the **Log On** tab, select the "Network Service" BUILT-IN ACCOUNT and click the **Start** button to start the service.
7. If you receive an error, such as:

"The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. [0x80070422]"

you may need to do the following:

a) Open the Windows Control Panel
b) Open the ADMINISTRATIVE TOOLS
c) Open the SERVICES tool
d) Double-click the SQL SERVER BROWSER service
e) On the GENERAL tab, change the STARTUP TYPE to AUTOMATIC
f) Click the START button.

**Enable TCP/IP**

To allow TCP/IP access to SQL Server:

1. Open the SQL Server Configuration Manager (as described earlier in this chapter).
2. In the left tree, under the SQL Server Network Configuration, select Protocols for SQLEXPRESS (or MSSQLSERVER).

- The ‘SQLEXPRESS’ or ‘MSSQLSERVER’ in the name refers to the default names of the SQL Server instance, as specified when SQL Server was installed. This name may be different on your server.

- On 64-bit systems, you may also see two SQL Server Network Configuration items, one marked as “(32bit)”. Be sure to select the correct one based on your SQL Server installation.

3. Right-click on the TCP/IP item in the right pane and select Enable.

**NOTE:** As you make changes and configure the SQL Server, changes will be saved, however they will not be effective until the server is stopped or restarted. Refer to the section, *Restarting the SQL Server*, for details on how.
Connecting to the SQL Server using SQL Server Management Studio

The next settings need to be made using the SQL Server Management Studio tool.

To launch SQL Server Management Studio and connect to the SQL Server:

1. Open up the SQL Server Management Studio from the Windows Start Menu’s PROGRAMS group:

   PROGRAMS \ MICROSOFT SQL SERVER [2012] \ SQL SERVER MANAGEMENT STUDIO [EXPRESS]

2. You will be prompted to connect to the SQL Server:

   ![Connect to Server dialog]

   If you are on the same machine where the SQL Server is installed, you should see the name of the server listed in the SERVER NAME list. If not, choose the BROWSE FOR MORE… option from that list and find the server directly.

   - Note the specific format of the Server name (in this case, “XPVM\SQLEXPRESS”). You will need it when setting up the database from Smartware Studio’s setup wizard.

   Click CONNECT to connect to the SQL Server.
Mixed Mode Authentication

Smartware Studio will communicate with SQL Server using a built-in SQL Server account that it will create. Allowing this along with the standard Windows Authentication is called “Mixed Mode Authentication.”

To configure SQL Server to allow Mixed Mode Authentication:

1. Connect to the SQL Server using SQL Server Management Studio, as outlined in the previous section.
2. In the left pane (OBJECT EXPLORER), right-click on the name of the SQL Server and select PROPERTIES:
3. In the SERVER PROPERTIES dialog, select the SECURITY page:
4. Under Server authentication, choose the SQL Server and Windows Authentication mode:
Allow Remote Connections to the SQL Server
This setting is generally configured correctly but should be double-checked if there are issues.

To allow remote connection to the SQL Server:

1. Connect to the SQL Server using SQL Server Management Studio, as outlined in the previous section.
2. In the left pane (OBJECT EXPLORER), right-click on the name of the SQL Server and select PROPERTIES:

3. Select the CONNECTIONS page:
4. Under the Remote server connections heading, check the Allow remote connections to this server checkbox:
**Restarting the SQL Server**

Once you’ve applied these changes, you will need to restart the SQL Server service. You do not need to reboot the computer itself.

---
**Note:** If other applications are or may be using the same SQL Server, the database will become temporarily unavailable to them. This can cause unexpected or harmful results. You may want to consult the application’s publisher before restarting the server.

To restart the SQL Server:

1. Connect to the SQL Server using *SQL Server Management Studio*, as outlined in the previous section.
2. In the left pane (OBJECT EXPLORER), right-click on the name of the SQL Server and select **RESTART**:

![SQL Server Management Studio](image)

---

**Opening up the Firewall**

Depending on your network configuration, you may need to open up your firewall to allow the Smartware Studio workstations to communicate with the SQL Server.
NOTE: Changes in the firewall settings for your network should only be done by an authorized IT technician or administrator.

The specifics of each different type of firewall are beyond the scope of this document. You will, however, need to allow access to the following two programs:

```
C:\Program Files (x86)\Microsoft SQL Server\90\Shared\SqlBrowser.exe
```

Note that the “90” part of the path may vary from version to version. ‘90’ is SQL Server 2008, etc.)

```
C:\Program Files\Microsoft SQL Server\MSSQL14.SQLEXPRESS\MSSQL\Binn\SqlServr.exe
```

Note that the “MSSQL14.SQLEXPRESS” part of the path for the SqlServr.exe file will vary from server to server.
6. Configuring the Smartware Studio Server Elements

You can configure and administer Smartware Studio’s Server Elements from any workstation on your network with Smartware Studio installed on it. The Server Setup Wizard will guide you through the process step-by-step.

- For the initial setup, however, it may be easier to use the Server Setup Wizard directly from your server. In this case, you can install the software and run it without licensing. The tools on the ADMIN menu will still be available in an unlicensed mode, though you will still need a user account with IT Administration privileges. Refer to the earlier chapter on Installing Smartware Studio on a Workstation, specifically the sub-section on When Installing on a Server to use the Installation and Setup Tools.
- Once the Server Setup Wizard has been run successfully, additional workstations will automatically be configured to point to the server when they are licensed.

Using the Server Setup Wizard

To start the Server Setup Wizard, select SERVER CONFIGURATION AND TOOLS… from the ADMIN menu.

Follow the instructions for each step and click the NEXT and PREVIOUS buttons to move between them.
**Step 1: File Server Setup**

In the first step, you will tell Smartware Studio where the Shared Folder is located.

It is highly recommended that this folder be on a drive that is backed up regularly, and that has enough capacity to meet your needs.

- The folder can be located on any file server, as long as it can be accessed by all the workstations that will be using Smartware Studio. Refer to the later chapter on *Permissions* regarding how the access can be restricted.
- You should reference the path by a standard network path (e.g. `\yourserver\Data`).
- Although you can reference the folder through a common mapped drive letter, this method is not recommended as some workstations may be set up differently.
Step 2: Select the SQL Server
Next, tell Smartware Studio which SQL Server you will be using.

- The format of the SQL Server name will vary from system to system but is often MACHINENAME\SQLSERVER or MACHINENAME\SQLEXPRESS. It will be the same name as the one used when connecting to the database using SQL Server Management Studio.
  - For easy access or to copy and paste the server name, it is located in the SQL Server Management Studio tool.
    - Open SQL Server Management Studio, right-click on the topmost node in the left panel tree and click on PROPERTIES. There, you can copy find and copy your server name.
**Step 3: Specify How to Log into SQL Server to Create the Database**

Smartware Studio will need to log into the SQL Server to create the database. You can use Windows Authentication or SQL Server Authentication. The descriptions under each option will help you determine which to use.

![Server Setup Wizard](image1)

**Step 4: Test the SQL Connection**

If SQL Server is configured properly, you should now be able to connect to the SQL Server.

![Server Setup Wizard](image2)
Click the TEST CONNECTION button to test. If the connection fails:

- Review the error message for an explanation of the problem.
- Ensure that you have full rights to the path where you are creating the shared folder.
- Review the SQL Server settings outlined in the previous chapters.
- Have your IT staff contact our technical support team for one-on-one assistance.

**Step 5: Specify the Database Name and SQL Account to Create**
The default settings should suffice for most users.
Step 6: Create the SQL Database

Smartware Studio now needs to create and set up the SQL Server database.

- Click the CREATE DATABASE button to begin.

The results of the installation are shown:
You will then be given the opportunity to initialize the Parts Database (a set of tables in the SQL Database) used by the Designer (Design360) and Estimating Modules.

- It is strongly recommended that you do this initialization. If you don’t, you will need to do it later from the ADMIN→PARTS DATABASE MANAGER tool.

Smartware Studio will then restart itself.

If your Server Setup did not complete successfully:

- Open the SQL Server Management Tool and delete the unsuccessful Server Setup by right-clicking on the topmost node in the tree, or the Server Name, and click Delete.
- Refer back to Step 6 to create and setup the server again.

**Configuring Additional Workstations to Point to the Server**

Once the server is configured, additional workstations will automatically be configured to point to the server when they are licensed.

- There is a file named site.ini which contains the connection information for the folder and SQL server. It is stored on your server folder in the System Config sub folder.
- When you set up the server, your network folder path is stored in the Smartware licensing database.
• When you license a workstation, the site.ini file is copied from your server to the workstation’s root folder (usually C:\Program Files\Smartware Technologies\Smartware Studio).
• The workstation uses this file to access your server.

**Moving the Server Elements to a New Location**

There may come a time when you need to move the Shared Folder or the SQL Server to a new location or server machine. If so, you will need to use the following procedures to ensure all your users are updated accordingly.

- We recommend that you contact our support team before doing these procedures. We will be happy to walk through them with you online to ensure a smooth transition.
- Whenever you make these types of changes, ensure that all your users are out of Smartware Studio.
- If you have the Studio Windows Service configured and running, you must stop and restart the service after either of these changes.

**Moving the SQL Server Database**

To move the database to a new SQL Server:

1. As long as you are logged in as the SQL Server Administrator, you should delete the SQL server user created for Studio users (the default is SmartwareStudioUser). This needs to be recreated anyway on the new server, so removing it first is helpful and prevents inadvertent user changes to the database during the transition.
2. Backup the SQL Database from SQL Server Management Studio, or in Studio (but only on the machine running SQL Server) by going to ADMIN—SERVER CONFIGURATION AND TOOLS, selecting the SQL SERVER DATABASE tab, and using the BACKUP DATABASE utility. The backup file will be stored in your Shared Folder in the SQL DB Backups sub-folder.
3. Copy the backup file to a location visible to the new server.

On the new SQL Server:

4. Set up and configure the new SQL Server. Refer to Chapter 5 for specific details on the required SQL Server settings.
5. In SQL Server Management Studio, connect to the new SQL Server.
6. Right click on the DATABASES folder and select the RESTORE DATABASE command.
7. In the **TO DATABASE** (**DATABASE** in later versions) field, enter “Smartware Studio”.

8. Select the **FROM DEVICE** radio button. Click the … button to the far right of the radio button to specify the backup location.
9. Click the ADD button and browse to the backup file. Click OK.

10. Check the RESTORE check box and click OK. The database should now be recovered successfully.

11. You will need to recreate the user account originally specified for Smartware Studio to access the database (SmartwareStudioUser by default) and ensure that it has db_owner rights to the database.
   - If you did not delete the user before the backup, the reference to the user account will import with the database, but this is actually a reference to a user in the old SQL Server instance. Therefore, we need to delete the old reference, create a new SQL Server Login (that has the same name), and then add security permissions to this new login.
     - In SQL Server Management Studio, open the tree view for the Smartware Studio database, and go to the SECURITY/USERS folder.
     - Right-click on the account (e.g. SmartwareStudioUser), select DELETE, then click OK.

12. From the root of the SQL Server Instance (e.g., XPVM\SQLExpress), open the Security Folder, right-click on the Logins folder, and select NEW LOGIN.
13. On the General Tab:
   a) Fill in the Login name (e.g. SmartwareStudioUser)
   b) Select SQL Server Authentication.
   c) Enter and confirm the SQL Server Password. If this is not the same password
      as the original account, you will need to update it in the Configure Database
      Connection dialog in Studio (a few steps from now).
   d) Uncheck the Enforce password policy checkbox.
   e) Click OK to save the changes, and then reopen the user record.
14. Go to the *User Mapping* tab:
   a) In the upper box labeled *Users mapped to this login*, check the box next to the *Smartware Studio* database.
   b) In the lower *Database role membership for: Smartware Studio* list, check the *db_owner* checkbox.

15. Click OK.
Back in Smartware Studio:

16. From the Admin menu, select SERVER CONFIGURATION AND TOOLS.
17. Go to the PROJECT DATABASE SERVER (SQL SERVER DATABASE) tab.
18. You will see the current Project Database SQL Server settings. Click CONFIGURE… to edit them.

19. Update the connection parameters as necessary. Click TEST CONNECTION to test the connection and UPDATE when complete.
20. Smartware Studio will restart. You should verify that you can see your project data in the Project List. You should also verify that other users’ workstations are updated when they restart.
21. If you have the Studio Windows Service configured and running, you must stop and restart the service to affect these changes.

Moving the Shared Folder
Relocating the Shared Folder to another path or file server is a somewhat manual process.

- We recommend that you contact our support team before doing these procedures. We will be happy to walk through them with you online to ensure a smooth transition.
- Before making these changes, be sure you have a good backup of the entire Shared Folder.
- If you have the Studio Windows Service configured and running, you must stop and restart the service after either of these changes.
For the purpose of this example, assume the following:

Old Path:  \FS01\Data\Smartware Studio Data
New Path:  \FS02\Data\Smartware Studio Data

1. Ensure that all your users are out of Smartware Studio.
2. Copy the shared folder, in its entirety, to the new location.
3. On the old server, in the System Config folder, open the Site.ini file in a text editor (in this case \FS01\Data\Smartware Studio Data\System Config\Site.ini).

   ![Site.ini in Notepad](image)

4. Update the network path in the NetworkRootPath setting to the new path and save the file.
5. Copy the modified Site.ini from the old folder onto the new folder (e.g., \FS02\Data\Smartware Studio Data\System Config\Site.ini)
6. If you have the Studio Windows Service configured and running, you must stop and restart the service to affect these changes.
7. Contact Smartware Technologies’ technical support and provide us with the new folder path. We will update our database with this information. This path is stored in our central licensing database and is used to help your workstations find your server when they are licensed.

The next time each user starts Smartware Studio they will get the updated Site.ini from the old folder, and then automatically start looking at the new folder. When all your users have been updated, you can remove the old folder.

- Until all the users have started Smartware Studio, the System Config sub-folder in the old folder needs to remain. The other folders, particularly the Projects folder (where most of the data accumulates), can be removed immediately (be sure your new copy of the data is working properly).
- If the old folder is removed before a user has been updated, go to the File→Product License Registration dialog and click Update License to reestablish the connection to the server.
7. Administering Smartware Studio

Once the Server is configured, there are some Administrative tasks that you will need to do on an ongoing basis. These include:

- Installing Additional Workstations
- Adding and Managing Users and Licenses
- Viewing Workstation Licenses
- Application Updates
- Upgrading the Project Database
- Backing up the SQL Database

There are also separate chapters on the following administrative tasks (amongst others):

- Managing Server Files and Projects
- Setting up Permissions
- Managing the Parts Database

Most of these functions are available from the ADMIN menu and will not appear unless you have the required administrative privilege. These privileges are specified in the Edit User record from the USERS AND LICENSES administrative tool.

<table>
<thead>
<tr>
<th>User Privilege</th>
<th>Administrative Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smartware Studio Account Manager</td>
<td>• Users and Licenses</td>
</tr>
<tr>
<td></td>
<td>• Permissions</td>
</tr>
<tr>
<td>IT/Server Administrator</td>
<td>• Server Configuration</td>
</tr>
<tr>
<td></td>
<td>• Studio Windows Service</td>
</tr>
<tr>
<td>Parts Database and Customization</td>
<td>• Parts Database</td>
</tr>
<tr>
<td>Administrator</td>
<td>• Libraries and Templates</td>
</tr>
</tbody>
</table>

**Installing Additional Workstations**

When you configure the Server Elements, Smartware Studio stores the information in the Shared Folder on your file server. It also sends the path of the Shared Folder to Smartware’s licensing server. When you install the program and register the license on a new workstation, Smartware Studio automatically looks at that folder on your server and gets all the file server and database configuration information.
Thus, licensing a workstation should automatically configure the workstation to work with your server with no additional configuration required.

**Adding and Managing Users**

You can add, modify and disable your users from within Smartware Studio.

- From the **ADMIN** menu, select **USERS AND LICENSES** to bring up the Account Manager.
- You will be prompted to login to the Smartware server.
- Only users with **SMARTWARE STUDIO ACCOUNT MANAGER** permission for their company can add or change users.

The Account Manager has tabs for **Users, Remote Users, Groups** and **Licenses**.
Adding a New User
To add a new user, click the ADD USER button. You will be prompted for the following information:

- If the WINDOWS USERNAME field is specified, the user will be authenticated by being logged into your network and will not be required to log into Smartware Studio explicitly.
- If the WINDOWS USERNAME is not specified, the system will assume the user is the one who logged in when licensing the workstation.
- The OFFICE AND PHONE EXTENSION fields, if shown, are used for the Sign Me In/Out service. The list of offices for your company is currently managed by Smartware Technologies.
- The SMARTWARE STUDIO ACCOUNT MANAGER, I/T SERVER ADMINISTRATOR and PARTS DATABASE AND CUSTOMIZATION ADMINISTRATOR checkboxes grant the administrator privileges described in the previous section.
- The GROUPS tab allows you to select the permission groups to which the user belongs. Refer to the later chapter on Setting up Permissions for more information.

Managing Users
All of the other User maintenance actions are available on the Users tab as well.

- To edit an existing user, select them and click EDIT USER, or right-click and select EDIT USER.
  - When editing a user, you can email them their password or change it explicitly.
• To deactivate a User, edit the user and check the DISABLE USER checkbox. Deactivated users are hidden from the user list by default, so you must check the HIDE INACTIVE USERS checkbox to make them appear to edit and reactivate them. There is no way to permanently delete a user, as historical records such as file uploads, may be kept indefinitely.

• Click the EXPORT TO EXCEL button to generate a complete list of your users.

• For Enterprise Administration environments, there are additional management options such as remote logins detailed in the section, Configuring a Multi-Server Enterprise, of the later chapter, Enterprise Management and Reports.

Managing Workstation Licenses
You can view a list of your Smartware Studio license accounts, including information on which are used and by whom, which are available and what the passcodes for those licenses are.

• From the ADMIN menu, select USERS AND LICENSES
• You will be prompted to login to the Smartware server.
• Select the Licenses tab.
• Only users with SMARTWARE STUDIO ACCOUNT MANAGER privilege for their company can view license information.

• You can generate a report of all your license information by clicking EXPORT TO EXCEL.
**Resetting a License**
If a user’s hard drive crashes or a license is otherwise lost on a machine, you can reset that license and generate a new passcode to use on another machine.

- To reset a license, right-click on it and select **RESET LICENSE**.

If you reset a license on an active machine, that license will deactivate itself the next time Smartware Studio starts.

**Smartware Studio Application Updates**
Smartware Studio is designed to automatically check for and update itself when new releases are available.

- When a regular user starts Smartware Studio and an update is available from our web site, they will be told to contact their IT or Account Administrator.
- When an IT Administrator starts Smartware Studio when an update is available, they will be given the option of downloading and installing the update immediately.
You can review and manage the application updates by selecting SERVER CONFIGURATION AND TOOLS from the ADMIN menu and going to the APPLICATION UPDATES tab:

- If a new version is available, the DOWNLOAD button will be available.
- Click DOWNLOAD to copy the new version to your local workstation.
- Once downloaded, the PUBLISH button will be available.
- Click PUBLISH to copy the new version to the System Config folder on your Shared Folder.
- Once published, all other users will be prompted to download and install the new version the next time they start Smartware Studio.
**Installing and Publishing a Beta Version**

As new versions of Smartware Studio are created, they may be made available as Beta versions on our web site before being posted for automatic download for all users.

- You can generally install a Beta version on a single workstation without affecting other users.
- Occasionally such an update could update the system database in such a way that all users will need to upgrade as well.

To make a Beta version available to all users, simply download it and copy it into the appropriate server folder (*System Config*). You can open the System Config folder on your network using the link on the **APPLICATION UPDATES** tab in the **INSTALL BETA VERSION** section.

**Prompt for a Different Login During Installation**

If a user’s workstation is “locked down” such that the user doesn’t have administrative rights to install programs, you can configure the workstations to prompt for a different user account when it downloads and runs updated versions of the Studio installer.

- New versions of the installer’s MSI file are downloaded and launched by the *Background Updater*, which normally runs once on the first launch of the day.

To force the installer to prompt for a new Username and Password, open the *Smartware Studio.ini* file found on the user’s workstation.

- This file can be found in the *\[APPDATA\]/Config* folder.
  - You can access the APPDATA folder from a link in the **TOOLS** → **OPTIONS** dialog on the Local Files tab.
  - You can also open the file by going to **HELP** → **ABOUT SMARTWARE STUDIO / STUDIO360** and pressing **CTRL+ALT+SHIFT+I**

Find the section marked **[Application]** and add the following line:

```
[Application]
MsiPromptForUser=True
```
Upgrading the Studio SQL Server Database

New releases may require that the structure of the Studio SQL Database be upgraded. This usually involves adding fields to existing tables or new tables or queries.

**NOTE:**
- In most cases the Database structure will be upgraded automatically as necessary the first time any user runs a new version of Studio.
- After an IT Administrator installs an application update and runs it, they will be informed if a manual database upgrade is required.

If a manual database upgrade is required:

- Back up your database before you apply the upgrade (refer to the next section)
- From the ADMIN menu select SERVER CONFIGURATION AND TOOLS
- Go to the SQL SERVER DATABASE tab:

![Server Configuration Window]

- Click the **UPGRADE DATABASE** button.
Back Up the Studio SQL Database
For best practice, you should set up an automated regular backup of your SQL Server Database.

- One method is to create a SQL Server Maintenance Plan in SQL Server.
- Another is to ensure that all the files on the SQL Server are being backed up to a remote location

**Note:** If you are using and relying on backup software that backs up files on your SQL Server, be sure that it is actually getting a good backup of the database. The SQL files may be viewed as “open” at all times and be continually ignored by the backup software if not configured properly. You should test a sample backup file by restoring it onto another SQL Server Express installation on a spare workstation (and NOT back onto a server)

For manual backups, Smartware Studio can generate a quick backup.

**Note:** This procedure only works when running Studio on the same machine as the SQL Server. You can install Studio on a server to run the Administration tools without needing to license it.

- From the Admin menu, select Server Configuration and Tools.
- Go to the SQL Server Database tab.
- Click the Backup Database button to create a new backup. Previous backups will be shown in the list.
- The backup files are stored in the Shared Folder in a sub-folder called SQL DB Backups. You can open this folder by clicking the link above the backup list.
  - **Note:** If you do not see the SQL DB Backups sub-folder, then you haven’t successfully backed up your database.
- You may need to configure the SQL Server to have write permissions for the Backup Folder.
- Refer to the earlier chapter on Configuring the Smartware Studio Server Elements for information on how to restore or move the SQL database.
8. Managing Server Files and Projects

You can review and manage the projects and files on your server by selecting **ADMIN → SERVER CONFIGURATION AND TOOLS** and going to the **FILES AND PROJECTS** tab.

Managing Server Files

There are a number of tools and utilities for managing the files in the server projects.

**Viewing Server File Sizes and Purging Older Data**

To view a list of projects and the number and size of its files, select **ADMIN → SERVER CONFIGURATION AND TOOLS**, go to the **FILES AND PROJECTS** tab, and click the **MANAGE SERVER FILES** button:

- The **Total Active File size** and count represent only the current version of each file in the project or system. The **Total Previous Version size** and count represent the total of all the previous versions of the files in the project or system.

**Purging Older Previous Versions**

By default, the system will keep all previous versions of practically all the files stored on the server. With this tool you can purge older, previous version of active files selectively.
To calculate which files will be purged, choose the minimum number of versions and days and click **CALCULATE VERSIONS TO DELETE**. For example, in the image above it has calculated that the total size of the previous files, not including the most recent two versions or any version less than 45 days old, is 55.62 GB.

Once you are satisfied with the amount to delete, click **DELETE OLD PREVIOUS VERSIONS** to permanently delete these older versions from your server.

Once purged, the history of the previous versions and the users that uploaded them will remain (as the indexes are stored in the SQL database), but the previous versions of the files themselves will be unavailable.

**Purging Deleted Files**

By default, when a user deletes a server file it is still available to be restored from the Studio Recycle Bin. With this tool you can select the range of deleted files to delete permanently.

- To calculate which files will be purged, select the number of days for which deleted files should not be purged and click **CALCULATE FILES TO PURGE**. In the example, it has calculated that purging any file deleted more than 30 days ago will free 9.97 GB.

- Once you are satisfied with the amount to purge, click **PURGE DELETED FILES** to permanently delete these files from your server.
**Searching Server Files**

You can do an advanced search of all the files in all the projects on your server.

- From the **ADMIN ➔ SERVER CONFIGURATION AND TOOLS** dialog, go to the **FILES AND PROJECTS** tab, and click the **SEARCH FILES** button:

![Advanced File Search](image)

- The **Search Text** can be found in the **File Name** or the File’s **Description** property.
- You can search for files that came from a specific Multi-File Library (MFL) based on a piece of its ID (GUID)
- You can also search for files that came from MFLs with specific filter properties by clicking the **LIBRARY PROPERTIES** button and selecting the options.

**Viewing File Download History**

For audit trail purposes, Studio tracks each time a user downloads a version of a file from the server.

- You can view the download history for one or more files by selecting them in the **Files** tab, right-clicking and selecting **ADMIN ➔ VIEW DOWNLOAD HISTORY**. You can filter by **User**, **Computer Name**, **Download Date** and **File Name**.
- You can view the download history for a single user across multiple projects by selecting **ADMIN ➔ SERVER CONFIGURATION AND TOOLS**, selecting the **FILES AND PROJECTS** tab, and clicking the **FILE DOWNLOAD HISTORY** button.
• This feature was introduced in Build 3.4.426. No records will be available before that version was installed on the machine where the file was downloaded.

**Server File Update Utility**

The *Server File Update Utility* is designed for very specific cases where an organization or enterprise wants to manipulate (add, update, delete) common files that exist in the same folder on multiple projects. For example:

- Files that were part of a New Project template at some point but are no longer wanted
- A file that should be added to every project that has a ‘Sales’ folder.

The utility is driven by specifying a set of actions in a spreadsheet and then running those actions on a server.

- **From the ADMIN→SERVER CONFIGURATION AND TOOLS dialog, go to the FILES AND PROJECTS tab, and click the SERVER FILE UPDATE UTILITY button.**
- **Follow the instructions to generate a template, editable command file spreadsheet.**
- **Import and Run the commands from the file.**
Managing Server Projects

There are other tools that can be used to manage Server Projects.

**View Project Statuses and Purge Deleted Projects**

Only an Administrator can delete a project from the server, and even then, it is only marked as deleted and can be restored. To view a list of all the server projects and their status, select **ADMIN ➔ SERVER CONFIGURATION AND TOOLS**, go to the **FILES AND PROJECTS** tab, and click the **MANAGE SERVER PROJECTS** button.

- To restore a deleted project, right-click the project name and select **RESTORE DELETED PROJECT**.
- To permanently delete a deleted project, right-click the project name and select **PURGE DELETED PROJECT**.

**Viewing Previous Versions of Projects**

As with files, Studio keeps a copy of every version of a Project as it’s checked in. You can access:

- The check-in history of a server project.
- Any previous version of a server or local project.

To access the history and previous versions:

- Bring up the Open Project dialog (**FILE ➔ OPEN PROJECT**)
- Right-click on the project in the **Local Projects or Server Projects** List
- Select **VIEW PREVIOUS PROJECT VERSIONS**.
Studio will create a list of all available versions of a project, both locally and (for server projects) on the server.

- You can view any of them in a temporary, read-only instance of Studio. You will not be able to make any edits, or view any files, emails, tasks, permissions or passwords.
- You can set one of the previous versions to be the current version. You must have proper permission, and the project needs to be checked in at the time.
- If the project is an Estimate, or contains one or more Estimates, you can select two or more versions and compare the values in the Estimates in each version by clicking the Compare Estimates button.

**Reporting on Server Projects**
There is a separate tool for generating reports that includes data from all the projects on the server. Refer to the later chapter on *Enterprise Management*. 
9. Configuring a Smartware Studio Workstation

There are a number of configuration settings for each Workstation that you may want to adjust, depending on the features and modules of Smartware Studio that each person is using.

- To access the Smartware Studio Options dialog, select OPTIONS from the TOOLS menu.

Workstation Options
There are some Workstation-specific options that you can select:
By default, Smartware Studio will display the *Open Project* dialog when it starts up. To suppress this behavior, uncheck the *Show Open Project Dialog on Startup* checkbox. This is useful if you access projects through the **File** → **Recent Projects** or **File** → **Favorite Projects** lists.

**Setting a Workstation Region**

Depending on where you are located, you may need to change the region of your workstation to reflect the correct units, numbers, currency, and dates displayed and calculated within Studio.

- To specify a region, simply choose from the drop-down list as shown below.
- Setting a region will not affect the language of the text in Studio.
Local Files Folder
Whenever a user opens a project from the server or accesses a file from within a project, a copy of the relevant data is copied from the server onto the local workstation. These local versions of the project files are stored in the *Local Files Folder*.

- You can view information about the Local Files Folder on the **LOCAL FILES** tab.

- By default, this folder is created in the user’s *Documents and Settings* folder.
- Be aware that this data can take up considerable space on your hard drive. If the computer has a small C: \ drive, you may want to relocate the folder to a different partition or drive.
- You can move the folder by clicking the **MOVE LOCAL FILES FOLDER**. When you move the folder, you can choose to just point to a new folder or to move the existing data as well.
- You can specify a quota that is shown on the user’s Open Project dialog to help warn them if they have downloaded a large amount of data and may need to clean up some local files. This quota is for information purposes only and is *not* enforced.
- Downloaded PDF files for part data and System Libraries are also stored in the Local Files Folder.
Server Settings

The SERVER SETTINGS tab shows you how the workstation is connected to the server.

- If you need to use a Proxy Server, check the ENABLE PROXY SERVER and fill in the Address and Port Number.
- If you are using a machine that is shared by multiple users (e.g., a machine for Presenting in a conference room), check the PROMPT FOR USER LOGIN option to be prompted for a Studio User Name and Password each time Studio is opened.
Connectivity

The Connectivity tab allows you to adjust how the workstation connects to the server.

- If your normal connection is slower or unreliable, or if Studio often opens as Disconnected, you may need to specify a custom timeout for one or more of the connection types.

Checking Connectivity

To help diagnose connectivity issues, you can bring up the Connectivity Management dialog.

- From Tools→Options, select the Connectivity tab and click Check Connectivity.
- If you are currently disconnected, click yellow warning icon in the lower-left corner of the Status bar.
The Connectivity Management dialog will let you test different custom timeout values, and show you detailed error messages that can assist IT staff or Smartware in diagnosing the problem.

![Connectivity Management dialog]

**Parts Database**

The Parts Database used by Smartware Studio’s Core Module (e.g. Browsing Parts, adding parts to an Estimate, etc.) is managed separately and automatically downloaded to each workstation. Refer to the later chapter on *The Parts Database Manager* for more information.

- There are options on this tab to configure the part browsing and searching features.

**Designer Module**

You can select specific template files to use with the Designer Module, such as a blank drawing file or valve schedule. Refer to the *Designer Module User’s Guide* for more detail.
PDF Files
The PDF Files tab helps you manage the PDF files associated with the parts in the Parts Database.

- The Parts Database Manager is used to download the latest PDFs from the Smartware server to your Company’s server.
- The latest PDFs are downloaded automatically by the Background Updater.
- Refer to the later chapter on The Parts Database Manager for more information.

PDF Generator
For some features, such as reporting and the Submittal Generator, Smartware Studio can convert generated files and reports into PDF files. This requires two additional configuration items:

- Installation of the free Ghostscript driver
- Installation of the CutePDF Writer printer drive.

To configure these settings, go to the TOOLS→OPTIONS dialog and select the PDF GENERATOR tab:
Installing Ghostscript

Ghostscript is a free driver that converts postscript printer files into PDF files. You can install it by clicking the INSTALL GHOSTSCRIPT 8.64 button:

You can download Ghostscript from either server. Once downloaded, the installation process will begin:

Click the SETUP button and follow the instructions to complete the installation.

Installing the CutePDF Driver

Regardless of any printers connected to the computer, you will need to install a PostScript-specific printer driver on the machine. This driver will not point to a physical printer but will only be used to create the PDF files.
The simplest choice is the free CutePDF Writer driver that also allows you to create PDFs from any application that can print. You can install it from the PDF Generator tab on the TOOLS ➔ OPTIONS menu by clicking the INSTALL CUTEPDF WRITER button:

- After installation, click the REFRESH LIST button as needed
- Select CutePDF Writer as the PostScript Printer Driver.

Additional Configuration Settings
Depending on the features and specific modules of Smartware Studio that each individual user or company has purchased or licensed, there will be additional configuration tabs visible.

Estimating Module
- The Estimating Module tab enables users to transfer local Estimate templates to their server for all users, set default Estimate templates and customize Task Sheet templates and rules.

Prometheus
- The Prometheus tab allows users to set the location of the Prometheus Systems as well as configure document generation and diagnostics settings.
- Refer to the Prometheus Module Guide for more detail.

Import / Export Options
- The Import / Export Options tab allows users to import and export the configured settings of a workstation using the UserSettings.ini file. Additionally, admins can globally set a company’s default workstation settings via this tab.
3\textsuperscript{rd} Party Software

- The 3\textsuperscript{rd} Party Software tab helps you manage the integration settings of 3\textsuperscript{rd} party software associated with Smartware Studio, such as WorkPlace Tech, XPSI, Microsoft Visio Viewer, and PDF editing and annotation software.

Template Files

- The Template Files tab gives you access to the Windows File Explorer folder where your Custom Templates are stored on your workstation, as well as additional useful information about Custom Templates.

System Library

- The System Library tab gives you access to the Windows File Explorer folder where the two different types of System Libraries (Single-File Visio Drawings and Multi-File System Libraries) are stored on your workstation, as well as some additional info on Standard System Libraries.
10. Setting up Permissions

Smartware Studio provides the ability to restrict access to certain projects, files, data or functionality on a per-user and group basis.

Overview of Permissions in Smartware Studio

Smartware Studio allows you control which users can do which actions to which data. These rules are collectively referred to as Permissions.

- **Permissions are always used to grant access.** For example, a user or group can be given permission to edit a type of file. However, there is no permission to deny someone that ability. For anyone to do anything, they need to be explicitly given that permission.

- Permissions in Smartware Studio are completely independent of any rights and user groups created in Windows.

There are two types of Permissions:

- **Project-Level Permissions** specify what users can do on each Project based on its type (Customer Site, Job, Estimate), and are effectively global settings. Examples of Project-Level Permissions include Opening a Project, Editing a Network Tree and Deleting Files from the Project Tree.

- **Folder-Level Permission Sets** allow you to restrict access to portions of your project and network tree (e.g., Pricing data) to specific users (e.g. Salespeople and Project Managers), essentially restricting all others.

To get started with Permissions, you should do the following tasks:

- Create User Groups
- Assign Users to the Groups
- Specify Project-Level Permissions for each Group
- Enable Permissions in the System

**NOTE:** By default, Permissions are not enabled in a Smartware Studio environment. You will want to set up your Groups and Project Permissions before enabling the feature. Any users who are not in a group with some Permissions will effectively be locked out of all projects.
After you have configured your initial Permissions, you can also optionally do the following:

- Create Permission Sets for Restricted Folders
- Assign the Permission Sets to the Folders in the Projects
- Lock Down the Projects Folder on the Server using Impersonation

**Managing Permissions**

Permissions are global to the system and only affect projects on the server. In order to manage Permissions:

- You must be a SMARTWARE STUDIO ACCOUNT MANAGER, as specified in the Account Manager form (ADMIN→USERS AND LICENSES). Refer to the Adding and Managing Users section of the earlier chapter Administering Smartware Studio.
- You must be connected to the server.
You can access most of the Permissions settings by selecting **ADMIN**→**PERMISSIONS**:
Creating User Groups for Permissions

For the purposes of assigning Permissions, you can organize your users into any number of User Groups that you define.

- To create and manage users and groups, select ADMIN→USERS AND LICENSES and select the GROUPS tab.

- To add a new group, click the ADD PERMISSION GROUP button.
- To edit or delete a group, select the group and click the EDIT GROUP or DELETE GROUP button, or double-click to edit.

When you are adding or editing a group, you can select the users that are in that group from a list.

- You can also choose the groups that a user belongs to by selecting the user in the Users list, selecting the GROUPS tab, and the choosing the groups of which the user is a member.
Project-Level Permissions

Project Level Permissions specify what users can do on each Project based on its type (Customer Site, Job, Estimate). You specify the permissions by building up a list of Groups and Users, and then choosing the actions that each can do.

- If a user is in more than one group, they can do an action if any of their groups can also do that action.

Creating Project-Level Permissions for a Group or User

To create Project-Level Permissions for a Group or User:

- From the PERMISSIONS MANAGEMENT dialog, click the EDIT PERMISSIONS BY PROJECT TYPE… button.
• Click the ADD… button to select a Group (or individual User)

![Add User / Group dialog]

• Select the Group (or User) to add and click OK. The Group (or User) will be added to the list and selected and you will be able to edit its Project-Level Permissions

**Editing Project-Level Permissions**

Once you’ve added a Group (or User) or the Project-Level Permissions list, you can edit the actions the Group (or User) can perform by selecting the Group (or User) and clicking EDIT.

• When you add a new Group (or User), you will automatically be put in a mode to edit their Permissions.
The Project-Level actions are listed for each Project Type:

- Check the boxes to indicate the actions that the Group (or User) can perform on each type of project.
- To grant permission for all project types, check the box in the ALL PROJECT TYPES column.
- When you are done assigning permissions, click SAVE.

**Individual Project Permissions**
There may be instances where you want to restrict or otherwise control access to a specific project differently than the other projects of its type in the system. If so, you can specify distinct Project-Level Permissions for that project.

- From the Open Project dialog, select the project in the Server Project list.
- Right-click the project and select EDIT PROJECT’S PERMISSIONS… from the menu.
Setting Up Permissions

There are two ways to specify how the permissions will be applied:

- If the OVERRIDE THE PERMISSIONS FOR (PROJECT TYPE) checkbox is checked then the permissions specified here are the only ones that apply. All other permissions for this type of project are ignored. This is useful if you want to limit access to a sensitive project to a limited number of users.
- If the same OVERRIDE checkbox is not checked, then the permissions specified here are in addition to the ones for this type of project. This is useful if you want to expose a project to a Group or User that normally wouldn’t have access to this type of project.

Enforcing Permissions

Once you have the Groups and Project-Level Permissions established, you must tell Smartware Studio to enforce the permissions. To enable permissions for all users in the entire system:

- Select ADMIN ➔ PERMISSIONS

  ![Permissions Management]

  Enforce Permissions
  - When the Permissions are Turned Off, all users have full rights to all projects and files.
  - When the Permissions are Enforced, all restrictions are enforced.
  - Enforce Permissions

- Check the ENFORCE PERMISSIONS checkbox

Folder-Level Permission Sets

Folder-Level Permission Sets allow you to restrict access to portions of your project and network tree (e.g., Pricing data) to specific users (e.g. Salespeople and Project Managers), essentially restricting all others.

Overview

The most common use of Folder-Level Permissions is to control access to specific types of folders which likely appear in many projects. For example, you may commonly have a folder called “Sales” where you get sales data that not all users should be able to see. Instead of having to go to each folder and repetitively list the groups or users and the permissions they should have on that folder, Smartware Studio defines and names these permissions globally as Folder-Level Permission Sets.
• A (Folder-Level) Permission Set is a set of Groups (and/or Users), and the folder-level actions that they can perform (e.g., View Folder Contents, Move Child Folders).
• A Permission Set can consist of a single Group (or User), or multiple Groups (and/or Users) each with its own permissions.
• This named Permission Set is then assigned to any number of folders in any number of projects.
• If you change the members or permissions in a Permission Set, the change automatically affects all folders in all projects that use that Permissions Set.
• Folder-Level Permissions are automatically inherited from parent folders unless the IGNORE PARENT PERMISSIONS checkbox is explicitly checked.
• There is a utility for searching all folders in all projects (by folder name) and assigning a Permission Set to one or more of them (see the sub-section later in this chapter).

Creating a Permission Set
Permission Sets are created globally, and not within a single project.

• Select ADMIN ➔ PERMISSIONS
• Click the EDIT FOLDER PERMISSIONS SETS… button

![Edit Folder Level Permission Sets](image)

• To create a new Permission Set, click the ADD button.
• To edit or delete an existing Permission Set, select it and click the EDIT… or DELETE button.
**Specifying the Permissions in a Permission Set**

Once the Permission Set has been created, you can add Groups and/or Users to it and select the permissions for each one.

To edit a Permission Set:

- Select ADMIN → PERMISSIONS
- Click the EDIT FOLDER PERMISSIONS SETS… button
- Select the Permission Set from the list
- Click the EDIT button

- To add a Group (or User) to the Permission Set, click the ADD… button.
- To edit the permissions associated with a Group (or User), select it in the list and click EDIT. Click SAVE when done.
**Assigning a Permission Set to a Folder in a Project**

To apply a Permission Set to a single folder in a project:

- Open the Project, but DO NOT check it out. Permission Sets cannot be assigned to a folder if the project is checked out.
- Select an item in the project or network tree
- Select the PERMISSIONS tab (only visible to administrators)
- Click the SELECT PERMISSION SET… button to select the Permission Set

- By default, the Permissions associated with a folder’s parent are automatically inherited by its child folders. To override this behavior and have the permissions in the specified Folder Set be the only ones that are applied, check the IGNORE PARENT PERMISSION checkbox.
**Assigning a Permission Set to Multiple Folders in Multiple Projects**

A common scenario when working with Permissions is to need to assign the same Permission Set to a number of folders, usually with similar names, in a number of projects. To handle this case, use the *Bulk Assign Folder-Level Permission Sets* utility.

- Select **ADMIN → PERMISSIONS**
- Click the **ASSIGN FOLDER PERMISSION SETS…** button

Enter a search string and click **SEARCH FOR FOLDERS**. You will be presented with a list of folders from all the projects on the server with names that match the search.

Select the folders you want to affect by checking the boxes in the **SELECT** column.

Choose the Permission Set to assign to each of these folders from the list. If required, also check the **IGNORE PARENTS** checkbox.

When your selections are complete, click the **ASSIGN PERMISSIONS TO CHECKED ROWS** to apply the selected Permission Set to all the selected folders.
Using Impersonation to Lock Down the Server Folder

When Permissions are enabled, Smartware Studio limits the users’ access to projects and files. However, the Projects sub-folder in the shared folder on the file server is, by default, accessible by all users. In order to close this back-door access, you can:

- Create a Windows domain-level account (e.g., SmartwareStudioUser).
- In Windows, grant full access to the Projects folder to this account
- In Windows, remove access to the Projects folder for all other regular users.

Once this new account is created and configured, you must give these credentials to Smartware Studio, which will use them for all file access to the Projects folder.

- Select Admin→Permissions
- Click the Configure File Server User Account… button

- Fill in the Domain, Username and Password fields.
- Check the Enable Impersonation checkbox
- Click the Test Impersonation button to make sure the settings are correct.
- Click Save

If the configuration is correct, users should be able to open files from and save them to the server (if they have the appropriate permissions).
11. The Parts Database Manager

Smartware Studio includes a detailed Parts Database with a full-featured Database Manager. The parts in this database are used:

- For browsing of parts, prices and PDF cut sheets (TOOLS→PARTS→BROWSE ALL PARTS, etc.)
- For selecting parts for a System when using the Estimating Module.
- For associating physical parts with Designer stencil shapes in engineering drawings and reports.
- For creating Designer Valve Schedules.

There are a few steps you must take to initialize, update, customize and distribute the Parts Database to all users.

Accessing the Parts Database Manager

You open up the Parts Database Manager by selecting ADMIN→PARTS DATABASE. The Parts Database manager will open in a separate window with its own set of menus.

If you do not see the ADMIN menu, or don’t see the PARTS DATABASE command on the ADMIN menu:

- Ensure that you, as a user, have the rights to manage the Parts Database. This is specified in the Add/Edit User dialog in the ADMIN→USERS AND LICENSES tool.

- You will need to restart Smartware Studio after giving yourself this permission for the change to take effect.
Keeping the Parts Database Up to Date

The Parts Database lives in three places:

- The Master Parts Database resides on Smartware’s server.
- Your Company’s version of the Parts Database resides on your Company’s SQL Server.
- A copy of your Company’s version is converted into a Microsoft Access file that is stored on your file server and automatically downloaded to each of your users’ workstations.

The Dashboard

When you start the Parts Database Manager, it will automatically contact Smartware’s server and see if there are any updates available to the Parts or the PDF Library. If so, you will be greeted by a message such as:

![Smartware Studio message](image)

and the Dashboard will come up automatically.

- You can also bring up the Dashboard at any time by select FILE→DASHBOARD.
- If the Dashboard opens automatically (as it will if there are updates to make), in order to access the FILE and other menus options, you might need to close the dashboard window.
The Dashboard shows you the status of your part and PDF data and allows you to make any updates:

- If the version and/or date of your server is older than the one available from the Smartware Master Database (as it is above), click the button next to **SYNCHRONIZE YOUR COMPANY’S DATABASE WITH SMARTWARE’S** to update your server with the latest parts and pricing.
- After you synchronize with Smartware or make any additions or customizations to the parts, you will need to click the button next to **PUBLISH YOUR COMPANY’S DATABASE TO USERS** to get those changes to your users.
- The **PDF Files and Part Images** tab is described in the later section on **Managing PDF Files**.
What Does Synchronizing to the Smartware Master Database Do?

When you *synchronize*, all the tables and master part data records are copied from the Smartware Master Database into your SQL Server database. This will give you the latest parts and pricing information.

- Any custom records (such as Parts, Discount Multipliers, Companies or Categories) that are in your Company database will be left alone when you synchronize.
- If you receive a timeout error when synchronizing to the Smartware Server, select Options ➔ Options and increase the timeout value.

What Does Publishing to Users Do?

The Company’s copy of the Parts Database resides on the SQL Server, but each workstation uses a *cached* copy of the database converted to a Microsoft Access database file (named P2Cache.mdb). This allows them to work equally well offline and disconnected.

Any time you make changes to the Company’s Parts Database (i.e., re-synch to the Smartware version, add custom parts, change multipliers, etc.) you will want to *publish* a new version for the end users.

Subscribed Parts

The parts in the Smartware Master Parts Database are organized into groups called *Recordsets*, which usually represent a specific product line or vendor.

- Our central Customer Database determines which recordsets (and therefore parts) you download when you synchronize to the Smartware Master database. If you feel you do not have all the part data you would expect, [please contact our technical support department](#).
Quick Start Setup of the Parts Database
To get started with the Parts Database, you should do the following steps. Later sections of this chapter explain some of these tasks in more detail.

- Open the Parts Database Manager
- Synchronize your Company’s Parts Database with Smartware’s
- Update the Discount Multipliers to reflect your pricing with the vendors
- Publish the Parts Database for your Smartware Studio Users

Open the Parts Database Manager
- From the Smartware Studio ADMIN menu, select PARTS DATABASE.
- Refer to the section at the beginning of this chapter, Accessing the Parts Database Manager, if you are unable to access the Parts Database Manager.

Synchronize the Company’s Parts Database with Smartware’s
- Select FILE→DASHBOARD
- Click the SYNCHRONIZE YOUR COMPANY’S DATABASE WITH SMARTWARE’S button.
- Refer to the earlier section on Keeping the Parts Database Up to Date for more details.

Update the Discount Multipliers
While there are many elements of the Parts Database that you can customize, the ones that are most critical are the Discount Multipliers used for calculating net prices. You will want to update these to reflect the values in use by your company.

- In the Parts Database Manager, select DATA TABLES→DISCOUNT MULTIPLIERS…
- Select and double-click the Vendor and Discount Code you want to change.
- Select the CUSTOM FOR OUR COMPANY radio button and enter the appropriate multiplier for your company. The multiplier will show with a light blue background in the Discount Multipliers list after you update it.
• You may need to update several multipliers for the same vendor.

Publish the Parts Database for Smartware Studio Users

The Company’s copy of the Parts Database resides on the SQL Server, but each workstation uses a cached copy of the database converted to a Microsoft Access database file. This allows them to work equally well offline and disconnected.

Any time you make changes to the Company’s Parts Database (i.e., re-synch to the Smartware version, add custom parts, change multipliers, etc.) you will want to publish a new version for the end users.

• Select FILE ➔ DASHBOARD
• Click the PUBLISH YOUR COMPANY’S DATABASE TO USERS button.
• Refer to the earlier section on Keeping the Parts Database Up to Date for more details.
Adding and Updating Individual Parts

There are numerous ways you can add and modify the parts in the database. This section will cover the following customization tasks:

- Selecting Top Parts
- Adding a New Part
- Adding a Manufacturer or Vendor
- Updating or Adding a Discount Multiplier
- Duplicating an Existing Part

**Note:** Remember to publish the Parts Database for all Smartware Studio users after any updates. Refer to the previous section Keeping the Parts Database Up to Date for more information.

Selecting Top Parts

To help your users make their way through the tens of thousands of available parts, you can flag a subset of the parts as your Top Parts.

- In most places in Smartware Studio where the user can select a part (e.g., TOOLS → PARTS → BROWSE ALL PARTS), there is a checkbox that can be used to filter the list to show only the Top Parts.
- There are also reports in the Estimating Module that allow you to compare a list of parts in a system to see if any of them are not Top Parts.
- Your Top Part selections will not be overwritten when you resynchronize your Parts Database with Smartware’s.
To select your Top Parts:

- In the Parts Database Manager, select **DATA TABLES** → **PARTS**

  - Filter to find your part and select it in the list. An ‘X’ in the *Top* column indicates if the part is already a Top Part.
  - Click the **SET AS TOP PART** button or right-click on the part and select **SET AS TOP PART** from the menu.

**Adding a New Part**

You can add a single part directly to the database. Your parts are segregated from the Smartware parts.

- When you resynchronize your Parts Database with Smartware’s, your custom parts are not affected.

To add a new part:

- In the Parts Database Manager, select **DATA TABLES** → **PARTS**
• Click on the NEW PART button

- If the Manufacturer or Vendor is not available in the list, you will need to add a new record to the Manufacturers and Vendors table. Refer to the later sub-section.
- If the Vendor’s Discount Code does not appear in the list, you will need to add a new record to the Discount Multipliers table. Refer to the later sub-section, *Updating or Adding a Discount Multiplier*.
- For the PDF Documentation Files, enter only the filename (without any path or drive information). Refer to the later section on *Managing PDF Files*.
- Refer to the later section on *Part Properties* for more details on the individual part fields.

**Updating a Part**

You can show the part detail for any part by selecting it from the DATA TABLES→PARTS list.

- If you open one of your custom parts, you can modify all the fields and make all changes.
- If you open the parts from the Smartware Master Database, you will only be able to change a few specific fields.
You can also use the UPDATE EXISTING PARTS tool to update or modify part information individually or in bulk through importing a spreadsheet.

- Refer to the later section, Exporting and Updating Multiple Parts for details.

**Custom Vendors**

You can specify custom Vendor information for a part in the standard database. When editing a part, there is a Custom Vendor tab where you can choose a new Vendor and specify the Vendor Part Number, List Price, Discount Code or Individual Discount Multiplier, and Price as of Date.

- This does not apply to parts added by your Company or by individual Users, as the main Vendor is already specifiable by you.
- Users cannot override the Vendor for any parts, as this can only be done by a Parts Database Administrator.
Adding a Manufacturer or Vendor

There is a separate table of information in the database with a list of companies that are the Manufacturer or the Vendor for one or more parts.

To view the Manufacturers and Vendors list:

- Select the DATA TABLES ➔ MANUFACTURERS AND VENDORS menu command

- The Company ID (in the 3000 range for the companies in the Smartware set of data and the 21000 range for the companies that you added to your Company version) is used as the ManufacturerUID and VendorUID values when importing and exporting parts.
To add a new Company, click the NEW COMPANY button:

- The Company ID will be assigned after the record is created and shown in the Company List.
- Check the IS A MANUFACTURER and/or the IS A VENDOR checkbox to make the company available to select in the Manufacturer and Vendor lists when adding, editing and importing Parts.

**Updating or Adding a Discount Multiplier**

The Parts Database calculates the Net Price of a part by multiplying the List Price by the Discount Multiplier. The Discount Multiplier can be 1.000 (which indicates that the Net Price equals the List Price, or no discount), or a smaller value such as 0.750 (indicating the Net Price is 75% of the list price or discounted by 25%).

Each part can have its own Discount Multiplier, but it is much more common to use a Discount Code to represent the multiplier. This allows the multiplier on a whole set of parts to be updated at once.

- For each Vendor you can specify as many Discount Codes as you want.
- Discount Codes can be any text or numeric string.
- You can override the Discount Multiplier values for the Discount Codes specified for Smartware parts.

To edit an existing Discount Multiplier:

- In the Parts Database Manager, select DATA TABLES→DISCOUNT MULTIPLIER
- Select and double-click the Vendor and Discount Code you want to change.
• Select the CUSTOM FOR OUR COMPANY radio button and enter the appropriate multiplier for your company. The multiplier will show with a light blue background in the Discount Multipliers list after you update it.

• You may need to update several multipliers for the same vendor.

To add a new Discount Multiplier, click the NEW MULTIPLIER button.

**Duplicating an Existing Part**

If there is an existing part, either from the Smartware Master Database or one you created for your company, that is very similar to a new part you want to create, you can duplicate the existing part to use as a new part.

• Select DATA TABLES → PARTS to display the parts list.
• Select the part you wish to duplicate.
• Click the DUPLICATE PART button, or right-click on the part and select DUPLICATE PART.
The Add New Part dialog will appear with all the same information as the selected part.

- You will want to change the Part Number field and update any other fields that differ.
- When you are done, click OK to create the new part. If you click Cancel, the part will not be created.

Importing Multiple New Parts

If you have a number of parts to add at once, you can create a spreadsheet with all the relevant information and import them all together.

- From the File menu, select IMPORT NEW PARTS.

Step 1: Create the Import Spreadsheet

The part data need to be imported from a template worksheet:

- Click the GET IMPORT TEMPLATE button to get the latest template Excel workbook.
- The workbook contains two worksheets: (1) a description of all the importable fields; and (2) the worksheet on which to enter the part data fields. The Import Parts worksheet contains a sample row of information.
You can save the template anywhere on your workstation, but it is saved by default in an appropriate Application Data folder.

You may need to create a custom Manufacturer or Vendor to enter the appropriate MfgUID or VendorUID. Refer to the earlier section in this chapter.

If you have part data in a workbook from the vendor or manufacturer, it is recommended that you copy and paste it into and Import Template to ensure that the column names are correct.

**Step 2: Import Parts from Spreadsheet**

Once you’ve entered the part data in the workbook, you can import the data into the Parts Database Manager.

- Click BROWSE and select the saved import workbook.
- Select the worksheet with the parts (e.g. Import Parts)
- Click the GENERATE PREVIEW button

**Step 3: Preview and Verify the Imported Parts**

A preview of the import will be shown. If there are warnings or errors, they will be displayed as well.

- You can still import the parts even if there are warnings.
- You cannot import the parts if there are any errors.
- When the data has been reviewed and any issues resolved, click ADD PARTS TO DATABASE to actually import the parts.

Once you have added the parts, be sure to publish the database to your users from the Dashboard. Refer to the early section in this chapter.
Exporting and Updating Multiple Parts

There will be times when you need to update a set of parts at one time. The most common example is when you receive a pricing update from a vendor whose parts you have imported into your Company database.

The general concept for doing this type of update is:

- First export the parts from the parts database into a standard format with all the current values filled in, including the PartUID (the unique number that identifies each part in the database).
- Next, make any changes to any of the data values in the spreadsheet. You can easily paste in information from other sources or use Excel functionality such as Fill Down or formulas to make it easier.
- Finally, import that spreadsheet back into the Parts Database Manager. It will find any new or changed values and update the database accordingly.

To begin the process, select **File → Update Existing Parts**.

**Step 1: Create a Part Import Spreadsheet by Exporting Existing Parts**

The Export Parts for Update utility is actually separate (**File → Export Existing Parts**), but you can access it from the Update Parts dialog by clicking the **Export Part Spreadsheet** button.

- The Export Parts tool allows you to filter the parts in any number of ways.
Be sure to include the columns that you want to update in the export, even if the current values are empty. This will give you a place to fill in new values.

If you really want to, you can also use your own spreadsheet format for updating the data. Just be sure the column names match exactly. You must also have a PartUID or PartNumber column, as that is the key that is used to find the part when updating.

**Step 1a: Update the values in the Spreadsheet using Excel**

After you export the existing data, fill in new values or overwrite existing values that you want to change.

- When re-importing, the utility will match the parts on the PartUID number, so do not modify the PartUID values.
  - You can change the Part Number if the PartUID is also available as a column in the spreadsheet being imported.
- You cannot add new parts by adding rows. You must use the IMPORT NEW PARTS tool instead.
- If the part is in the Smartware database (e.g., you did not add it to your company’s database), most of the fields are not changeable. Exceptions include IsTopPart and SellPrice1.
- The Excel VLOOKUP function can be very useful for merging values from another spreadsheet into the generated import spreadsheet.

**Step 2: Import the Updated Values from the Spreadsheet**

Next you will open the Excel file with the updated part data and indicate the data to reimport and update.

- Click the BROWSE button and select the Excel file with the updated part data.
- Select the appropriate Worksheet Name.
- If all the parts are in a specific Extended Property Category, select it to have these properties included.
- If you want to filter the list of parts that will be updated, you can specify a WHERE clause in the standard SQL format (e.g., PartNumber LIKE ‘A%’ or ImportThis = ‘X’)

Click the IMPORT DATA button and the two lists of columns will be filled in with the names of the columns that correspond to database fields.

- Check the Columns to Update. The values in these columns will be compared to the current values for those parts in the database and will be updated if they are different.
• Optionally check the *Columns to Preview*. The current database values for these columns are added to the Preview table for your reference. They will not be modified in the database.

• Columns without header names or with header names that aren’t a database field will be ignored.

**Step 3: Preview and Verify the Updated Part Values**

Click the GENERATE PREVIEW button to import the data and preview the changes.

• Each row will indicate if any changes were found.

• *Warnings* and *Errors* will be noted in the Status columns

• Values will be color coded in the grid: *Changed* (green), *Warnings* (yellow) and *Errors* (red)

• You can filter the results with the radio buttons: *Show All Parts*, *Show Only Changed Parts*, *Show Only Errors*, *Show Only Warnings*

• You can export these preview results to Excel for offline review.

**Step 4: Update the Database with the Changes**

When you have addressed all the issues, you are ready to post the changes to the database

• If there were any errors in the Preview, you cannot update the database. You can, however, update the database if there are only warnings.

• Click the UPDATING PARTS IN DATABASE button to apply the changes permanently to the database.

Once you have updated the parts, be sure to publish the database to your users from the Dashboard. Refer to the early section in this chapter.
**Part Properties**

There are numerous pieces of information associated with every part in the database. Many are discussed at various places in this chapter, others are self-explanatory, and some are associated with specific modules of Smartware Studio (e.g. only Estimating or only Designer).

- You can see the lists of fields with notes about using, importing and exporting them by selecting HELP→PART FIELD REFERENCE.

**Extended Properties**

For use with the Designer Module, some categories of parts have additional properties that provide technical details used to provide detailed part filtering and selection, and to draw and fill in information in the corresponding Visio shapes for the part.

- Examples of the Extended Property Categories are: Relays and Sensors.
- These category names are distinct from and essentially unrelated to the Part Category field discussed earlier in the context of Labor Categories.

The Extended Properties are specified on the Extended Properties tab of the Add/Edit Part form.
• When you select the Extended Property Category, the Extended Properties sub-tabs (*Filter Properties* and *Shape Properties*) will repopulate with the specific properties of that category.

• The Filter Properties are generally used in category-specific part selectors (when editing the Designer shape, or from the TOOLS→PARTS→BROWSE PARTS menu):

![Select a Part Form](image)

The Shape Properties provide information into the Designer to customize the corresponding Visio shape when the part is selected in Visio.
Here are the Shape Properties for a specific relay:

And here is the corresponding relay when selected in the Relay Shape in Designer:

- When creating your own parts in an extended property category, you will want to refer to the Designer shape’s Properties form and view (or duplicate and edit) existing parts from the Smartware Master Database that are in the category and are similar.
- You should also refer to the Part Field Reference list available from the Part Database Manager’s Help menu.
**Importing and Exporting Extended Property Values**

Since each Extended Property Category has its own properties, you cannot import the extended property values at the time you import the parts. Instead, you must first set the `ExtPropsCategory` field to the name of the extended property. You can then Export and Update the parts.

The *Export Parts for Update* tool allows you to specify the Extended Property Category. This can filter the selection down to only parts in the category. It can also automatically add all the extended properties as columns in the exported spreadsheet.

Many of the extended properties must be selected from a list of choices. The generated spreadsheet will have these values available from a drop-down list.

Some extended properties allow more than one value to be specified from a list. They must be formatted as a semi-colon separated list of the allowable values (as in the *CoilVoltage* field above).
If you specify the Extended Property category when importing the data back in to update using the Update Existing Parts tool, the extended properties for that category will be available in the **Columns to Update** and **Columns to Preview** list. You can also choose to update all the extended properties by clicking the **Select Ext Props** button.

### Multiple Configuration Sensors

For the Sensor shape, it is possible for a part to define multiple configurations of the properties and allow the end user to choose between them when they create the sensor.

To manage this, there is an Extended Property called *ExtPropConfigurations*, which itself is a set of lists of property values with names. For example:

\[
\text{ConfigName=Voltage 5, OutputSignalRange=0-5 VDC;} \\
\text{ConfigName=Current, OutputSignalRange=4-20 mA, ShowResistor=True;} \\
\text{ConfigName=None;} \\
\text{ConfigName=Voltage 10, OutputSignalRange=0-10 VDC}
\]

In this case, there are four configurations:

- "Voltage 5", which as the first is the default, sets *OutputSignalRange* to 0-5 VDC.
- "Current", which sets *OutputSignalRange* to 4-20 mA and *ShowResistor* to True.
- "None", which leaves the *OutputSignalRange* unchanged.
- "Voltage 10", which sets *OutputSignalRange* to 0-10 VDC

If multiple configurations are specified, then the Sensor's Part Properties will offer the user a list of these choices and set the properties accordingly as they switch between them.
Part Groupings

There are three user-definable Group fields that are available in the Parts Table. These group codes are carried forward to an Estimate and can be used as a reporting Group field.

- The three User-defined Group fields are *UserGroup1*, *UserGroup2* and *UserGroup3*.

You can specify them explicitly with each part you add or edit on the Sort Fields tab:

- You can specify values for these fields on all parts, including those maintained by Smartware.
- You can import these values using the Parts Database Manager’s *Import New Parts* or *Update Existing Parts* tools.
- There are no pre-defined values for the Smartware parts.
- When selecting a value for these fields in the Parts Database Manager or a part item in a System in an Estimate, the user will be presented with a list of all the values for the existing parts in the database, but can enter custom values.
You can also pre-define the set of values for these fields.

- In the Parts Database Manager go to **DATA TABLES→PART GROUPINGS**

![Part Groupings](image)

**Labor Factors and Part Categories**

One way in which the Estimating Module calculates the amount of labor needed for a system is to look at each part for its labor factors. The **Labor Factors** specify the number of hours of labor for each task associated with a part.

- The Designer Module does not utilize the Labor Factors in the database.

The tasks are specified as Labor Codes:

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENG</td>
<td>Engineering</td>
</tr>
<tr>
<td>SOFT</td>
<td>Software</td>
</tr>
<tr>
<td>GRAPH</td>
<td>Graphics</td>
</tr>
<tr>
<td>PM</td>
<td>Project Management</td>
</tr>
<tr>
<td>CTS</td>
<td>Check/Test/Start (includes installation)</td>
</tr>
<tr>
<td>ELEC</td>
<td>Electrical work (often subcontracted)</td>
</tr>
<tr>
<td>MECH</td>
<td>Mechanical work (often subcontracted)</td>
</tr>
<tr>
<td>PANEL</td>
<td>Panel Building</td>
</tr>
<tr>
<td>COMM</td>
<td>Commissioning</td>
</tr>
<tr>
<td>TRAIN</td>
<td>Training</td>
</tr>
</tbody>
</table>
You can create your own Labor Codes for use with the Estimating Module. This requires some changes in the Part Database Manager and some in the Estimate's Model.


Some of the Smartware parts in the database have labor factors specified. Since the concept requires a certain amount of guess work (e.g. how many hours of Project Management time do you attribute to an individual sensor?), the populated data may not match your needs. If you utilize this feature of the Estimating Module extensively, you may want to review and update these values.

**Specifying Labor Factors for a New or Existing Part**

When you create or edit an individual part, the Labor Factors are specified on one or two tabs (Labor Factors and/or Custom Labor Factors)

- For parts that you add to the database, you specify the labor factors (in hours) for each labor code on the *Labor Factors* tab.
For Smartware parts, the Labor Factors tab is read-only. Instead, you can specify your own labor factors on the Custom Labor Factors tab.

**Specifying Labor Factors when Importing and Updating Multiple Parts**

When using the Import New Parts or Update Existing Parts utilities described earlier in this chapter, you can specify labor factors for new parts and existing Smartware parts.

- When Importing New Parts, there are columns in the Import Template for each labor code (ENG, SOFT, GRAPH, etc.). Fill in the hours for each labor code for each part (in hours, or fractions of hours).
- When Updating Existing Parts that you added, you would again fill the values in using the labor code columns (ENG, SOFT, GRAPH, etc.).

When Updating Existing Parts that are part of the Smartware Master Database, you need to update a different set of fields that correspond to the parameters on the Custom Labor Factors tab.

- To activate the custom values, you will need to set the UserUsePartLabor column to ‘X’ or True in the update spreadsheet.
- The column names for the custom labor factors themselves are UserENG, UserSOFT, UserGRAPH, etc. Any labor codes you do not specify explicitly will default to 0 (i.e., they will NOT use the existing values in the part, so you would need to copy in values you want to keep).
- If you want to set a new *Category for Labor* (as described in the next subsection), import the `UserUseCategoryLabor` field as ‘X’ or ‘True’ and fill in the `UserCategoryClass` field (set to the new category).

**Specifying Labor by Part Categories**

The parts in the database are classified into a hierarchical *Category Tree*. This tree is available during parts browsing to help locate specific types of parts:

Another feature of Part Categories is that you can associate a set of labor factors to each category and sub-category. These values can then be used to either override the values specified in the parts, or to specify them in cases where the part does not have any of its own.
To view and modify the categories in the Part Category tree, select **Data Tables → Part Categories**.

- Some of the Part Categories are defined by Smartware and cannot be removed or renamed.
- You can add your own categories and sub-categories for use with any of your parts.
- Categories with labor factors specified are shown in bold in the tree.

If a part is in a specific category, these rules are used to determine the Labor Factors for the part when it is added to a system:

- The first set of options (**Where to Find Labor Factors for Parts in This Category**) determine whether the category labor factors overrides the labor factors specified with the part, or whether the category labor is a “catch-all” default for parts in the category that do not have their own labor factors.
- The second set of options (**Category-Based Labor Factors for Parts in This Category**) determine the category-based labor factors to use (in the cases where they are to be used). If there are category labor factors in the Smartware Database, they will be shown. If you select **Use Custom Labor Factors**, you can specify your own.
- If there are no labor factors for a specific category (e.g. **Actuators.Electric.Forta**), the labor factors for the closest parent category (**Actuators.Electric** or **Actuators**) will be used instead.
**Using Custom Categories for Labor Codes**

Even if a part is from the Smartware Master Database, you can still use Part Categories to specify a set of labor factors for one or more parts.

When editing a single part from the DATA TABLES → PARTS list, the Custom Labor Factors tab has an option for selecting a Custom Part Category to use for labor:

- You can choose an existing labor category or create a custom one from DATA TABLES → PART CATEGORIES.
- This category field does not affect where the part is shown in the Category tree of when browsing for parts. It is only used to get the labor factors.

You can use the Update Existing Parts tool to fill in the Custom Part Category on a group of parts at the same time.

- To activate the custom values, you will need to set the `UserUseCategoryLabor` column to ‘X’ or True in the update spreadsheet.
- Fill in the `UserCategoryClass` column of the spreadsheet with the name of the category.

When importing the class name, or path, it must be in a specific format that is different from how it’s displayed. For example, the Air Quality sub-category under Sensing & Monitoring is displayed as:

>Sensing & Monitoring / Air Quality
But the class name to specify during importing is:

*Sensing&Monitoring.AirQuality*

The exact format of the category *Class Path* (which uses dots between levels and excludes many spaces) can be seen when using the DATA TABLES → PART CATEGORIES tool:
Managing PDF Files

As part of the Parts Database, Smartware Studio maintains a set of PDF files with product information for the Parts. These files are referenced in the five PDF File fields and are associated with the part as one or more of the following:

- Submittal
- Installation
- Reference
- Programming
- Other

**Downloading PDFs and Part Images for Smartware Master Parts**

When you start the Parts Database Manager, you will be shown the Dashboard if there are new or additional PDF files or part images to be downloaded from Smartware to your company server. Go to the PDF FILES AND PART IMAGES tab of the Dashboard to manage these downloads.

- To get the latest PDF and Image files from Smartware, click the arrow next to **DOWNLOAD THE LATEST PDFS AND IMAGES TO YOUR SERVER**.
- Depending on how many files there are, this could take some time. Consider doing the initial download during off hours or possibly overnight.
Where the PDF Files are Stored on Your Server

The files are stored on the file server in a sub-directory of your shared folder, such as:

\OurServer\Smartware Studio Data\Resources\PDF Files\

There are two sub-folders in this folder:

- **Smartware**, which contains the latest PDF files for the Smartware Master database parts. These are downloaded here when you synchronize the PDF Files.
- **Company**, which is where you should copy PDF files for any parts you add to your Company’s database. You can create subfolders to help you organize the PDF files if you wish.

You can easily access these folders from the Manage PDF Files tool:

- From the Dashboard’s PDF Files page, click **MANAGE PDFS**
- Alternatively, you can select **DATA TABLES → PDF FILES**

![Screen Shot](image)

- Click the **OPEN COMPANY PDF FOLDER** to browse to the root PDF folder.

Publishing PDFs to Users

For any users who want them, Smartware Studio should be configured to download the PDFs from the server to their workstation. Assuming it’s configured to, when the workstation starts up it checks the server to see if there are any new PDFs and offers to download them. The workstation uses the PDF Version Number to determine if there are new files available.
• This version number is specific to your Company. You should update this version number (by clicking the UPDATE button) after you add new PDFs. It will be updated automatically when you complete a download of new PDFs from the Smartware Master server.

To check if PDFs are automatically updated on a workstation:

• Go to Tools→Check for Updates and click the Options button.
• In the Always Download and Update the following list, check PDF Files.

**User Parts**

Users can create their own parts to use in certain features, such as the Estimating Module.

• When browsing parts to add to a System, there is a tab called MY PARTS which shows their User Parts and allows them to manage them.
• User Parts can also be managed by selecting TOOLS → PARTS → MANAGE MY PARTS

User Parts contain less information than full-fledged database parts, but enough for them to be used within the system. Therefore, users can add such parts quickly.

**Submitting and Approving User Parts**

If a user thinks a part should be available to all users in the Company, they can submit them to the Database Administrator.

• To submit a User Part, select it in the list and either click the SUBMIT FOR APPROVAL button or right-click and choose the SUBMIT FOR APPROVAL menu item.
• Parts can also be unsubmitted and resubmitted as needed.

The Parts Database Administrator can choose which submitted parts to import into the main database.

• In the Parts Database Manager, select DATA TABLES→USER PARTS FOR APPROVAL

This will show you a list of all the submitted parts pending approval. From here you can choose to reject the part or import the part.
• When you import the part, you will be required to fill in additional fields (such as the Manufacturer or Vendor) or create other records (such as a discount multiplier).

• The new part will be available to all users (including the one who created it) the next time the database is published for Smartware Studio users.

**Being Notified of User Parts Awaiting Approval**

If you are a Part Database administrator and want to receive an email when a user submits a part for approval:

• In the Parts Database Manager, select **OPTIONS → OPTIONS**
• Check the **Subscribe to User Parts Submitted for Approval**

![Parts Database Manager Options](image)

• This feature requires that the Studio Windows Service and the Notifications service be installed and configured. Refer to the next chapter for more details.
Part Packages
The Parts Database includes a feature that allows you to group multiple parts together into a Part Package. A package can contain parts, extra labor items and point data for a system, and can be added to an Estimate system as a unit.

- To manage the Part Packages, select DATA TABLES → PART PACKAGES

You will see the packages shown in three folders: Enterprise, Company and User.

- To add a package, right-click on the appropriate folder and select NEW PACKAGE.
- Right-click on a package in the folders to edit, duplicate or delete the package.
- When you edit or create a package, you can populate the Parts List, along with the Points and Labor lists.

Though they once were, the Part Packages are not stored in the database.

- They are stored as individual files with a .stpkg extension.
- They are distributed to company users with regular updates, and do not require the Parts Database Manager to publish the parts database to update the packages.
- They can be organized into folders. Right-click on any folder and select OPEN FOLDER to view the folder and package files in Windows Explorer.
- They can be created by and shared between individual users for their own use.

The Company packages, which are distributed to all users automatically, are stored in the server folder in the Resources\Parts Packages\Company folder.

- You can copy and paste individual files into this folder freely.
• You can create sub-folders to organize packages by right-clicking on a folder and select NEW FOLDER.
  o Users will see the folder structure when browsing for packages.
• All the package files and folders are copied to the user’s machine during updates.

Packages are stored on each workstation in the [Application Data]\Part Packages folder.

• There are separate sub-folders for User and Company.
• User created packages are stored in the User folder and are only available on that workstation.
• The Company folder is a copy of the Resources\Parts Packages\Company folder from the server. Any files added to the user’s version of the Company folder will be overwritten or removed.

The Package selector in an Estimate’s System node shows the packages and separates the User’s packages from the Company’s packages.

• The user can edit their own packages by going to TOOLS→PARTS→MANAGE MY PACKAGES.

**Updating Packages**

When a Package is added to an Estimate, the price and other properties are automatically updated to the latest values from the Parts Database. If all the parts are in the database, you do not have to do any additional maintenance of the packages.

You can also do a Find and Replace on various properties (such as custom price) of the Parts in one or more packages.

• When managing company or user packages, right-click on a package or folder and select FIND AND REPLACE PARTS.

**Service Equipment and Tasks**

There are additional tables for importing and managing a list of types of Service Equipment and common maintenance Tasks for each. These tables are described in the Service Estimating User’s Guide.
12. The Studio Windows Service

The Studio Windows Service is an additional component that can be installed and run on a server to provide additional features of Studio that require some server intervention or outgoing emails, including:

- The Email Forwarding Service allows you to create a set of incoming mail address based on a sub-domain that automatically route onto the Email tab of a specific folder in a specific project (e.g., AbcSchools@studio.ourcompany.com).
  - This feature requires the installation, setup and configuration of a separate incoming SMTP server, as described later in this chapter.
- The File Notification Service allows your users to “subscribe” to changes to files or folders in any project with an immediate, daily or weekly notification.
- The Password Monitoring Service allows an administrator to be notified when any user views, adds or changes a password stored on a Network Tree device.
- The Task Notification Service sends various types of notifications about Tasks from the Management Module.
- The Cloud Accounts Service allows you to set up a constant synchronization of files and folders between Studio and a Cloud Account, such as Box.
- The Web Service creates a portal for the Mobile App and other devices outside the network to communicate with Studio.

Installing the Studio Windows Service

The Studio Windows Service must be installed on a server that can access the other server elements, specifically:

- The Shared Folder and the Studio SQL Server.
- If using the Email Forwarding Service, it must also have access to the mail drop folder of the incoming SMTP server.
  - Do not plan to install the incoming SMTP server on a machine already handling email, such as an Exchange Server.

**Note:** The machine on which the Windows Service runs needs to have access to the Site.ini file in its Config folder. This happens automatically if the machine was used to set up the server, or if the machine was ever licensed as a workstation. If necessary, you can license and unlicensed the machine to get the Site.ini file.
The general steps to configure the service are:

- Create a new domain user to be used by the service (optional)
- Install and configure the service, including the outgoing SMTP server.
- If using the Email Forwarding Service, install and configure the separate incoming SMTP server.

Create a Domain User for the Service (Optional)
It is highly recommended that you create a new domain user (e.g., SmartwareStudioServiceUser) specifically for the service. The account should have a strong password that never changes, and must have full read/write access to the following:

- The root of the shared folder for Smartware Studio on your file server (refer to the ADMIN \ SERVER CONFIGURATION AND TOOLS \ FILE AND PROJECTS tab).
- The directory where you will install the Smartware Studio service (C:\Program Files\Smartware Technologies\Smartware Studio by default)
- If using the Email Forwarding System, the mail root folder for the SMTP Server (e.g. C:\inetpub\mailroot in IIS)

You will also need to add the Log on as a Service right to the user account.


Install the Service
The Studio Windows Service is installed through Smartware Studio itself.

- If it’s not already, install Smartware Studio on the server where you will run the service, using the same procedures as you would any workstation. Refer to the earlier chapter as necessary. You do not need to license the workstation to use the Windows Service Administration tools.
- Launch Smartware Studio.
  - In many cases, it will be best to RUN AS ADMINISTRATOR.
- From the ADMIN menu select WINDOWS SERVICE.
• Go to the **SERVICE CONTROL** tab.

![Windows Service Configuration](image)

• Click the **INSTALL** button to install the service.
• If you are using a specific domain account for running the service, select **THIS ACCOUNT** under **LOG ON AS** and enter the **account** name and **password**.

After all other configuration in this chapter has been completed, you can click the **START** button to start the service. Once installed, the service should automatically restart any time Windows is restarted (**Startup Type** is **automatic**).

**Manually Controlling and Configuring the Service through Windows**

If you need to access the Service configuration directly from Windows:

• From the Control Panel, select Administrative Tools, then Services; or search Windows for “Services”
• Scroll down the list until you find Smartware Studio Service. Right-click on the Service and select Properties.

Configure an Outgoing SMTP Server

Each of the services sends outgoing emails:

• The Password Monitoring and File Notification services use outgoing emails for their notifications to the user.
• The Email Forwarding Service sends error messages to a configured administrator in cases where it cannot route the incoming email.
• The Service itself sends a daily Status Report to an administrator to confirm the service is running properly.
  o The Windows Service will also send separate emails to any user configured to receive Status Reports when an updated version of Smartware Studio needs to be installed on the machine running the service.

To send these emails, the service will need access to an Outgoing SMTP Server.

• Many ISPs make an outgoing SMTP server available over the network (e.g., mail.twc.com). Consult your ISP or network provider for details.
• This is NOT the same as the incoming SMTP Server used by the Email Forward Service, as described later in this chapter.
• Some email providers, such as Gmail or Hotmail, allow the accounts to be used as outgoing SMTP servers. Click the LOAD PRESET button for more details.
To configure the Outgoing SMTP Server:

- Go to the OUTGOING EMAIL tab of the Windows Service Configuration dialog.
• Enter a ‘From’ address to use on these emails (e.g., StudioEmails@ourcompany.com).

• Under SMTP SETTINGS, enter the SMTP Server Address.
  - If necessary, specify a custom Timeout
  - When using a Gmail or Hotmail account, you will need to specify the Advanced Settings per that provider.

**Testing the Outgoing SMTP Server**

Once configured, you should test the Outgoing SMTP Server by entering an Email Address to send to and clicking the Send Test Email button. You should also try this with an attachment of various sizes to confirm that the Outgoing SMTP Server allows attachments.

**Configure Status Emails**

You should also specify a list of one or more administrative users to receive the daily status report that indicates the service is running properly.

• In the Status Email Settings box, enter one or more email addresses, separated by semi-colons.
• You can also choose the time and frequency of these status reports.
The Email Forwarding Service

The Email Forwarding Service allows a user to send Smartware Studio an email from any email client (such as Microsoft Outlook) and have that email appear in Smartware Studio in a specific folder in a specific project. For example, a user could send an email to WilsonCSD@studio.yourcompany.com, and have that email appear in a correspondence folder of the Wilson CSD project.

Overview of the Email Forwarding Service

The service works with two elements:

- An Incoming SMTP Mail Server on any of your servers, which accepts the incoming mail from the internet and saves the messages to a known location on your network.
- The Studio Windows Service, which server polls the SMTP server’s inbox and transfers the messages into the appropriate Smartware Studio project.

In addition, you will want to create a sub-domain record for the incoming email.

---

**Note**: Setting up and configuring these elements requires a detailed knowledge of Windows and Windows Server administration. You should not attempt these configurations without first consulting your IT Administrator.

---

In deciding which server or servers on which to install these services, consider the following:

- To avoid conflicts, the SMTP Server should never be installed on a Microsoft Exchange Server or any other server running an application with email functionality.
- The Smartware Windows Service will need full access to the SMTP Server’s mail drop folder (e.g. C:\inetpub\mailroot\drop in IIS). It will also need full access to the Smartware Studio shared folder on the file system and the Studio SQL Server database.

Setting up an Incoming SMTP Server

You can choose any incoming SMTP Server that saves the incoming email as standard .eml files into a folder on your network.

- While we will help where we can, Smartware cannot guarantee that we can help set up any particular SMTP server in any particular network configuration.
The Studio Windows Service

- Refer to the later section in this chapter, *Example: Setting up an Incoming SMTP Server*, for examples of setting up IIS and an incoming SMTP Server

**Configure the Email Forwarding Service**

Once installed, there are a few steps to configure the service:

- In the *Windows Service Configuration* dialog, go to the *Email Forwarding* tab.

  ![Windows Service Configuration](image)

- In the *Folders to Poll* section, click the *Add* button and select the location of the SMTP Server’s mail drop folder (e.g., `C:\inetpub\mailroot\drop` in IIS)

- In the *Servers* section, click the *Add* button, chose the company name and enter the sub-domain name

**Managing Multiple Servers**

If you have an enterprise account with multiple servers, each server will appear in the *Company Name* drop-down.

- You can assign distinct sub-domains to each server or use a single account to handle email for multiple servers. In this case, you may want to use a distinct *Alias Suffix* for each server.
In the example above, email sent to Customer@studio.acme.com would route to the SmartEdge server (10536), while email sent to Customer.sw@studio.acme.com would route to the Smartware Technologies server.
  
  In both cases, it would seek to route the email to a folder with an alias of “Customer”.

**Specifying an Email Alias for a Folder**

Any folder in any project in Smartware Studio can be configured with an email address to receive emails through the service.

- All the email addresses will end with the sub-domain name you created during the configuration (e.g., @studio.yourcompany.com).

To create a new email address, specify the EMAIL FORWARDING ALIAS property of the folder.

- With the project checked out, create and select the folder in the project tree.
- On the right side, select the PROPERTIES tab
- On the Details sub-tab, fill in the EMAIL FORWARDING ALIAS

![Image of folder properties](image)

- The full email address for this folder will be Acme@studio.ourcompany.com, as shown in the properties window (for easy copying and pasting into emails).
- When an Alias is specified on a folder, an envelope icon appears on the icon (as shown).

The Alias can be formatted to include other properties by enclosing them in angle brackets as field codes. For example, the alias
<ProjectNumber>.<Name>

will substitute in those values when calculating the Alias, such as

AcmeCompany.Correspondence@studio.ourcompany.com

- Spaces and other invalid characters are removed from the values when creating the email alias.
- This feature is especially useful in template projects that are duplicated to create new projects, as the values will automatically be updated to those from the new project.
- To see the names of the available properties, select VIEW → PROPERTY NAMES and browse the Properties tabs. The Property Name will be shown in brackets.

**Emailing to a Project**

Once an alias is created, you can send email from any mail client (Outlook, Hotmail, etc.) by using the full alias (Acme@studio.ourcompany.com) in the To, Cc or Bcc line.

The service will poll the SMTP’s inbox folder every 30 seconds or so and copy incoming emails to the appropriate project and folder.

- Once a project is open on a workstation, you will not see any new emails that come in until after your close and reopen the project.

**Generating an Email Import List**

Smartware Studio can generate a list of all the aliased folders in all your projects so you can import it into an address book, such as a global contact list in Microsoft Outlook.

- Refer to the documentation for Outlook or your other mail client for more details on importing contacts.

To generate the Email list:

- From the Windows Service Configuration dialog, select the Email Forwarding tab.
- Click the GENERATE EMAIL MAILING LIST FROM FOLDER ALIASES button.

A CSV file will be generated and opened in Microsoft Excel. Save this file appropriately and follow the instructions for importing into your mail client.
The Notifications Service

The Notifications Service allows users to “subscribe” to Files and Folders in a project and receive an email when files have been changed or added. It also handles some other administrator level notifications, such as when a part has been submitted by a user for approval by a Part Database Administrator.

Subscribing to File Notifications

The user manages their own subscriptions:

- To subscribe to changes to a file or folder, right-click on the file or folder in an open server project and select **Subscribe To File Notifications**.
- Right-click again to select **Unsubscribe To File Notifications**.

The user can also maintain their subscription by selecting **View** → **File Subscriptions**:

- The user can choose how often to receive notifications and unsubscribe to folders without opening the associated projects.
- Refer to the *Smartware Studio User’s Guide* for more detail on subscribing to notifications.
Enabling the File Notifications Service

To enable File Notifications, you must do two things:

- In the Studio Windows Service configuration dialog, go to the File Notifications (Notifications in later versions of Studio) tab and check the server or servers for which you want to send notifications.

- In the ADMIN→SERVER CONFIGURATION AND TOOLS dialog, go to the Files and Projects tab and check the Enable File Subscriptions checkbox.
**Administrator Notifications**

If you are a Part Database administrator and want to receive an email when a user submits a part, image or library for approval:

- In the Parts Database Manager, select **OPTIONS → OPTIONS**
- Check the notifications to subscribe to

![Parts Database Manager Options](image)

---

**The Password Monitoring Service**

The Password Monitoring service can send an administrator an email every time a Password record stored on a Device in the Network Tree is viewed or changed.

To configure this service:
In the Studio Windows Service configuration dialog, go to the *Password Monitoring* tab and check the server or servers for which you want to send notifications.

![Windows Service Configuration dialog](image)

Specify the Email Frequency and a semicolon separated list of email recipients, as well as the other options.

**The Device Password Log Report**

There is also a tool for searching and generating reports of which users accessed which passwords.

- **Go to** `ADMIN → SERVER CONFIGURATION AND TOOLS` **and select the DEVICE PASSWORDS tab.**
Other Services
There are other services that can be configured for the Windows Service. These are described in later chapters and other Guides.

- **Cloud Accounts** are discussed in *Chapter 15.*
- The **Smartware Studio Mobile Application** is discussed in *Chapter 16.*
- The **Task Scheduler** is discussed in the *Management Module Guide.*

Example: Setting up an Incoming SMTP Server
This section will give you examples of setting up an incoming SMTP Server for use with the Email Forwarding Service.

- This example is for illustration purposes only. We do not warrant that this method will work in all scenarios or all versions of Windows, and we can only support such setup to the best of our abilities.

*Note: Setting up and configuring these elements requires a detailed knowledge of Windows and Windows Server administration. You should not attempt these configurations without first consulting your IT Administrator.*

The sole purpose of this SMTP Server is to receive mail on behalf of Smartware Studio. It should be explicitly configured not to forward or relay mail to reduce the chance that any malware could use it maliciously.

The general steps are:

- On your DNS server, create an A record for the sub-domain (e.g., *studio.yourcompany.com*) and point it to that IP address.
- Install the SMTP Server software. The example that follows uses Windows IIS, but other SMTP servers should work as well.
- Configure the SMTP Server to recognize your sub-domain.
- Configure the SMTP relays to only allow mail from the SMTP server itself.

Some examples follow in the next sub-sections.

*Example: Creating a DNS Record for Subdomain in Windows Server*

Example: Installing an IIS SMTP Server – Windows Server 2008 R2

To begin the installation of an IIS SMTP Server:

- From the START menu, choose RUN, enter “servermanager.msc” in the OPEN dialogue box and click OK.
- Right-click on FEATURES and click ADD FEATURE.

- Use the ADD FEATURES WIZARD to select SMTP Server on the SELECT FEATURES Page
• You may see a dialogue box like the one below stating that certain role services and features are required for SMTP:

![Add Features Wizard](image1)

• Click **ADD REQUIRED ROLE SERVICES** and you will return to the previous section; click **NEXT**.

• In the **WEB SERVER (IIS)** section, click **NEXT** to proceed to the **ROLE SERVICES** section:

![Add Features Wizard](image2)
• The ROLE SERVICES should be pre-populated – IIS 6 Management Compatibility should be selected, and below it, IIS 6 Metabase Compatibility and IIS 6 Management Console should also be checked. Click NEXT to continue:

![Select Role Services](image)

• In the CONFIRMATION section, click INSTALL.
• In the RESULTS section, click CLOSE to complete the installation.

**Example: Configuring an IIS SMTP Server – Windows Server 2008 R2**

To configure the IIS SMTP Server:

• From the START menu, choose RUN, enter “inetmgr6” in the OPEN dialogue box and click OK.
• Expand the item for the Computer in the tree
• Expand the item for the SMTP Server in tree
• Click on DOMAINS
• In the domain name list, right click and choose RENAME to rename the domain to match your email sub-domain (e.g. studio.yourcompany.com)
To prevent this server from relaying spam, you will need to turn off relay and only allow it for the SMTP Server.

- Right-click on SMTP VIRTUAL SERVER and select PROPERTIES

- Go to the ACCESS tab and click the RELAY button.
On the *Relay Restrictions* dialog:

- Ensure that the **ONLY THE LIST BELOW** radio button is checked.
- Click the **ADD** button and enter in the IP address localhost, (127.0.0.1); click **OK**. This will only permit the server itself to relay mail.
13. Enterprise Management and Reports

This chapter discusses a set of reports that incorporate data from multiple projects across your server, as well as features designed to managing multiple servers in an Enterprise environment.

- While we refer to the reports described here as Enterprise Reports, even a single-server organization can run them. Other features, such as Remote Login, will only apply to true multi-server enterprise configurations.

Enterprise Reports

To run administrative reports for your single server or Enterprise environment, select the ADMIN→ ENTERPRISE MANAGEMENT AND REPORTS menu command.

- From here you can select and run one or more reports representing data across the server and its projects.
- For Enterprise environments, you can select some or all of the servers to query. The resulting report will include data merged from those servers.
- These reports are stored in your \ApplicationData\Reports\Enterprise folder.
  - Click the OPEN REPORT TEMPLATE FOLDER link to view the folder’s contents.
- You can copy these templates and customize the copies to make your own reports. Refer to Smartware Studio - Reporting Guide for more detail.

**The Project Statistics Report**

The Project Statistics report requires that additional information be gathered from projects. Before running this report, click the SCAN NODES button to update this data. Depending on the number of projects, this may take some time.

This report includes:

- For Estimates, the *Contract Amount* and *Gross Margin* (as percent and dollars).
- For Designer nodes, the number of Designer Visio drawing files and the child node count.

On occasion, as noted in the *Release Notes*, new calculated fields may be added to the report. In those cases, if you have previously scanned nodes you will want to click the CLEAR LAST SCAN DATE button before doing the next scan of nodes to rescan all projects and get the new information.

**Point Statistics**

Point Statistics files are a special case where the report named *Point Statistics* is run for a Designer or Estimate Project and named with the phrase ‘Point Statistics’ in the file name. These reports have a specific format that include counts of engineering points by point type, which can be scanned separately into the Project Statistics data.

- You must run and save the Point Statistics report in each Designer or Estimate project for which you want these statistics.
- The format of the report should not be changed after it is generated, though you can fill in additional values manually into the existing format.
- The file must be named as described above.

If you are using these Point Statistics files, you can click the SCAN POINT STATS FILES button after you run the SCAN NODES button to update the Point Statistics.
**Designer Drawings using MFLs**

The *Designer Drawings using MFLs* report helps you locate Designer drawings that are copied from or based on system drawings contained in a Multi-File Library.

In some cases, there may be file names that you use for testing or otherwise want to be ignored in these reports. You can provide a list of file names to ignore by clicking the *FILES TO IGNORE* button:

- You can use the * and ? wildcard characters (e.g., `VAV*.vsd`)

**Configuring a Multi-Server Enterprise**

In most cases, an organization will have a single server to store all their projects. In larger organizations, especially those where offices are geographically separated, it may be useful to have multiple independent servers, each with their own configurations and sets of projects. In these cases, it is possible to associate these servers as an *Enterprise* or *Account Family* and manage them as a whole.

- An Account Family must be created in the Smartware License database by our support team. Please contact us to discuss the pros and cons of specific configurations and how to set them up.

**Account Family Administrators**

One or more users in your company must be designated as an Account Family Administrator. These people will have administrative access to each server, as well as to the shared Enterprise configuration.
• Account Family Administrators must be set up by our support team.

**Remote Users**
Each user is associated with a single home server, but it is likely that some of them will need to access other servers in the Enterprise. Each user that needs to access a specific server will need to be registered as a Remote User of that server.

• An administrator of a server can give remote access to any other user on another server, as well as remote access to a server in a different enterprise account family.
• To give a user remote access to multiple servers, they will need to be added as a Remote User to each of those servers individually.

To register a Remote User, go the Account Manager on that server (ADMIN → USERS AND LICENSES).

• There will be an additional tab for Remote Users, showing any users currently configured as Remote Users.
• Click ADD REMOTE USER to select a user from any of the other servers in the Account Family and make them a Remote User of this server.
• Alternatively, you can also add a user to multiple remote servers and user groups at the same time by right-clicking on a user within the USERS tab and selecting CHANGE REMOTE ACCESS.
• Refer to the section *Adding and Managing Users* in the earlier chapter *Administering Smartware Studio* for more details on the Account Manager.
**Remote Login**

Once configured as a Remote User, a user can log into a remote server by selecting **File → Remote Login**:

- When you log into a remote server, a new instance of Smartware Studio will open and point to that server. You will only see the projects and files for that server.
- Certain configuration tools are not available when remotely logged in.
- You must have appropriate connectivity to the remote server’s file and SQL servers before you do the remote login. This may entail establishing a VPN connection.

**Enterprise Features**

There are a number of features specific to an Enterprise configuration. Most deal with distributing resource and configurations files from a central location (the *Enterprise Distribution Folder*) to each of the servers in the Enterprise, thus keeping them in sync and avoiding the need to update each server individually.

- For more details about distributing templates and files, refer to the next chapter, *Libraries, Templates and Distributions*.

**The Enterprise Distribution Folder**

This folder should be located on a server that is accessible by the Family Administrator, as it is where files are copied from when these tools are used by the Admin.

- You will need to provide the path of this folder to our support team to enter into our account database.
This folder can contain a number of sub-folders, most of which mimic the structure of the Resources folder on each of the individual server’s Shared Folders. These folders can include:

- Custom Templates
- Databases
- DS Stencils
- Estimating/Estimate Models
- My Documents
- Part Packages
- Reports/Design
- Reports/Estimate
- Reports/Enterprise
- Schedule Templates
- System Library

**Distributing Enterprise Files**

To distribute the Enterprise files to one or more servers, go to the *File Distribution* tab:

- Click **OPEN DISTRIBUTION FOLDER** to access the folder in Windows Explorer to create the various sub-folders and copy in the files to distribute.
- When you click the **COPY FILES** button, the files in the Enterprise Distribution folder will be copied to the corresponding Resources folder on the selected servers.
- Details about the copying can be viewed on the **Output Log** tab.
- Refer to the next chapter, *Libraries, Templates and Distributions*, for more details about how files are distributed and how to recall old files.
Other Enterprise Features

As described in the next chapter, some of the special distributions and customizations allow for a specific Enterprise version to be created that is merged with any server-specific customizations. These features include:

- Enterprise Custom Templates Menu (*Enterprise Custom Templates.xml*)
- Enterprise Designer Shape Dictionary (*Enterprise DS Shape Dictionary.xls*)
- Enterprise ‘My Documents’
14. Libraries, Templates and Distributions

This chapter discusses some of the features that allow you to incorporate custom templates and libraries into the Studio environment to be used by the various modules.

The Resource Folders

Most of the features covered in this chapter refer to the Resource Folders on the users’ workstations and your file server.

The Resource Folder Locations

For most workstations, the user’s Resources are stored in:

C:\ProgramData\Smartware Studio\

For the server, the Resources folder is:

\OurServer\Smartware Studio\Resources\

This assumes that your server folder is \OurServer\Smartware Studio\

- You can access the Resource folder on a workstation from TOOLS→OPTIONS→LOCAL FILES

Adding Custom Resource Files

There are a few simple rules for customizing resource files:

- The resource folders contain files that are installed and updated with Smartware Studio.
  - You should not modify the files that Studio installs, as these files will be removed or overwritten during an updated install.
  - To customize a file, duplicate it in the folder and rename the copy to be your custom version.
- If users copy files into the folders on their workstation, only they will be able to use them.
- If an administrator copies files into the folders on the server, they will be copied to the corresponding folder on all users’ workstations when the Background Updater is next run on their machine.
Libraries, Templates and Distributions

- Refer to the later subsection on the **Background Updater** for more detail.

**The Resource Folders**
The following folders are used to hold specific resources:

/Custom Templates
- Can contain template files (Word, Excel, Visio, etc.) to be used with custom ‘New’ menu items
  - Refer to the section, **Customizing the ‘New’ Files Menu**, later in this chapter for more detail.
- Can contain files for controlling the Designer right-click add-shape menu:
  - **User DS Shape Dictionary.xls** and **Company DS Shape Dictionary.xls**
  - Refer to the **Designer Module User’s Guide** for more detail.

/Databases
- Contains **PzCache.mdb**, the caches version of the Parts database.

/Distributables
- Contains optional files distributed by Schneider Electric and downloaded by the Parts Database Manager.
- Refer to the later section on **Schneider Electric Distributables** for more detail.

/DS Stencils
- Can contain custom Visio stencil files (.vss) for use with Designer
  - These stencils will be copied in the users’ **My Documents\My Shapes** folder
  - Refer to the **Designer Module User’s Guide** for more detail.

/Estimate Models (Workstation)
- Can contain Estimate Model Template files (.EstModel)
- This folder is **/Estimating/Model Templates** on the Server
- Refer to the **Estimating Module User’s Guide** for more detail.

/My Documents (Server)
- Can contain folders or files that you want copied into all user’s My Documents folders/
  - Refer to the later subsection, **My Documents Distributions**, in this chapter for more detail.

/Part Images
- Can contain custom image files for use in the Designer module shapes.
/Part Packages
- Can contain custom Part Package (.stpkg) files for use with the Estimate module.
- Refer to the earlier chapter on the Parts Database Manager for more detail.

/Reports/*
- Can contain custom reports for the various modules, stored in the corresponding sub-folders: Design, Estimate and Enterprise.
- Refer to the separate Smartware Studio Reporting Guide for more details.

/Schedule Templates
- Can contain custom Schedule Template files (.stsch)
- Contains corresponding schedule report templates that can be stored in like-named sub-folders (e.g., \Schedule Templates\Valve Schedule)

/System Library (Server)
- Can contain Multi-File Library (MFL) files (.zip)
- Can also contain older single-file library Designer module library drawings (.vsd)
- These files are copied to the __System Library folder in the user’s Local Files folder.
- You can access these folders from the Admin→Libraries, Templates and Standards tool
- Refer to the later section on Multi-File Libraries and the Designer Module User’s Guide for more detail.

Updating and Recalling Distributed Files
If you add a file to one of the Resource folders on the server, it will eventually be copied to the corresponding folder on each workstation.

- If you need to update the file, simply copy the updated version into the same folder on the server.
  - The new version must have a later timestamp to trigger the update on the workstations.
- If you want a file or folder deleted from all the workstations, you can create a recall.txt file in that folder.
  - Create a text file named recall.txt in any distribution folder on the server.
  - In this file, list the names of the older versions of files or folders (one per line) that were distributed that you want removed from the corresponding folder on each workstation.
**Designer Module Templates**

As described in the *Designer Module User’s Guide*, each user can create and specify custom versions of the various template documents (Blank Drawing, Table of Contents, etc.).

- Custom versions of the templates should be copied into the *Custom Templates* resource folder.
- To specify company-wide templates that users can or cannot override, select the **ADMIN**→**LIBRARIES, TEMPLATES AND STANDARDS** menu item and go to the *Template Files* tab.

**My Documents Distributions**

You can create a folder on your Company (and Enterprise) server that will distribute any types of folders and files to your end-users’ *My Documents* folders.

- This feature can be used for files that are unrelated to Studio itself, such as standard company forms.

To distribute files to the user’s My Documents folder:

- Copy the files and folders to be distributed to the *My Documents* resource folder on your Company Server.
  - You can access this folder easily from the **ADMIN**→**LIBRARIES, TEMPLATES AND STANDARDS** tool on the *Other Distributable Files* tab.
• For multi-server Enterprises, copy the files and folders to the Enterprise Folder’s *My Documents* folder.
  o You can access this folder easily from the **ADMIN**→**ENTERPRISE MANAGEMENT AND REPORTS** tool on the *File Distribution* tab.

• Users will *not* receive these files by default and *must opt-into* receiving them.
  o On the workstation, go to **TOOLS**→**CHECK FOR UPDATES** and click the **OPTIONS** button.
  o Check the box next to *Company ‘My Documents’ Files*.

• The files are downloaded as part of the Background Updater, which normally runs with the first launch of Studio each day.
  o The **TOOLS**→**CHECK FOR UPDATES** tool can force the download at any time.
  o The *Recall.txt* feature referenced earlier in this chapter is available to remove folders and files at both company and enterprise levels.

### Checking for Updates

All of the updating of resources and files on a workstation is handled by the Updater.

• To have a workstation check for and download any available updates, select **TOOLS**→**CHECK FOR UPDATES**.

![Smartware Studio Updates](image)

• When you open the form, the checks will start immediately. If any of the items require attention or interaction, their bullets will be yellow or red.
The Background Updater
In general, the first time Studio is launched during the day it will start up a separate instance to do these checks in the background.

- The Background Updater will show as an icon in the lower-right corner of the screen (in the Windows Notification area, sometimes called the System Tray). If you double-click or right-click on that icon, you can open the Updater window.
- More often than not, no action is required by the user.
- To change the options for when the Updater will automatically close or if you prefer it to show or hide notifications from the system tray:
  - Access the settings from TOOLS → CHECK FOR UPDATES → OPTIONS
  - Or from TOOLS → OPTIONS → LOCAL FILES → DOWNLOAD OPTIONS

To manually check for updates later in the day, simply select TOOLS → CHECK FOR UPDATES.
Download Options
The workstation can be configured to include or exclude certain downloads.

- To set the options, choose TOOLS→CHECK FOR UPDATES and click the OPTIONS button.

Multi-File Libraries
Multi-File Libraries (MFLs) are essentially zip files that contain a set of related documents, often for a single system such as an Air Handling Unit. These files might include Designer drawings, estimated system nodes, sequence documents, and graphic images.

- Refer to the chapter in the Smartware Studio User’s Guide for full information on creating and using MFLs.

Distributing MFLs
As described earlier, MFLs are stored in the System Library resource folder on the server and copied to the __System Library folder in the user’s Local Files folder.

To publish a library to all users in an organization:

- Get the MFL from the __System Library folder of the workstation on which it was created.
- Copy it to the Resources/System Library folder on the Server.
Each workstation can control which MFLs they receive by going to TOOLS→CHECK FOR UPDATES and clicking the OPTIONS button.

**Submitting and Approving User Created MFLs**

Users who create their own MFLs can submit them to be reviewed and approved by an administrator.

Users can create and edit the libraries from TOOLS→LIBRARIES→MANAGE MULTI-FILE LIBRARIES.

- They should right-click on the Library to submit and select SUBMIT LIBRARY FOR APPROVAL.
- This will copy the Library onto a temporary folder on the server (/SERVER FOLDER/Resources/Review/System Library).

Administrators can then go to the Parts Database (ADMIN→PARTS DATABASE) and select DATA TABLES→SYSTEM LIBRARIES FOR APPROVAL.

- This shows a list of all the libraries pending approval.
- The Administrator can view and edit the Library, its properties and its contained files.
- When the Library has been reviewed, the Administrator can right-click on the library and select APPROVE LIBRARY or REJECT LIBRARY.
- If approved, the library is copied into the Company's main Library folder, and it will be downloaded onto users' machines during the next update. If either approved or rejected, it is removed from the Review folder.

If you have configured the Studio Windows Service, Administrators can request to be notified when an MFL has been submitted for approval:

- These notifications can be enabled by going to ADMIN→PARTS DATABASE then selecting OPTIONS→OPTIONS.

**Schneider Electric MFLs**

Schneider Electric makes available to its partners a set of MFLs containing files for use with its product lines. These libraries can be downloaded onto your server for distribution to users as well. Refer to the next section, Schneider Electric Distributables, for more detail.
Schneider Electric Distributables

In addition to all the part data and product information PDFs, Schneider Electric has three types of additional resources that they make available to their partners:

- Multi-File Libraries
- Custom Designer Stencils
- Other Files

These files are distributed in two steps:

- The files are optionally downloaded to the Company server through the Parts Database Manager.
- Users can opt-in to having these files copied onto their workstations

**Downloading the Distributables to the Company Server**

To download the Schneider Distributables to your server:

- Open the Parts Database Manager by selecting **ADMIN ➔ PARTS DATABASE**.
  - If the dashboard doesn’t come up automatically, select **FILE ➔ DASHBOARD**.
- Go to the **Other Distributable Files** tab
- Click the arrow button to get the latest files
The files will be downloaded into sub-folders on the Company Server in the *Resources/Distributables* folder, specifically:

- *Resources/Distributables/SE/MFL*
- *Resources/Distributables/SE/Stencil*
- *Resources/Distributables/SE/Other*

These folders may contain other sub-folders. The structure of the folders will be recreated on the users’ workstations.

**Downloading the Distributables to a Workstation**

To opt-in to receiving these files on a workstation, go to **TOOLS → CHECK FOR UPDATES** and click the **OPTIONS** button:

- To receive Schneider MFLs and/or Designer stencils, check the appropriate boxes in the upper list.
- To receive one or more of the Other Installable Folders, check the boxes in the lower list.
The downloaded files will be copied to the following locations on the workstation:

- MFL files will be copied to the user’s `__System Library` folder in their Local Files folder.
- Stencil files will be copied the user’s `My Documents/My Shapes` folder, which is where Visio looks for custom stencils
- The Other files will be copied into sub-folders in the user’s `My Documents/Schneider Electric` folder.

The files in an Installable Folder are downloaded onto the server as a zip file but expanded into folders and files on the user’s workstation. A copy of the zip file is also kept on the user’s workstation and is used as a reference to compare to any updated versions to properly synchronize the folder.

### Customizing the ‘New’ Files Menu

The **New** menu is available when a user right-clicks on a folder or in the empty area of a folder’s **Files** tab. This menu contains a list of blank documents that you can insert into your project.

- The default list of blank template files will vary depending on the type of folder. For example, Microsoft Word documents can be inserted anywhere, but Designer Drawings can only be added to a Designer Systems folder.
You can add your own documents to this menu and can make this list available to all users.

- This process requires some manual file manipulation in Notepad or another text editor.

You will need to create a text file called *Custom Templates.xml* which lists the entries for the New menu. The format of this file should be similar to the following example (we suggest you cut and paste from here):

```xml
<?xml version="1.0" encoding="utf-8" ?>
<TemplateFiles>
  <TemplateFile>
    <Description>Our Letterhead</Description>
    <FileName>Acme Letterhead.doc</FileName>
    <DefaultFileName>New Letter.doc</DefaultFileName>
    <MenuPath>Form Letters</MenuPath>
    <MenuSection>Custom</MenuSection>
  </TemplateFile>
  <TemplateFile>
    <Description>Our Legend Page</Description>
    <FileName>Acme Legend.vsd</FileName>
    <DefaultFileName>Acme Legend.vsd</DefaultFileName>
    <MenuSection>Systems</MenuSection>
    <FileType>Designer Suite Drawing</FileType>
  </TemplateFile>
</TemplateFiles>
```

The file is essentially a list of `<TemplateFile>` records. For each one, you should specify:

- **Description**: What it says on the New menu
- **FileName**: The actual name of your template file
- **DefaultFileName**: The initial name that will be given to the file the user creates when they select it from the New menu.
- **MenuSection**: An indicator as to the section of the menu in which the file should be listed.

The following properties are optional:

- **MenuPath**: If specified, the item will appear as a sub-item on a pop-up menu, and MenuPath will be the text for the menu. You can create multiple levels of sub-menus by using a slash between levels (e.g., “Letters/Form Letters”)

Libraries, Templates and Distributions
**SeparatorBefore**  
If the value is “True”, it indicates that there should be a separator line in the menu before the entry. The separator will be on the last level of a multi-level menu.

**AddSeparator**  
You can also create an explicit separator outside of any of the defined templates. Create a `<TemplateFile>` record that includes only the `MenuPath` and `AddSeparator` properties, and a separator will be added to the menu tree after any existing menu items defined at that level:

```
<TemplateFile>
  <MenuPath>Our Menu/Forms</MenuPath>
  <AddSeparator>True</AddSeparator>
</TemplateFile>
```

**File Type**  
An indicator as to what the specific type of file is (mostly for Visio files, which can be more than one type)

**OnlyAllowOnNodeTypes**  
Specifies a comma-separated list of node types that should show this template file (and therefore not show it on all others). If this tag is omitted, the template is available for all node types.

```
<OnlyAllowOnNodeTypes>Folder, System</OnlyAllowOnNodeTypes>
```

**OnlyAllowOnNodesNamed**  
Specifies a comma-separated list of names for the nodes that should show this template (and therefore not show it on all others). Wildcard characters (* and ?) are allowed.

```
<OnlyAllowOnNodesNamed>Sales*</OnlyAllowOnNodesNamed>
```

**FillInProjectFields**  
If the value is “True”, it indicates that this document should be processed as a Mail Merge template. Refer to the next sub-section for more details.

**QualityRecord**  
If the value is “True”, it indicates that the copy of the file created in the folder should have the `QualityRecord` property set to true.

The valid values for `MenuSection` are:

- **Blanks**  
The same section as the default blank Word, Excel and Text documents
- **Custom**  
A separate section at the bottom of the menu
- **Systems**  
The same section as Designer Drawings (and only shown when in a Designer Systems Folder)
**Schedules** The same section as Designer Schedules (and only shown when in a Designer Schedules Folder)

The *FileType* is only needed for Designer-specific file types, and can be: *Designer Suite Drawing, Designer Suite Valve Schedule, Designer Suite Air Flow Schedule*, etc.

The *Custom Templates.xml* file and the template files should be stored in the *Custom Templates* resource folder on the workstation (and server, to distribute to all users).

- Refer to the **TOOLS**→**OPTIONS** Template Files tab and the **ADMIN**→**LIBRARIES, TEMPLATES AND STANDARDS** Template Files tab for more detail on these folder locations

**Mail Merge Documents**

By default, when the user selects an item from the menu Studio makes a copy of the template file and puts it into the selected folder. For Word and Excel files, menu items can also indicate that the template contains *Field Code Tags* that should be replaced with the appropriate values from the current project.

To indicate that a template should be processed, include the following in its entry:

```xml
<FillInProjectFields>True</FillInProjectFields>
```

- The entry `<ProcessTemplate>` can also be used to mean the same thing.

The Field Code Tags can be placed almost anywhere in a Word document or any cell in the Excel worksheet, and should be of the form `<PropertyName>`, as in `<ProjectName>` or `<ProjectNumber>`.

- In Excel files, tags are only found if they are the only value in a cell.
- The list of *PropertyName* values correspond to the properties shown on the Properties tab of the first *Project Root Node* (Customer Site, Job Folder, Estimate or Designer Project) encountered when going up the project tree from the selected folder.
  - You can view the actual property names by selecting **VIEW**→**PROPERTY NAMES**, which will show them in brackets on the Properties tab.
- For generated Word documents, the user will have an option to **UPDATE VALUES IN REPORT** when they right-click on the file.
**Designer and Estimate Reports**

Another option for the NEW menu is to create entries that run reports for the current (or other) Estimate or Designer project. This essentially becomes a shortcut for running the reports on the corresponding Reports tab of that project.

To make the entry run reports (instead of copying a template file), include the `<RunReport>` element with a value of “True”, then include any of the options shown in the example:

```xml
<TemplateFile>
  <Description>Reports-All Projects and Reports</Description>
  <MenuPath>My Reports Menu</MenuPath>
  <MenuSection>Custom</MenuSection>

  <RunReport>True</RunReport>

  <EstimateReports>All</EstimateReports>
  <DesignerReports>All</DesignerReports>
  <ShowAllProjectsOnMenu>True</ShowAllProjectsOnMenu>
  <ShowReportListOnMenu>True</ShowReportListOnMenu>
  <ShowReportSelector>True</ShowReportSelector>
  <SaveAsDocument>True</SaveAsDocument>
  <SaveAsPdf>True</SaveAsPdf>
</TemplateFile>
```

- The `Description`, `MenuPath` and `MenuSection` elements work the same as with Template files.
- The `EstimateReports`, `DesignerReports`, and `EstimateGroupReports` elements can be “ALL” or the name of one or more reports, separated by semi-colons

```xml
<EstimateReports>Estimate Summary.xls</EstimateReports>
```

- If `ShowAllProjectsOnMenu` is “True”, the menu will contain a separate sub-menu item for each Designer and/or Estimate node in the main project. If it’s “False” or left out, the menu item will only show up if the selected node is part of a Designer and/or Estimate project.
- If `ShowReportListOnMenu` is “True”, the menu (or each project sub-menu item) will contain a separate sub-menu item for each available report (based on the `EstimateReports`, `DesignerReports`, `EstimateGroupReports` settings. If `ShowReportListOnMenu` is “False” or left out, selecting the menu item (or the project sub-menu item) will run all the specified reports.
- If `ShowReportSelector` is “True”, an additional menu item will be added to the top of the report list sub-menu that brings up a form that allows the user to select any of the appropriate reports to run.
- If `SaveAsDocument` is “True”, the file will be saved as an Excel or Word document.
- If `SaveAsPdf` is “True”, the file will be converted to and saved as a PDF file.
**Enterprise Version of the ‘New’ Menu**

In addition to the *Custom Templates.xml* file, entries can also be stored in a separate file called *Enterprise Custom Templates.xml*. The format for the two files is the same, and the entries are merged together into a single menu.

- This can also be used to create a Company version for distribution while allowing users to create their own version of *Custom Templates.xml*.
- Refer to the previous chapter on *Enterprise Management and Reports* for details on the Enterprise folder.
15. Cloud Accounts

Studio allows you to use certain cloud-based storage systems to act as an intermediary for sharing files with users outside of the Studio environment.

- This feature requires the creation of accounts on third party services. *Smartware does not specifically endorse the use of these services and makes no warranty as to their effectiveness or security.*

Currently the only Cloud Service for which a driver has been created is *Box*. Others may be available in the future.

How Studio Integrates with a Cloud Account

The basic structure is:

- A distinct cloud account is created to act as the interface between other accounts and Studio.
- Certain credentials and access keys are created on the cloud account side and entered into Studio in the **ADMIN → CLOUD ACCOUNTS** tool.
- The *Studio Windows Service* is configured with information on how to email invitations to users, when necessary.
- The users can right-click on a folder or file and select **SHARE WITH → BOX** (or whatever the cloud account is named).
  - They will have an option to invite other users to share the file or folder.
- The Studio Windows Service will copy the file or files to the cloud account and send out the invitations.
- The Studio Windows Service will then continue to poll both the Studio database and the cloud account periodically looking for changes to any shared files or folders. As changes are found, files are copied in either direction to keep them synchronized.

For more detail, please contact our technical support team.
Configuring a Box Cloud Account

The steps to using Box include:

- Create and configure a new Box account to use as the "backbone" of the synchronization. Files will be copied there from Studio and shared to other Box users.
- Enter the Box Account in Studio's Cloud Account list.
- Configure the Studio Windows Service to process the Cloud Account synchronizations.

**Note:** Some of these Setup steps require that you be running Smartware Studio as an Administrator. Even if you are a local administrator, you may not be running with full privileges, so you should launch Smartware Studio by right-clicking on the icon and selecting **RUN AS ADMINISTRATOR.**

Setup and Configure a Box Developer Account

You will start by creating a free Box Developer Account, then configure it for access by Smartware Studio. These directions are correct as of the time of this writing but could change if the Box web site is updated over time.

- Go to [http://developers.box.com](http://developers.box.com), click the **SIGN UP** link, and enter the necessary information to create an account.
- Once logged in, click the **CREATE NEW APP** button.
- Choose the **ENTERPRISE INTEGRATION** option, and then click **NEXT**.
- Select **STANDARD OAUTH 2.0 (USER AUTHENTICATION)** and click **NEXT**.
- Specify a Name for your App, and click **CREATE APP**.
- On the next screen, click **VIEW YOUR APP**.

This should bring up the **Configuration** page.

- Scroll to the section labeled **OAUTH 2.0 REDIRECT URI**
- Enter the following as the URI: `http://localhost:12520/ProcessBoxResult`
- **Click SAVE CHANGES.**
Register the Box Account with Smartware Studio

**Note**: This next feature requires that you be running Smartware Studio as an Administrator. Even if you are a local administrator, you may not be running with full privileges, so you should launch Smartware Studio by right-clicking on the icon and selecting **Run as Administrator**.

To register the Box Account:

- Go to **Admin → Cloud Accounts**, which will bring up the Cloud Accounts list.

- Click the **Add Account** button. This will bring up the following form:

  - **Account Name** can be whatever you would like to call the Box account.
  - **Support Email** is the email address used to create the Box account.
Cloud Accounts

- *Client ID* and *Client Secret* are two long alphanumeric values that are displayed on the Configuration of the Box web site under the OAuth2.0 Credentials.

When you click Save, Studio will attempt to authorize the Box account:

\[\text{Authorize Cloud Account}\]

By clicking on the OK button an authorization message will be sent to your Box account. The response from Box will be displayed below. A successful message is required for you to begin sharing files on Box. You must be running Studio as an Administrator to Authorize the Box Account.
• Click OK and a browser window will pop up asking you for the Box account login information.

![Box login window]

• Enter the Box Account credentials and click Authorize.
• On the next screen, click Grant Access to Box.

![Box authentication success]

**Studio has successfully been linked with your Box account**
You should see a web page that says Studio has successfully been linked with your Box account. When you close the page, you should see a message similar to this one:

![Authorize Cloud Account](image)

**Configuring the Cloud Account Service**

The Studio Windows Service monitors the Box Account and the Smartware Studio database, copying files back and forth as needed to keep them in sync.

- You will need to have the Studio service installed and running. For more information, refer to *Chapter 12, The Studio Windows Service*, earlier in this Guide.
- These steps require restarting the Windows Service, so you should run Studio from the machine where the Windows Service is running.
To configure the Cloud Account in the Windows Service:

- Go to **ADMIN→WINDOWS SERVICE** and go to the *Cloud Accounts* tab.

- Select the Server (or Servers) that you want the cloud service to monitor.

- In the Invitations section, enter the information for when users are invited to share a file or folder:
  - The *Send Invitation From* should be a valid email address to use in the *From* field of the invitation email.

- You can set how often the service will check for changes. It is recommended that you do it no more often than every 15 minutes or longer, as changes to files on box are unlikely to occur that frequently and Box places limitations on the number of times the service can contact their site through the API per day.
  - You can adjust this value as necessary in the future. If you do, you must restart the Studio Windows Service for it to take effect.
To save your changes and start the polling:

- Click the APPLY button to save the changes to the settings.
- Go to the Service Control tab and click the Restart button to restart the service.

**Sharing Files with a Cloud Account through Studio**

Once the Cloud Account is set up and configured, users will be able to initiate the sharing of a file or folder.

To initiate the sharing:

- Right click on a file or folder and select:
  
  **SHARE WITH**→**[BOX]: [APPLICATION NAME]**
  
  o **BOX** and **APPLICATION NAME** will vary depending on the Cloud Services you’ve setup.

- You can specify an automatic *Expiration Date* for the share. On that date the shared file will be removed from the backbone account. The file on the Studio server will not be removed or modified in any way.

You can choose to invite someone else to share the file or folder:

- Click **INVITE STUDIO USER** to choose from any of the users in the system, including remote users.
- Click **INVITE OUTSIDE USER** to specify a non-user’s email address. They will need to create a personal account on Box.com in order to do so.
Cloud Account Reports

You can generate an administrative report of all the files and folders being shared through Cloud Accounts.

- Select **ADMIN ➔ ENTERPRISE MANAGEMENT AND REPORTS**.
- Check the **Cloud Account Shares** report.
- Click **RUN SELECTED REPORTS**.
16. Smartware Studio Mobile Application

The Smartware Studio Mobile Application ("Studio Mobile") enables users to access Smartware Studio Projects and Files from their mobile devices.

- The App is available for iOS and Android devices
- It can be downloaded at no cost from the App and Play stores, but it must be separately licensed (for a small monthly license fee).
- At this time, files can only be viewed on the device.
  - In the future, it may be possible to edit files downloaded from Studio using a Cloud Service such as Box.
  - Depending on the type of file, another mobile app may be required to view the file.

Since Studio Mobile must communicate with the database and file system on your network, additional configuration must be performed before any users can utilize the app.

- The Studio Windows Service, detailed in Chapter 12 of this Guide, is used to communicate with the devices outside your network and transmits the project information and files to the device.
- Since the device must communicate with the server, you will likely need to open a port in your firewall to allow this traffic.
- You will also need to create a sub-domain A record to point to the IP address of the machine running the Studio Windows Service. This is a specific security requirement of iOS and Android.

The next sections describe these steps in more detail

**Note:** These Setup steps require that you be running Smartware Studio as an Administrator. Even if you are a local administrator, you may not be running with full privileges, so you should launch Smartware Studio by right-clicking on the icon and selecting RUN AS ADMINISTRATOR.

### Configuring the Studio Web Service

To configure the Studio Web Service for the Mobile Application:

1. If you haven't done so already, install and start the Studio Windows Service on your server, as detailed in [Chapter 11: The Studio Windows Service](#), of this Guide.
2. Create a sub-domain A record and point it to the IP address of the machine running the Studio Windows Service.
   - An example might be studiomboile.ourcompany.com
   - This record must be public and private.

3. Select **ADMIN ➔ WINDOWS SERVICE** to open the Windows Service Configuration tool.

4. Go to the **Web Service** tab

   ![Windows Service Configuration]

   - In the **Mobile Web Service IP Address** field, enter the IP address of the machine running the Windows Service, or the DNS name that points to it.
     - To use the iOS version of the App, you must use a DNS name. This is an iOS security requirement.
   - In the **Mobile Web Service Port** field, enter the port you want to use.
     - The choice of port is arbitrary, as long as it's not already in use on the machine.
     - We recommend avoiding ports that are associated with other common applications (e.g., 80, 25, 1433). We've chosen 22211 as a default.
   - You can generally leave the **Mobile Web Service Root** field empty.
     - It can be used to specify a root path for the Web Service. For example, if the value was **NewRoot**, then the URL for the Web Service would be studiomobile.ourcompany.com:22211/NewRoot

5. Go to the **Mobile App** tab and check the server (or servers) which should be reachable from the Mobile App.

6. From the **Service Control** tab, APPLY your changes and RESTART the Service.
**Testing the Connection**
At this point you can (optionally) do a quick check to make sure the Windows Service is responding on the port.

- Open a Command Prompt (type CMD in the Windows search bar) and enter the following command:

  \`netstat -ano | findstr <Port Number>\`

- In our example, that would be:

  \`netstat -ano | findstr 22211\`

If the service is running properly, you should see one or two lines like this:

![Command Prompt](image.png)

**Creating a Self-Signed SSL Certificate**
The mobile platforms require that communications be secure, on an https connection to a named address with an SSL certificate.

- The rest of this section discusses how to create and install a self-signed SSL certificate, which has no cost and requires no outside authentication agency.
- If you have other certificates and know how to install them, you should be able to use those instead.

**Starting IIS**
Start by opening IIS:

- For Windows Server 2008 and higher, Go to *Server Manager* and start the *Internet Information Services (IIS) Manager*.
- For Windows 10, type 'IIS' into the search bar and see if it finds *Internet Information Services (IIS) Manager*.
  - If not, search for 'Programs' or open the Control Panel and get to the *Programs and Features* tool.
  - Click the link for *TURN WINDOWS FEATURES ON OR OFF*. 
Cloud Accounts

- Check the IIS MANAGEMENT CONSOLE checkbox in the folders for
  Internet Information Services / Web Management Tools / IIS Management
  Console

Generating the Certificate
To generate the Self-Signed Certificate in IIS:

1. Under Connections in the left tab, select the server.

2. Double-click on the Server Certificates icon in the center.
3. On the right side, click *Create Self-Signed Certificate.*

   - For the *Friendly Name,* you can enter *'Studio Mobile Certificate',* or any identifying name you wish.
   - For the *Certificate Store,* select *Personal*
   - Click OK to create the certificate

4. Double click the Certificate you just created to bring up its properties.
5. Select the *Details* tab.

6. Select the *Thumbprint* property, then highlight the value in the lower box (the full set of pairs of hexadecimal digits) and copy it to the clipboard.
7. From Smartware Studio, go to ADMIN→WINDOWS SERVER and select the Web Service tab.

8. In the section labeled Creating a Self-Signed Certificate in IIS, paste the CERTIFICATE THUMBPRINT value into the textbox. The COMMAND LINE TO RUN box will be filled in. Click Copy to Clipboard to grab the entire command line.

9. If it’s running, stop the Studio Windows Service.

10. Launch a Windows Command Prompt (and RUN AS ADMINISTRATOR), and paste the command line into it and run it.

11. Restart the Studio Windows Service.

12. If everything is correct, you should see a message stating that the SSL certificate was added successfully

Certificate Generation Problems
Here are some known troubleshooting steps.

Error 1312
SSL Certificate add failed, Error: 1312
A specified logon session does not exist. It may already have been terminated.

This might be because the certificate is in the Web Hosting store, instead of the Personal store.

- Create another self-signed certificate and use the thumbprint of the new one to try again.
Install the Notifications Certificate

For Mobile App Notifications to work on iOS devices, another SSL certificate needs to be installed on the server. This certificate is included in the Studio install files. It is valid for one year and will need to be updated (from a later version of Studio) before it expires.

Installing the Certificate

1. Open up the Microsoft Management Console by either (a) clicking START→RUN and typing `mmc.exe`; (b) right-clicking Start, selecting RUN, and typing `mmc.exe`; or (c) by opening up a Command Prompt and typing `mmc.exe`.

2. Select FILE→ADD/REMOVE SNAP-IN

3. Select Certificates, then click ADD
4. Select *Computer Account*, then click NEXT.

![Certificate Import Wizard](image)

5. Select *Local Computer*, then click FINISH. Click OK on the *Add or Remove Snap-ins* window.

6. Expand the *Certificates* node, then expand *Personal*, and click on the *Certificates* folder underneath.

7. Right click the *Certificates* folder, select *All Tasks*, then click IMPORT to start the Certificate Import Wizard.
8. Click NEXT to start the import.

9. Click the BROWSE button and navigate to [Program Files x86]\Smartware Studio\Service\Certificates\APNSWSM_Production.p12, then click NEXT.

10. Enter the password **SwMOBILE5562** (case sensitive) and click NEXT.
11. Select *Place all certificates in the following store*, then select the *Personal* certificate store. Then click NEXT.

![Certificate Import Wizard](image)

12. Click **FINISH**.

13. Open a Command Prompt (in Admin mode) and type the following:

```bash
netsh http add sslcert ipport=0.0.0.0:2195
certhash="0bea4d0e42d39b98cafdbfd72b18e3234fc3377b"
appid="{1f7a21a9-7e30-4b61-a013-0f7f97955fc6}" and hit ENTER. You should see a message stating “SSL certificate added successfully.
```

14. In the same command prompt, type the following:

```bash
netsh http add sslcert ipport=0.0.0.0:2196
certhash="0bea4d0e42d39b98cafdbfd72b18e3234fc3377b"
appid="{1f7a21a9-7e30-4b61-a013-0f7f97955fc6}" and hit ENTER. You should see a message stating “SSL certificate added successfully.
```
Open the Ports in the Firewall

Since the mobile devices will be contacting the Windows Service via http on the specified port, any firewall devices between the machine running the Service and the outside must be configured to allow traffic in both directions.

- You should contact your IT professional or department before making any changes.
- There may be more than one firewall device or system in place that needs to be configured.
- The ports that need to be open are as follows:
  - The Web Service port you have chosen above; in this example, 22211
  - 2195, 2196, 5223 for Apple’s APNS servers for notifications
  - 5228, 5229, 5230 for Google’s GCM servers for notifications

Configuring Windows Firewall

If Windows Firewall is running, you can create the rules to open the port for traffic in both directions.

1. From the Windows Control Panel, search for or find the Windows Firewall settings (in the System and Security group).

2. Click the link for Advanced Settings.
3. In the left panel, select Inbound Rules.
4. In the right panel, click *New Rule*…

5. Select the *Port* option, and click *NEXT*.

6. Leave the TCP/UDP option set on *TCP*. Enter the Port Number of the Web Service in the *SPECIFIC LOCAL PORTS* list.
7. Click NEXT.

8. Choose the *Allow the connection* option. Click NEXT.

9. Apply the rules to DOMAIN, PRIVATE and PUBLIC, unless otherwise necessary.
10. Click **Next**.

![New Inbound Rule Wizard](image)

11. Enter a Name for the rule and click **Finish**.

12. Repeat Steps 3-11 to create a similar Outbound Rule.

**Testing Communication through the Firewall**

Once the firewall, Web Service and DNS record are configured, you can do a quick test from another machine on the network.

- Open a Command Prompt (type CMD in the Windows search bar) and enter the following command:

  ```
telnet <DNS> <Port Number>
  ```

- In our example, that would be:

  ```
telnet studiomboile.ourcompany.com 22211
  ```

- If it goes to a black screen, the service is configured properly and responding. If the command hangs, then there is a communication issue with the server.
  - If there is a communication issue, contact your IT department or reach out to our technical support team.
Installing and Configuring the Mobile Application

Each device that uses the Mobile Application must be licensed, in a manner similar to the Studio desktop.

- Contact Smartware Technologies to purchase licenses for the Mobile Application
- Existing desktop licenses should not be used to license Mobile Devices. Those licenses will not enable any of the Mobile Application features.

Permitting the Mobile Applications

While each device must be licensed for each mobile application feature (Projects and Schedule), the server must also be configured to globally enable them as well.

- Select **ADMIN → PERMISSIONS**

  ![Permissions Management](image)

- Check the boxes for the appropriate Mobile Applications to enable.
Installing and Configuring the Mobile App on a Mobile Device

The Smartware Studio Mobile Application is available for download from the iOS App Store or the Google Play store.

The first time the Mobile App is launched, the user will need to go into the Settings page (available from the Login Page) to point to your server.

- Fill in the Address and Port fields with the values configured in the Studio Windows Service on the Web Server tab.
- Your company’s Customer Account Number can be found as the first five digits of your License Account Number, as shown in the File→Produce License Registration screen.
Licensing the Mobile Application
You will then need to license the application on the Mobile Device.

From the Settings Page, select the Licensing tab.

- Enter the Email Address and Password of the User, as well as the 9-digit Passcode for the license account, click Register License.

The Mobile Applications
There are currently two features of the Mobile Application, each of which is licensed separately.

Projects (Studio Mobile Core)
The Studio Mobile Core, also known as Projects, lets you browse the list of Studio Projects and their folders.

- You can download and view many standard types of files (depending on the availability of a compatible Mobile Application)
- You can view the properties of the nodes in the Project.
Schedule

If you are using the Management Module to maintain a calendar of Service appointments, Mobile App users can view their schedule using the Service application.

- Refer to the Management Module Guide for more information.